Embed question atto button

Atto ::: atto_embedquestion
Maintained by Tim at Lone Pine Koala SanctuaryTim Hunt, John Beedell, at the OU (Perry building)Mahmoud Kassaei
An Atto editor plugin for use with the embed questions filter.
Latest release:
715 sites
236 downloads
26 fans
Current versions available: 3

This Atto editor plugin makes it much easier to use the embed questions filter.

Therefore, all the documentation is with the filter plugin.

Sets

This plugin is part of set Embed questions.

Screenshots

Screenshot #0

Contributors

Tim at Lone Pine Koala Sanctuary
Tim Hunt (Lead maintainer)
John Beedell: Developer
at the OU (Perry building)
Mahmoud Kassaei: Developer
Chris Nelson: Product owner
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Fri, Jun 28, 2019, 1:28 AM
    @Kieran: thanks, good to know your version. In that case, that blog post should be perfect for you, as it was written when we were on Moodle 3.5 as well! Basically the big difference is that pre-Moodle 3.6, you use "ID:zzz" in the website category title and the question title, where "zzz" is your preferred ID. I tend to use "embeddable" as the website category ID (I keep all the embeddable questions together), and then a question ID that makes sense, like "CourseWeek##Activity##". This results in a question ID something like "k101w15act22" (K101 being an example course, week 15, activity 22.
  • Thu, Jul 4, 2019, 6:52 PM
    @Chris: Thanks for that. Its working great now. Cheers smile
  • Mon, Jul 22, 2019, 2:55 AM
    Hi all, in response to interest here and through other channels, I've written a new blog post (will try and get them added to this page):
    https://medium.com/@GoTeamOU/embeddable-moodle-quiz-questions-one-year-on-d076ff22d6e6
  • Wed, Jul 24, 2019, 9:08 PM
    Thanks so much for that write-up Chris.
    >>"Once we are back from our July holidays, we’ll check the latest code against Moodle 3.7 and share the new version of the plugin with the community."
    A question not covered by the FAQ: When are you back from your July holidays? smile
    (I want to know when I can get my hands on it!)
  • Thu, Jul 25, 2019, 2:37 PM
    End of July wink
    We don't know the amount of effort required for checking Moodle 3.7 and any additional work required yet, so it's difficult to know for sure how long it'll take. I am personally hoping we can share the latest version by mid-August.
    For v2.0 (the version that records student responses), we'll try to share that update with the community much quicker!
  • Mon, Nov 11, 2019, 1:23 AM
    thanks its working
  • Fri, Sep 25, 2020, 11:26 PM
    I installed both filter and plugin, i added the button to Atto when I edit the course and press on the button nothing react mean there no tab appearing
  • Fri, Sep 25, 2020, 11:38 PM
    Hi @Rachid,
    Which Moodle version are you using?
    Also, have you created at least one question with a 'question embed ID' within a category that has an 'embed category ID' on the same course (in order to have a question to embed)?
  • Sat, Sep 26, 2020, 5:04 AM
    thanks for your reply, please note that I use Moodle latest version 3.9 when I click on the tab it doesn't show any things and resulting an error in the debug console :
    require.min.js:5 Uncaught Error: No define call for atto_embedquestion/dialogue_manager
    http://requirejs.org/docs/errors.html#nodefine
    at makeError (require.min.js:5)
    at Object.completeLoad (require.min.js:5)
    at HTMLScriptElement.onScriptLoad (require.min.js:5)
  • Tim at Lone Pine Koala Sanctuary
    Thu, Oct 1, 2020, 9:09 PM
    That is strange. I am running the latest version of this plugin with Moodle 3.9.2 and it works fine.
  • Sat, Oct 10, 2020, 2:12 AM
    Still no fix? I managed to embed question using /filter/ manually but the atto button still not operational as when I click on it with atto no reaction at all.
    Thanks for your support
  • Tim at Lone Pine Koala Sanctuary
    Mon, Oct 12, 2020, 6:44 PM
    There is nothing for us to fix. The problem is almost certainly something specific to your server. The plugin works for us. It works when the automated tests are run (https://travis-ci.com/github/moodleou/moodle-atto_embedquestion) and 400+ other people have the plugin installed and are not reporting problems.

    Only you can investigate why it is not working on your server.
  • Wed, Sep 1, 2021, 4:38 PM
    Hi @Galit. You need to ensure both the question and the course category have IDs. Please see the documentation at https://github.com/moodleou/moodle-filter_embedquestion/blob/main/internaldoc/functionality.txt

    Hope that helps,

    Chris.
  • Wed, Sep 22, 2021, 1:54 AM
    Hi, why am I getting a "This question may not be embedded here" message on the Page please? Will be grateful for any help.
    Thank you
    Isaac
  • Wed, Sep 22, 2021, 5:10 PM
    Hi @Isaac.

    I'm afraid I'm not able to replicate this problem on our test server, where I was able to embed various questions on a Page.
1 2
Please login to post comments