Installing and upgrading help

Coding error detected, it must be fixed by a programmer: get_referer() can not be used any more. Please use get_local_referer() instead

 
Picture of Andy Hill
Coding error detected, it must be fixed by a programmer: get_referer() can not be used any more. Please use get_local_referer() instead
 

Hi Guys

Just upgraded to the latest version of moodle and everything seems fine but every-time i goto administration>plugins>install new plugins from moodle plugin directory it comes up with the following error on moodle plugin site:-

Coding error detected, it must be fixed by a programmer: get_referer() can not be used any more. Please use get_local_referer() instead

I can get round it by just manually going to the directory and downloading the plugin, but wondered if anyone else has experienced this and whether there is a simple solution to fix this.


Thanks guys

Andy

 
Average of ratings: -
Picture of Ken Task
Re: Coding error detected, it must be fixed by a programmer: get_referer() can not be used any more. Please use get_local_referer() instead
Particularly helpful Moodlers

Ditto


 
Average of ratings: -
Picture of Ken Task
Re: Coding error detected, it must be fixed by a programmer: get_referer() can not be used any more. Please use get_local_referer() instead
Particularly helpful Moodlers

Follow up ...

Login to Moodle.

then go to the search/select plugins page


Right side under a block/box labeled Reports click 'My Sites'

https://moodle.org/plugins/report/index.php?report=user_sites

If the site info is in-correct ... like not the 3.4 you have, use the gear icon to edit it.

After I changed 1 or 31 sites I have there) to the sandbox 3.4 site I have
(just had to change the name, the URL, and version number).  

After that, worked as before.  No such errors.

Might work for others.

Also, FireFox updated yesterday to 57.0 ... about 3 times today when working with the 3.4 sandbox, I'd get an error about the site not available ... uhhhh, was logged on via ssh at the same time and had  a chrome browser instance also logged onto the same site.   Neither of those dis-connected nor reported the same issue ... matter of fact, no issue at all.    So am wondering if this is a Firefox thang?

'spirit of sharing', Ken


 
Average of ratings: -
Picture of David Mudrák
Re: Coding error detected, it must be fixed by a programmer: get_referer() can not be used any more. Please use get_local_referer() instead
Core developersDocumentation writersMoodle HQParticularly helpful MoodlersPlugin developersPlugins guardiansTestersTranslators

Thanks Andy. I can confirm this was a real regression of the recent moodle.org upgrade. It should be fixed now.

 
Average of ratings: Useful (1)