Installing and upgrading help

Blank page in Xampp installation

 
Picture of Javier Sánchez
Blank page in Xampp installation
 

Hi,

My version is 3.3 and my problem is get error when install moodle in Xampp.

All correct but I arrive at http://localhost/moodle/user/editadvanced.php?id=2 i get blank page. It not show error only blank page. My php version is 7 and MariaDB.

I reinstall  and nothing. Error. Is Xampp? Moodle? I don´t idea.

I need help. thx.

 
Average of ratings: -
Picture of Rick Jerz
Re: Blank page in Xampp installation
Particularly helpful Moodlers

What version of XAMPP?  PC or Mac.  And what version of Moodle.

I have XAMPP for Windows 7.1.7 running on a virtual PC with Moodle 3.4rc2 right now.  I just installed this over the last week.

 
Average of ratings: -
Picture of Javier Sánchez
Re: Blank page in Xampp installation
 

Hi,

Xampp version is 3.2.2 for PC and Moddle version 3.3.

I saw that Apache restart or do thing strange when I refresh the page http://localhost/moodle2/user/editadvanced.php?id=2. The message to show firefox is conection restart.

I changed antilope files at barracuda, I had change max_execution_time=600 and I deleted cache in moodledata. Nothing. Error. Blank page.

Thxs

 
Average of ratings: -
Picture of Rick Jerz
Re: Blank page in Xampp installation
Particularly helpful Moodlers

I am not sure how you arrived at the blank page.  Did moodle's install initiate, asking for program locations and more?  Did you make it through Moodle's setup?  Did you get to the point where you had to set up the admin account?  

I am not sure what XAMPP 3.2.3 provides.  This version does not show in the XAMPP, https://www.apachefriends.org/download.html, webpage.

 
Average of ratings: -
Picture of Javier Sánchez
Re: Blank page in Xampp installation
 

Hi,

Yes, the Xampp´s version is 7.1.7. I did make it through Moodle´s setup but it is stop in editadvanced.

No, I didn´t get to the point where set up the admin account.

I don´t know. Sorry for I can´t give more info.

Thank you very much Rick.

 
Average of ratings: -
Picture of Rick Jerz
Re: Blank page in Xampp installation
Particularly helpful Moodlers

Did you pick MariaDB when prompted for the database?

Can you take a screen shot of how you are filling in this webpage that asked for your database?  Do you have anything using port 80 on your PC, like Skype?  If so, you must fix this first.

Did you create a database using phpmyadmin or the mysql prompt, before starting the moodle installation?  Is your collation for your database set to utf8mb4.unicode_ci?

What database user name are you using?  And are you using a password?

 
Average of ratings: -
Picture of Javier Sánchez
Re: Blank page in Xampp installation
 

Hi Rick,

Thank you for help. Yes, I set MariaDB in page that select database.

Screen shots:

phpMyAdmin

Phpmyadmin

Logs

Log

Page´s error in Spanish:

error


database info:

database info


user without password: root. Name of database: moodle


check page

check page

In Xampp not appear bug the other software in port 80 like Skype. This yet I happened in other PC but now I can work in port 80. The database I create in normal process, automatic with collation utf8mb4.unicode_ci.

I think it could be a mistake of Xampp or Apache. I don´t know.

Thank you.

 
Average of ratings: -
Picture of Rick Jerz
Re: Blank page in Xampp installation
Particularly helpful Moodlers

You might need to enable xlmrpc, soap, and intl in your php.ini file.

 
Average of ratings: -
Picture of Javier Sánchez
Re: Blank page in Xampp installation
 

Hello!!

Miracle!!

Work it!. I don´t know how but work it. I didn´t install xlmrpc, soap and intl but I have add the directive <VirtualHost *:80> in httpd.conf while the page reload and eureka!! work it. I don´t know if is for this.

I installed in english, error in the page and I leave it few days and return work it.

Thank you very much all. In special at you Rick smile.

 
Average of ratings: -
Picture of Rick Jerz
Re: Blank page in Xampp installation
Particularly helpful Moodlers

Great, Javier.

When you get a chance, go to Site Administration, Server, Environment and see that you have "oks".

 
Average of ratings: -
Picture of soft nture
Re: Blank page in Xampp installation
 

XAMPP is the best Web Server and it’s easy to install and setup. First, you need to download XAMPP setup from XAMPP website as your system requirement. Since we are working on the Windows Platform, so we will talk about setting up a XAMPP Web server here on the Windows operating system.

For more detail: How To Build a WordPress Website Offline with Xampp


 
Average of ratings: -