Quiz

 
 
Picture of Sarah Long
Quiz question types not appearing
 

When creating a quiz, the button "choose a question type to add" shows nothing. Source code appears to be creating a popup/iframe or whatever with zero height. All quiz questions are on server. Everthing was fine before upgrade to 2.2 This happens on all browsers and both in-house and at home.Does anyone have any ideas please?

thanks

 
Average of ratings: -
Mary Cooch
Re: Quiz question types not appearing
Group Documentation writersGroup Moodle Course Creator Certificate holdersGroup Moodle HQGroup Particularly helpful MoodlersGroup TestersGroup Translators

Hi there -just to get some extra information  -you say "everything was fine before the upgrade to 2.2" Which version were you on before? Did the quiz work fine in 2.1? And is this for all users or just one user?

 
Average of ratings: -
Picture of Emma Richardson
Re: Quiz question types not appearing
Group Particularly helpful Moodlers

Have you tried switching themes?

 
Average of ratings: -
Picture of Joseph Rézeau
Re: Quiz question types not appearing
Group DevelopersGroup Particularly helpful MoodlersGroup TestersGroup Translators

@Sarah,

Do you have some add-on question types installed on your moode site, i.e. question types other than those that are part of the standard distribution?

Joseph

 
Average of ratings: -
Picture of Sarah Long
Re: Quiz question types not appearing
 

We were at version 2 I believe. We have no add-on question types of any sort.

Someone who knows tells me that the source shows that it is trying to draw a table of zero height.

We have changed to different themes but it makes no difference

 
Average of ratings: -
Picture of Joseph Rézeau
Re: Quiz question types not appearing
Group DevelopersGroup Particularly helpful MoodlersGroup TestersGroup Translators

Sarah,

Are you actually talking about creating a quiz, OR creating a new question in the question bank OR adding a question from the question bank to a Quiz?

There is no such thing as a button "choose a question type to add".

Please take a screenshot of your situation and post it here so we can actually SEE the problem.

Joseph

 
Average of ratings: -
Mary Cooch
Re: Quiz question types not appearing
Group Documentation writersGroup Moodle Course Creator Certificate holdersGroup Moodle HQGroup Particularly helpful MoodlersGroup TestersGroup Translators

This issue is also being discussed elsewhere online and I prompted the OP to come and ask here. I believe she is seeing the same as in the first screenshot here https://moodle.org/mod/forum/discuss.php?d=216544 - and when asked to go to the Manage questions page (to see if there are indeed any extra question types) she is getting a blank screen and an HTTP 500 internal server error.

 
Average of ratings: -
Mary Cooch
Re: Quiz question types not appearing
Group Documentation writersGroup Moodle Course Creator Certificate holdersGroup Moodle HQGroup Particularly helpful MoodlersGroup TestersGroup Translators

Ok - this is the debug message : PHP Warning: require_once(D:\Inetpub\wwwroot\moodle_migration\m oodle/question/type/gapselect/questiontypebase.php): failed to open stream: No such file or directory in D:\Inetpub\wwwroot\moodle_migration\moodle\questio n\type\ddimageortext\questiontypebase.php on line 31

So I am deducing these are two non-standard question types (from the OU, gapselect and ddimageortext) that have caused the problem?

 

 
Average of ratings: -
Tim at Lone Pine Koala Sanctuary
Re: Quiz question types not appearing
Group DevelopersGroup Documentation writersGroup Particularly helpful Moodlers

I guess the problem is installing ddimageortext without first installing gapselect.

 
Average of ratings: -
Picture of Joseph Rézeau
Re: Quiz question types not appearing
 
Average of ratings: -