TinyMCE: Cloze Editor

tinymce_clozeeditor
Maintained by Picture of Andreas GlombitzaAndreas Glombitza, Germán and temudginGermán Valero
An interface that integrates with Moodles existing HTML editor (HTMLArea in 1.9 and TinyMCE in 2.x and 3.x) to support teachers in creating CLOZE (Embedded answers) questions in the GIFT syntax. It will also read and edit existing CLOZE items.
1681 sites
723 downloads
31 fans
Current versions available: 7

The integration (PHP/javascript) is essentially a new button in the HTML editor which brings up an interface that helps create CLOZE questions in the correct syntax. It will also read and edit existing CLOZE items (which you have selected with your cursor).

Here's a demonstrator (which can also be used to create your own CLOZE quizzes):

http://goo.gl/zxRQmN

For installation instructions and more, see the "More documentation on this plugin" link below.

This plugin only works with the TinyMCE editor.

Daniel Thies made a very nice CLOZE editor plugin for Atto.

Screenshots

Screenshot #0

Contributors

Picture of Andreas Glombitza
Andreas Glombitza (Lead maintainer)
Germán and temudgin
Germán Valero: Documentation, translation and testing
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Russell Cunning
    Tue, Mar 15, 2016, 8:04 AM
    Hi Andreas,
    I have just used your online Cloze editor, and decided to install the plugin. The plugin installed successfully. When I click on it a new window pops up just like your online editor - but all that is in the window is a 403 error.
    I'm hosted on a LiteSpeed server, which has caused issues with some of my WordPress plugins in the past - but I have no idea where to start looking for what could be wrong. Do you have any ideas? I love the tool, and in the worst case scenario, I can still use your online editor.
    Thanks.
    Russell
  • Picture of Andreas Glombitza
    Tue, Mar 15, 2016, 9:53 PM
    Dear Russell,

    it's hard to diagnose from a distance, and I have no experience with a LiteSpeed server, but it sounds as if the files are not in the correct directory. You may want to double-check the file locations with the paths listed in the Readme-file.

    Best,
    Andreas
  • Germán and temudgin
    Thu, Oct 26, 2017, 10:33 PM
    Now there is also a cloze editor for Atto available for download (Moodle 2.7 to 3.4) at https://moodle.org/plugins/atto_cloze smile
  • Patrick Viney au MoodleMoot de Nîmes
    Fri, Dec 15, 2017, 12:28 AM
    Thank you for keeping up to date this great plugin. However, due to French localization, the pop up window I have is not wide enough. I can't find where to change the default width of this window in CSS. Can you help me ?
    Here is a screenshot : http://bit.ly/2j4EU3D
  • Germán and temudgin
    Sat, Dec 16, 2017, 11:07 PM
    Hi Patrick.

    The problem is not the french language localization. I just tested it in a new 3.4 local server in both french and mexican Spanish and it works OK.

    See the French and Spanish images at https://docs.moodle.org/34/en/Cloze_editor_for_TinyMCE#Other_languages

    Have you tried with a different browser?
    or from a different computer with a larger image display size?
  • Patrick Viney au MoodleMoot de Nîmes
    Mon, Dec 18, 2017, 10:02 PM
    Hi Germán,

    You're right, it depends a lot on the browser and computer that you use !

    I've tried with both Mac and PC computers, on several browsers, and it's not quite satisfying since it appears wrong on most of them. See this image where I made the comparison : https://tinyurl.com/y7t2hj3q
    (I kept 100% zoom on browser's screen for each screenshot)
  • Patrick Viney au MoodleMoot de Nîmes
    Mon, Feb 12, 2018, 10:55 PM
    Ok, we finally found out where to fix the width of this window :
    lib/editor/tinymce/plugins/clozeeditor/tinymce/editorplugin.js
    There, change width (originally 490) to 620.
    Don't forget to clear all caches : both browser AND Moodle caches
  • Germán and temudgin
    Sun, Jun 10, 2018, 6:44 AM
    New plugin version v3.5-r1 (2018060916) for Moodle 3.4 and 3.5 branches released today.
    Added support for Privacy API.
    It has a wider window in order to fix the problem described by Patrick Viney smile
    Remember to choose TinyMCe as your upmost (preferred) text editor smile
  • Picture of InsightKorea JobS
    Mon, Sep 3, 2018, 11:25 PM
    Hello~
    Problems with cloze quiz scores.
    When randomly taking quizzes in the quiz bank, the cloze quiz will bring two or more multiple question unconditionally to 1 point.
    But when I choose the question in the quiz bank, get the original score.
    Is there a way to get the score when it's original even when it's random?
    I'm sorry my English.

    If 1cloze question have 2Q and 1point (1PointX2Q), Total score is 2Points
    Now => random import => 1Point (0.5x2)
    want to change => 2Point (1Pointx2Q)
  • Germán and temudgin
    Tue, Sep 4, 2018, 12:24 AM
    @Polaris Lee:

    It is standard for all Moodle quizzes that use RANDOMLY selected questions to set a 1 point score for all random questions in the quiz.

    This is the default situation for ALL question types, not only CLOZE.

    I am afraid this can not be changed; if you use randomly selected questions, each question scores one point .
  • Germán and temudgin
    Wed, Nov 21, 2018, 12:06 AM
    Tested to work nicely in Moodle 3.6beta (Build: 20181118) smile
    It will be available for installing in Moodle 3.6 when it is released in 3rd december 2018 smile
    Remember to choose TinyMCe as your upmost (preferred) text editor.
  • Picture of steve m
    Tue, Jan 15, 2019, 2:40 PM
    I hope that the latest version will work pretty well!!
  • Germán and temudgin
    Tue, Jan 15, 2019, 10:18 PM
    The latest version 3.5r7 only has some minor syntax changes (when compared to the 3.5r5 version), in order to reduce the number of warnings reported by the code checker plugin.

    The new version also reduced the number of issues reported by the plugins database code prechecks system (194-292 versus 195-334). The original code (before I started working on it) had 493-360 issues reported by the code prechecks system.

    The new version should work exactly the same as the previous version. Please report any issue found.

    The new version will be offered as a recommended update when you check your installed plugins, but the old version is maintained in case anyone develops a problem.
  • Germán and temudgin
    Thu, May 16, 2019, 9:45 PM
    Tested to work with Moodle3.7 rc1 with Boost and Classic themes. Remember to choose TinyMCE as your top editor.
1 2 3
Please login to post comments