Themes: Base

theme_base
Maintained by It's only an avatar... Mary Evans
This theme was part of the Moodle core distribution, but for Moodle 3.2+ has now been moved to Moodle Plugins
2342 sites
452 downloads
6 fans

Moodle theme base
=================

This theme is a parent theme for the group of Moodle 2.0 themes such as Afterburner, Anomaly, and many other themes prior to Moodle 2.5.  Base was part of the Moodle core distribution, but has now been moved to a separate repository.

Installation
------------

The best way to install this plugin is to get a copy from [moodle.org](https://moodle.org/plugins/view.php?plugin=theme_base).

License
-------

Licensed under the [GNU GPL License](http://www.gnu.org/copyleft/gpl.html)



Screenshots

Screenshot #0

Contributors

It's only an avatar...
Mary Evans (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Me!
    Tue, Nov 15, 2016, 8:36 AM
    Thanks again for offering to maintain these plugins Mary - taking a look now.
  • Me!
    Tue, Nov 15, 2016, 8:59 AM
    Thankyou Mary - this looks correct. Nothing looks out of place in the code. This plugin entry could use a little more description to explain that this theme is meant as a parent theme and many other themes have been built on it. I did find one problem in core (not in this theme) that is preventing me from uninstalling this theme. I created https://tracker.moodle.org/browse/MDL-56952 to get it resolved.
  • Picture of David Mudrák
    Tue, Nov 15, 2016, 4:37 PM

    Thanks Mary and Damyon. I'll be happy to approve this theme together with the other one, once all the recommended missing parts (description, bug tracker, source code repository, screenshots) are provided.

  • It's only an avatar...
    Wed, Nov 16, 2016, 11:08 AM
    Sorry...just got to my emails!
    I'll fix this later today and add a screenshot of sorts with some info.
    Many thanks to you both.
  • It's only an avatar...
    Mon, Nov 28, 2016, 8:58 AM
    David, can you check to see that I have added all that is required. I cannot see anywhere to add a Bug Tracker URL.
    Thanks
    Mary
  • Picture of David Mudrák
    Tue, Dec 6, 2016, 6:08 AM

    There are still some required fields missing. If you go to the "Developer zone" link here on this page, the plugin edit form should open. All required fields are now correctly marked as such. Thanks in advance for providing the info.

  • It's only an avatar...
    Tue, Dec 6, 2016, 7:49 AM
    Sorry, I had added the description et al in the version form. I missed finding the Edit Plugin link in the Administration block!
    I'll do the same for Canvas.
  • Picture of Marina Glancy
    Tue, Dec 6, 2016, 12:05 PM
    can we have this plugin approved asap please? Moodle 3.2 was released yesterday and people really need this theme to upgrade
    https://moodle.org/mod/forum/discuss.php?d=343959
  • Picture of Daniel Munera
    Wed, Dec 28, 2016, 5:26 AM
    Hi People,

    Just one quick question. Why base theme was removed from the Moodle core?

    Regards,
    Daniel.
  • It's only an avatar...
    Wed, Dec 28, 2016, 6:02 AM
    Because it was depreciated and set to be removed in Moodle 3.2. It is still available to be downloaded from the Moodle plugins Database.
Please login to post comments