Activities: Open Forum

mod_hsuforum
Maintained by Picture of Blackboard Open LMS Development Blackboard Open LMS Development, Picture of Sean Flanagan Sean Flanagan, Picture of Stuart Lamour Stuart Lamour, Picture of David Scotson David Scotson, Picture of Guy Thomas Guy Thomas
Open forum are designed to increase engagement and provide a responsive, modern alternative to standard Moodle forums.
705 sites
505 downloads
49 fans

Open forum are designed to increase engagement and provide a modern alternative to standard Moodle forums.

Open forum reduce complexity and work like the modern messaging systems students use every day on the web and their mobile devices.

Unlike standard forums advanced forums are responsive, so users can read and post from their mobile or tablet. Advanced forums have been specifically designed to improve the usability and accessibility of Moodle forums. 

Posting and replying are all done via ajax to save page loads, take less clicks and increase engagement, while maintaining the user's context in a discussion thread.

Open forums contain a number of additional features including the ability to see who has engaged in a discussion before you open it, a setting to show recent forum posts on the course page, subscribing to individual threads, private replies and an option to allow anonymous posting, post bookmarking, along with all the features standard Moodle forums have.


Open forums are design by Blackboard in partnership with The University of Montana.

Screenshots

Screenshot #0
Screenshot #1

Contributors

Picture of Blackboard Open LMS Development
Blackboard Open LMS Development (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of Carina Börzel
    Thu, 16 Nov 2017, 8:43 PM
    Hello David,

    thank you very much for your reply.
    I've just tested it again in different browsers. I have the issue with firefox (Version: 56.0.2), chrome (62.0.3202.94) and edge (25.10586.672.0). Only with the Internet Explorer (11.1176.10586.0) I don't have this issue.
  • Picture of Mike Wilday
    Tue, 28 Nov 2017, 8:23 AM
    When will this plugin be available for Moodle 3.3?
  • Picture of John Hu
    Wed, 3 Jan 2018, 10:35 PM
    I installed this plugin for Moodle 3.4. It seems to work. However, if the faculty replied to a student's post privately (by checking the private reply box), that student sees the faculty private reply but there are no "reply" button for the student to reply to the faculty's private reply. I would think that student should be able to reply to faculty private replies. (If the faculty reply is not private, then I do see a "reply button" for student to reply to). Is this how the forum is supposed to work? (not having "reply" button for private replies?)
  • Picture of John Hu
    Wed, 3 Jan 2018, 11:19 PM
    If the student or faculty posted a Private reply, then even the site admin can't see that private reply. Is this true?
  • Picture of Michael Milette
    Sat, 17 Feb 2018, 3:49 PM
    Will this plugin be update to support Moodle 3.4 in the near future? If so, when do you expect to launch an updated release?
  • Picture of Andrew Molteno
    Mon, 19 Feb 2018, 5:56 PM
    Hi
    We have configured the forum to use Group Mode = Separate groups. A lecturer is allocated to each group. When viewing posts on the forum, lecturers only see posts from students within their group - as expected. However, when clicking "View posters" under forum administration, posts from all students in the course are displayed i.e. not limited to the lecturer's group. Is there a setting we have missed? Is it an issue that will be resolved in a future version? We are using plugin version 3.2.3.
    Thanks
  • Picture of Ehsan Anwar
    Tue, 13 Mar 2018, 1:19 AM
    Hi all,

    When send a post using the forum advance activity, the option in selected that all post are anonymous. When receiving the email to the mailbox from noreply@moodle.ucl.ac.uk, it shows sen "by Anonymous user" but when clicking on the link it takes your to the profile of the person posting, hence its not an anonymous post. Any ideas why this is? thanks.


    How to create issue


    1. create a forum (advanced) activity

    2. ensure that "Allow anonymous posting" is ticked in the settings

    3. in manage forum descriptions, ensure that subscribe button is "yes"

    4. submit a post

    5. You'll receive an email into your mailbox from noreply@moodle.ucl.ac.uk

    6. Click on the "by Anonymous link"

    7. This takes you to the users profile defeating the purpose of anonymous.

    Any anyeone else experienced or expericing this issue?
  • Picture of Trevar Pearce
    Thu, 26 Apr 2018, 4:57 AM
    Hi there, we recently upgraded to Moodle 3.4.2+ and are finding a problem:

    1. Add a new discussion in a Moodleroom (Advanced Forum) forum.
    2. Click the "Use advanced editor" link.
    3. Click the "Hide advanced editor" link.
    The text area for the post content disappears and can't be recovered until making a new post. All text entered is lost.

    Anyone else seeing this issue?
  • Picture of Greg O'Rourke
    Fri, 29 Jun 2018, 2:13 PM
    Hi there, there seems to be a problem with this plugin. We're running on Moodle version 3.2.2 and have Advanced forum version 3.2.3. When student select in Preferences > Forum Preferences > Forum auto-subscribe > Yes when I post, subscribe me to that forum discussion it doesn't actually subscribe the student when they reply to a discussion. How do I rectify this?
  • Picture of Carmen S.
    Wed, 25 Jul 2018, 12:04 AM
    Hi, is there a way to get an email every time someone writes in a forum? Thank you
  • Picture of Zeid Fanous
    Sun, 5 Aug 2018, 4:57 PM
    Hi, Is it possible to hide posts by other users... only see own posts?
  • Picture of Greg O'Rourke
    Sat, 8 Sep 2018, 8:35 PM
    I'm running Advanced Forum build 3.3.3 now and although it now subscribed users to a discussion when they reply to a post, it doesn't subscribe them when you first create a discussion (if you leave it as the default simplified text editor). Can this please be fixed in an updated release?
  • Picture of Chris Kenniburg
    Mon, 24 Sep 2018, 10:49 PM
    I really like this plugin. Thank you for sharing it. This is very much in line with what students expect in a discussion format. The ajax and other features are very nice.
  • Picture of Andres Ramos
    Tue, 6 Nov 2018, 11:40 PM
    We are having an issue where teachers are not getting the forum digest. Students get it but teachers don't. We are using the latest version of the plugin. Any ideas? We've already setup notifications and check notifications preferences. Using standard Moodle forum it works but not with open forums.
  • Picture of Blackboard Open LMS Development
    Thu, 8 Nov 2018, 7:25 AM
    Hi Andres Ramos,

    We just double check the forum digest and everything is working as expected, please verify your configuration. Remember to double check your suscribe list as the user (teacher) that is not getting emails or notifications. You can do that by going to the activity and clicking in the "Manage forum subscriptions" link. You can also check your forum and notification preferences.

    Let us know if the problem persist.
1 2 3 4 5 6 7 8
Please login to post comments