Select Moodle version:

Activities: Certificate

mod_certificate
This module allows for the dynamic generation of certificates based on predefined conditions set by the teacher.
Maintained by: Picture of Mark Nelson Mark Nelson
for Moodle
2.0, 2.1, 2.2, 2.3

Screenshots

screenshot

Contributors

Picture of Mark Nelson
Mark Nelson (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of Matthew Brewer
    Tue, Aug 6, 2013, 10:51 PM
    Will there be an update for Moodle 2.5? I have upgraded to this version of Moodle, but can't use the certificate module on it. Until the module is updated, I'm going to have to rely on my old Moodle 1.9 version, which isn't mobile-compatible, but will provide certificates.
  • Picture of Ian Johnstone
    Thu, Aug 22, 2013, 8:01 PM
    Hi Mark - I am looking for a way to create a single page certificate that displays a learners results (quiz names and scores of approx. 6 quizzes) from a single course on the one certificate. Is there a way to do this with this plug in?
  • Picture of Эдуард Галиаскаров
    Tue, Aug 27, 2013, 3:41 AM
    Hi Mark. I come across one problem. There are two type of students in my courses. Student is itself and student-curator. Curator can study course and watch the student succeses. I made the curator role on the assistant role based and modified it. There is mod/certificate:manage which restricts adding the user who have this right is true. If I turn it to false then user with the curator role cannot get student list who have issued certificates. I can change original code but it would be better to add new right looks like mod/certificate:viewuserlist ? Thank you (Ed)
  • Picture of Bronwen Campbell
    Tue, Aug 27, 2013, 3:45 PM
    Hi Mark, is this plugin working in Moodle 2.5 (was fine before upgrade, and have installed latest version of plugin.) I am getting a 500 internal server error - have checked permissions and they seem okay. Tried reinstalling, but no luck. Is it just a Moodle 2.5 issue and I have to wait, or is there something I can do to fix it. Thanks. I have Moodle 2.5.1 (Build: 20130708). Regards, Bronwen
  • Picture of Bronwen Campbell
    Wed, Aug 28, 2013, 8:34 AM
    Further to my request yesterday about certificate working in 2.5.1-giving a 500 error, I think I have managed to fix the problem. Found the error [2013-08-27 19:29:04]: error: file is writable by others: (/home/....../mod/certificate/view.php) and changed permissions for the view.php file from 664 to 644. Seems to have fixed it.
  • Picture of Wendi Turner
    Thu, Sep 12, 2013, 12:17 PM
    Every time I try to add it I get the error code "Add-on does not declare its version", which is false because it does declare it's version. Help...
  • Picture of iroshini Ratnapala
    Wed, Sep 18, 2013, 12:00 PM
    I also had the same issue as Bronwen. Did you view the report page? (/mod/certificate/report.php?id=xxx). It is not working and the permission change did not fix it.
  • wen photo
    Wed, Sep 25, 2013, 6:28 AM
    I just upgraded my site from 1.9 to 2.4. The certificate module used to be able to look up to the SCORM package to see if the participants have completed the SCORM course, then they can get a certificate. Now with the 2.4 certificate code (combined with 2.x "conditional activities") I was NOT able to do the same. If the participant only viewed few pages and then click on the "certificate" link, they will be able to get the certificate without going through the SCORM course. Does anyone experience the same thing? I turned on the debugging mode in Moodle 2.4.4 and the only thing I got is

    get_all_sections() is deprecated. See phpdocs for this function
    line 2956 of /lib/deprecatedlib.php: call to debugging()
    line 70 of /mod/certificate/index.php: call to get_all_sections()

    Thoughts or comments?
  • Picture of Joe White
    Wed, Oct 16, 2013, 12:55 AM
    Hi Mark,
    I love the plugin!
    Unfortunately when I upgraded to moodle 2.5 I immediately received a 404 error when trying to view the certificate. Is there anything I can do to rectify this?
    Thanks,
    Joe
  • Picture of rajiv gupta
    Mon, Nov 18, 2013, 12:19 AM
    Unfortunately when I upgraded to moodle 2.5 I immediately received a 404 error when trying to view the certificate. Is there anything I can do to rectify this?
    Thanks,
  • Picture of Ing. Edgardo Hdz. A. SS
    Thu, Dec 5, 2013, 3:21 AM
    Certificados en pdf no editables
    Hola a todos les solicito de su orientación ya que recientemente e instalado en moodle 2.4.5 y e agregado el módulo de certificados y se ejecuta adecuadamente pero al momento de generar el documento no me respeta las propiedades de no edición y copia del documento.
    Las características de mi servidor son:
    Sistema operativo Solaris 11.
    Php 5.3.10
    Postgress 8.3.1
    También si me pudieran decir cuál es la librería o las opciones que debo revisar para ver si puede ser ese el motivo de que el documento no se genere con seguridad ya que me permite editarlo y eso no debe ser.

    Certified non-editable pdf
    Hi all I ask you as your guidance recently and installed moodle 2.4.5 added ye module certificates and runs properly but when I generate the document does not respect the properties and no edition copy of the document.
    My server specs are:
    Solaris 11 Operating System.
    php 5.3.10
    Postgress 8.3.1
    Also if I could say what the Seller or options I should check to see if that may be the reason that the document is generated safely and that allows me to edit it and it should not be.
  • Picture of Christopher Molnar
    Mon, Dec 9, 2013, 8:59 PM
    Something has changed with the certificate. I used to be able to customize the certificate for a single activity or give it a name. Now it defaults to the course name. We have a training course in which the students are able to get several certificates based on different activities and tests. What happened to this customization?
  • Picture of Rich Sutton
    Tue, Feb 18, 2014, 8:08 PM
    Hi,
    I have upgraded my moodle to 2.6 and installed the latest version of certificate and now my certificates are blank? Any ideas please? Thanks.
  • Picture of Richard Smyton
    Wed, Feb 19, 2014, 12:48 AM
    Hi Rich
    We too have the same problem....although it seems to only affect Chrome. Works fine in IE and Safari. Can't find a solution yet.
  • Sketch...
    Sat, Mar 8, 2014, 12:52 AM
    An important message about this plugin from the maintainer, Mark Nelson:
    https://moodle.org/mod/forum/discuss.php?d=229683#p1107996
1 2 3 4 5 6
Please login to post comments