Your Moodle version

Blocks: Admin presets

block_admin_presets
Maintained by Picture of David Monllaó David Monllaó
Allow administrators to export the site settings to .xml presets, import and load other sites presets.

Features:

  • Export system settings to XML preset files
  • Import presets files
  • Preset preview and partial load
  • Allows rollback of applied changes
  • Option to autoexclude the sensitive data when exporting settings (editable sensitive settings list)
  • Third parties plugins supported (as long as they use the standard admin_setting classes)

License: http://www.gnu.org/licenses/gpl-2.0.txt

Screenshots

Screenshot

Contributors

Picture of David Monllaó
David Monllaó (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of Reto Müller
    Tue, May 28, 2013, 3:05 PM
    Is it planned to release the add-on for version 2.4 and 2.5?
  • Picture of David Monllaó
    Wed, May 29, 2013, 9:55 PM
    Hi Reto,

    Yes, it is planned, there are only a few required changes and the migration should be quick. In the meanwhile you can try (not in production) the latest available version, maybe you will need to hack version.php a bit. All feedback you cxan provide will speed up the migration process. Thanks
  • Picture of Daniel Lombardo
    Sat, Sep 7, 2013, 6:08 PM
    I am just getting a spinning loader under where it says Admin settings. Moodle 2.5
  • Picture of David Monllaó
    Mon, Sep 9, 2013, 10:40 AM
    Hi Daniel,

    Sorry, but I'm not sure I can locate the problem with the provided info. Do you mean in the administration block in a 2.5 site with block_admin_presets installed? Below the header in any of the admin_presets actions? In moodle.org/plugins?
  • Picture of Randal Johnston
    Thu, Sep 12, 2013, 1:49 AM
    I am seeing the same problem as Daniel. I am using Moodle 2.5. I go to the Admin Presets block and choose Export Settings. It loads the Export Settings screen and under the Admin settins section at the bottom, it only shows a spinning loader. Any suggestions?
  • Picture of David Monllaó
    Thu, Sep 12, 2013, 8:52 PM
    Hi Randal,

    Thanks for the info. I cloned the last version from the repository and it worked without any problem. For what I have seen this last version uploaded here is outdated. I have just uploaded a new version from the last repository code (removing a couple of debugging messages in the meanwhile) so it should work ok.
Please login to post comments