Themes: Rocket

theme_rocket
Maintained by Picture of DualCube TeamDualCube Team
Rocket is a professional high customisable theme for those who wish their Moodle site to look less moodley. It is a fixed width theme with multiple block locations.
335 sites
195 downloads
26 fans
Current versions available: 1

Rocket is a professional high customisable theme for those who wish their Moodle site to look less moodley. It is a fixed width theme with multiple block locations.

As this is an advanced theme using some very new Moodle 2 functions (I don't think used yet in other themes) I strongly recommend reading the documemtation via the link below.

A demo of this theme in action can be seen at http://features.demo.moodle.com.au/

Please view the sample screenshot below to see an image identifying key theme features. 

Should you have issues with the using the theme, please post your comments in the forums. If you have a bug or a patch, please post these in the Moodle Tracker using the link below


Screenshots

Screenshot #0

Contributors

Picture of DualCube Team
DualCube Team (Lead maintainer)
Julian Ridden
Julian Ridden: Original author
Please login to view contributors details and/or to contact them

Comments RSS

Comments

  • Julian Ridden
    Tue, Feb 7, 2012, 11:38 AM
    make sure you just have a folder called rocket with the files inside it. If you just unzip and upload you will often fid the folder hierarchy to be incorrect. Sadly I cannot fix this as it is a Github behaviour
  • Picture of g k
    Thu, Feb 9, 2012, 12:04 AM
    Yup...that's all I have. The folder is called "rocket". Inside of this, I have "fonts", "lang", "layout", "pix", "pix_core","pix_plugins", "style" folders. I also have the same error message as above: "syntax error, unexpected $end in /home/xxxxx/public_html/demo/theme/rocket/settings.php on line 23"
  • Picture of g k
    Thu, Feb 9, 2012, 9:53 AM
    Interesting....I was able to get it working. But now I get: Undefined index: defaultregion in /home/xxxxxx/public_html/CHIME/lib/outputlib.php on line 1145
  • Picture of Chris Newton
    Mon, Feb 13, 2012, 1:31 PM
    Found a bug, adding site news to main page hides the settings and navigation blocks. Any ideas on how to fix it?
  • Picture of Reva McEachern
    Fri, Feb 17, 2012, 4:09 AM
    Hi I have the theme installed at http://360i.lessonbee.com. Can you please explain how to achieve the top navigation and table display for course information as seen on the demo websites @ http://features.demo.moodle.com.au/ and http://ilearn.asam.mq.edu.au/ ?
  • Julian Ridden
    Fri, Feb 17, 2012, 6:48 PM
    For those asking (P.S. The forums is a better place for questions btw), the top menu is doen in "theme settings". The table of options on the left of the header image of my demo is just a HTML block placed in that location. Search was achieved by placing the global search block in the header location. For more info please check the themes forum on moodle.org
  • Picture of dylan oliver
    Wed, Mar 28, 2012, 5:40 AM
    ::SOLUTION:: add a semicolon (;) to the last line of theme/rocket/version.php
  • Picture of tim st.clair
    Tue, Apr 3, 2012, 7:33 AM
    Hi. just installed Rocket on Moodle 2.2.2+ / MAMP.
    - I had to add a semicolon to line 31 of version.php to make the homepage work.
    - Got an undefined index error (see below).
    - I hit the admin / upgrade page which told me that it needed to upgrade and check for a newer version. Pressed update and let it run through that screen.
    - I now get this error :

    Notice: Undefined index: defaultregion in /Applications/MAMP/htdocs/moodle22/lib/outputlib.php on line 1151

    (function setup_blocks); my line reads:

    $blockmanager->set_default_region($layoutinfo['defaultregion']);

    I then click through to the settings page and save all the defaults from that page (where it lists all the theme settings that are installed by the upgrade process). This takes me back to the homepage, then the error goes away. I suspect that it is still causing a problem because the theme seems to have some missing blocks / random grey areas.

    (sorry, private server, no links)
  • Picture of Jean Viera
    Thu, Apr 12, 2012, 3:41 AM
    Dear Julian,
    I appreciate this theme moodle, really good, I have it installed, but I get an error message:
    ..............................................................................................................................................................................
    Notice: Undefined index: defaultregion in /Applications/MAMP/htdocs/moodle22/lib/outputlib.php on line 1151
    ...............................................................................................................................................................................

    I appreciate your help ..
    Greetings from Peru
    Jean
  • Picture of William Lu
    Tue, Apr 24, 2012, 8:09 AM
    Installed on my Moodle2.2.1/MySQL5.0.51/PHP5.3.10, works well.
    I love the auto-hide buttons.
    But, the 'turn editing on' still appear as one normal button, not the BB switch look yet.
  • Picture of Darren Sutton
    Wed, Apr 25, 2012, 6:56 PM
    Hi Julian,

    The theme is great but I'm having trouble integrating it with a jscript flicker photo stream that I have on the front page of my site. When the photo stream loads the navigation bar at the top of the page doesn't display properly and I'm also unable to access site administration settings on the left hand side. If i navigate away from the front page to a page without the photo stream all is well again.

    Ive tested the photo stream in other themes and it doesn't have the same effect on the menu bar.

    Feel free to have a look for yourself at vle.nlcsjeju.kr

    Hopefully this will be an easy fix so that I can get back to enjoying a brilliant theme
  • Picture of lin zhang
    Tue, May 29, 2012, 4:43 AM
    I have the same problem. On login page, I got
    Notice: Undefined index: defaultregion in /home/xxxxxxxx/public_html/lib/outputlib.php on line 1145
    any suggestions?
  • Picture of Jean-Marc Doucet
    Thu, Jun 14, 2012, 4:09 AM
    Hello I tri to install this beautifull theme. I put the folder 'reocquet' in my 'theme' and on mysit.fr i have a white screen & i the adresse line : http://fael.fr/course/view.php?id=3
    xuse my poor english wink
  • Picture of Frank Szatkowski
    Tue, Jun 26, 2012, 4:51 AM
    Trying to change the background color on questions from blue to white. Went into theme/base/style/question.css and changed

    .que .formulation {background: #ffffff}

    but background color is still blue. searched in theme/rocket/style/core.css and cannot find any place to change the question background color.
  • It's only an avatar...
    Sat, Jun 30, 2012, 1:10 AM
    May i make a suggestion here. If there are any problems with this theme please ask for help in the Theme's forum? http://moodle.org/mod/forum/view.php?id=46
Please login to post comments