Themes: Classic

theme_classic
Maintained by Picture of Bas BrandsBas Brands
Theme classic is a simple theme based on the Boost theme. It uses the 3 column grid and the navigation block and settings block.
91 sites
280 downloads
5 fans
Current versions available: 1

This is a Child theme of the Boost theme that mimics the Clean theme. This theme can be used as a replacement for theme Clean once theme Clean has been deprecated.

It supports:

  • Bootstrap 4 Sass and JavaScript.
  • The 1, 2 and 3 column grid.
  • The settings and navigation blocks.
  • Allow the use of Moodle presets.
  • Adding a background image.
  • Set a light or dark navbar.
  • Set the site brand color.
  • Use the global settings for a small and large logo.
  • Adding custom Sass (pre and post).

It does not support:

  • docking
  • css written in less


Screenshots

Screenshot #0

Contributors

Picture of Bas Brands
Bas Brands (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of Plugins bot
    Mon, Aug 20, 2018, 6:50 PM
    Approval issue created: CONTRIB-7426
  • Picture of Ludovic ORNON
    Fri, Mar 22, 2019, 12:56 AM
    Hello, how to set up the column grid to 1, 2 or 3 column ? I am in a 2 column grid. On the setting of blocks, I see left, middle and right. But selecting right does nothing. Thanks for your help.
  • Picture of Louise Bennett
    Wed, Jun 12, 2019, 3:49 AM
    Hi -

    This page says this theme works on 3.5, but when I try and install it, I need an upgraded version of Boost. Attempting to upgrade Boost means I'm told I need an upgraded version of Moodle. IS there a version of this that will work on Moodle 3.5?

    Thanks!

    Louise
  • Picture of Adam Barker
    Tue, Jul 2, 2019, 4:20 PM
    Hi,

    I believe I am having a similar issue as the above, I am trying to install this theme onto a Moodle 3.5 version. But when I try I am met with "Not in the Plugins directory theme_boost" obviously this is in the theme directory as boost come with core Moodle on 3.5.

    It is flagging it as an 'unknown dependancy' which is a bit odd, the version it asks for in the theme itself is '2018120300' but the boost theme installed on the latest release of Moodle 3.5 is '2018051400' (so is 7 months out of date). The boost theme has subsequently been removed from the plugins area (online). Is this why it is being flagged as 'unknown'?

    Does the dependancy version in the theme need lowering to meet the version installed with version 3.5?

    Thanks
  • Picture of Bas Brands
    Fri, Jul 5, 2019, 3:44 PM
    Hi @Adam and @Louise. Yes I think that was a mistake and the version should be lowered. A better choice would be to upgrade to Moodle 3.7 now this theme is in core
  • Picture of Sorin Cocorada
    Mon, Sep 30, 2019, 12:08 AM
    Hi, Is there any possibility to show the navbar on the login page?
Please login to post comments