Adaptive adapted for coderunner

Question behaviour ::: qbehaviour_adaptive_adapted_for_coderunner
Maintained by Richard Lobb
A specialised version of the standard Moodle adaptive behaviour for use with the CodeRunner plugin (qtype_coderunner).
Latest release:
3154 sites
777 downloads
13 fans
Current versions available: 4

This question behaviour was created solely for use with the CodeRunner question type: https://github.com/trampgeek/moodle-qtype_coderunner/. It provides the caching of question test results needed to prevent re-testing a student's code every time the result page is viewed.


Potential privacy issues

None

Screenshots

Screenshot #0

Contributors

Richard Lobb (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Parādīt komentārus
  • Plugins bot
    piektd., 2017. gada 20. janv.., 22:10
    Approval issue created: CONTRIB-6702
  • Plugins bot
    ceturtd., 2017. gada 9. febr.., 20:36
  • Andreas Schenkel
    sestd., 2020. gada 18. janv.., 22:29
    This is only for moodle 3.6 but coderunner supports moodle 3.8. Do we need this Question behavior in moodle 3.8 is it not necessary?
  • Richard Lobb
    svētd., 2020. gada 19. janv.., 04:58
    Thanks for the heads up. The plug-in works fine with moodle 3.7 and 3.8. I've edited the info to include those version.
  • Michael Aherne
    pirmd., 2020. gada 1. jūn.., 19:04
    The latest version of qtype_coderunner (2020050400) in the plugin directory declares a dependency on version 2020021100 of this plugin but it's not available here. Can it be made available?
  • Richard Lobb
    otrd., 2020. gada 2. jūn.., 06:12
    Thanks for letting me know. It was on github but I had neglected to add the right version tag. Done now, and added to moodle repository.
  • Michael Aherne
    pirmd., 2020. gada 8. jūn.., 19:47
    Thanks very much for adding it so quickly!
Please login to post comments