Question types: Pattern match

qtype_pmatch
Maintained by Tim at Lone Pine Koala SanctuaryTim Hunt, Picture of Phil ButcherPhil Butcher
Allows a short response of one or a few sentences that is graded by comparing against various model answers, which are described using the OU's pattern match syntax.

Pattern match 1.1 for Moodle 2.1

Release notes

Pattern match question type

This question type was created by Jamie Pratt, working for the Open University
(http://www.open.ac.uk/).

Students can enter a response of up to 20 words, which is then graded by matching
it against vaious model answers that are expressed using a sophisticated patten
matching algorithm. See http://docs.moodle.org/dev/The_OU_PMatch_algorithm

This question type is compatible with Moodle 2.1+.

You will want to install Tim's stripped down tinymce editor that only allows the
use of superscript and subscript see (https://github.com/moodleou/moodle-editor_supsub).
To install this editor using git, type this command in the root of your Moodle install:

git clone git://github.com/moodleou/moodle-editor_supsub.git lib/editor/supsub

Then add lib/editor/supsub to your git ignore.

If the editor is not installed the question type can still be used but the super
script and sub script options in the question editing form will not be available.

To install the question type using git, type this command in the root of your
Moodle install

git clone -b MOODLE_21_STABLE git://github.com/moodleou/moodle-qtype_pmatch.git question/type/pmatch

And add question/type/pmatch to your git ignore.

Alternatively, download the zip from

https://github.com/moodleou/moodle-qtype_pmatch/zipball/MOODLE_21_STABLE

unzip it into the question/type folder, and then rename the new folder to pmatch.
Moodle 2.1

Version information

Version build number
2012081600
Version release name
1.1 for Moodle 2.1
Can be updated from
1.0 (2010090501), 1.0 (2010090501)
Can be updated to
1.2 for Moodle 2.3+ (2013021200), 1.3 for Moodle 2.5+ (2013070100), 1.4 for Moodle 2.5+ (2014010800), 1.5 for Moodle 2.5+ (2014061900), 1.6 for Moodle 2.6+ (2014111200)
Maturity
Stable version
MD5 Sum
033279ed220096c0dbbe889944a1c969
Supported software
Moodle 2.1
  • This is the latest release for Moodle 2.1

Version control information

Version control system (VCS)
GIT
VCS repository URL
VCS branch
MOODLE_21_STABLE
VCS tag
v1.1_m2.1

Default installation instructions for plugins of the type Question types

  1. Make sure you have all the required versions.
  2. Download and unpack the module.
  3. Place the folder (eg "myquestiontype") in the "question/type" subdirectory.
  4. Visit http://yoursite.com/admin to finish the installation