Lightbox Gallery

Activities ::: mod_lightboxgallery
Maintained by Picture of Andrew HancoxAndrew Hancox, Picture of Adam OlleyAdam Olley
This resource allows you to create 'Lightbox' enabled image galleries within your Moodle course. As a course teacher, you are able to create, edit and delete galleries. Smallthumbnails will then be generated, which are used for the thumbnail view of the gallery.
Latest release:
3699 sites
987 downloads
75 fans
Current versions available: 9

Clicking on any of the thumbnails brings that image into focus, and allows you to scroll through the
gallery at your leisure. Using the Lightbox scripts creates nice transition effects when loading and
scrolling through the images.

For Moodle 2.x+, YUI version:

* CREDITS *

Maintained by: Open LMS product team
Original plugin by: Paul Holden <pholden[at]greenhead[dot]ac[dot]uk>.


For the Moodle 1.9 jQuery version:

Moodle jQuery Lightbox Gallery v1.0.0 (16th Nov 11)

* CREDITS *

Ported to jQuery from:
Lightbox Gallery v2.2.1 (12th May 09)
by Paul Holden pholden[at]greenhead[dot]ac[dot]uk
http://moodle.greenhead.ac.uk/external/lightbox_gallery/

Port performed by Andrew Hancox at Kineo.
http://www.kineo.com/


External documentation URL: https://github.com/andrewhancox/Moodle-jQuery-Lightbox-Gallery/wiki
Source control URL: https://github.com/andrewhancox/Moodle-jQuery-Lightbox-Gallery
Bug tracker URL: https://github.com/andrewhancox/Moodle-jQuery-Lightbox-Gallery/issues
Website URL: http://www.kineo.com/

Sets

This plugin is part of set Lightbox Gallery.

Screenshots

Screenshot #0
Screenshot #1

Contributors

Picture of Andrew Hancox
Andrew Hancox (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Comments

  • Picture of David O'Brien
    Tue, Jan 24, 2012, 7:02 PM
    Version mod_lightboxgallery_moodle19_2011111600.zip on Moodle 2.2.1+ (Build: 20120119) gives error:


    Plugin "mod_lightboxgallery" is defective or outdated, can not continue, sorry.

    More information about this error
    Debug info: Plugin is not compatible with Moodle 2.x or later.
    Stack trace:

    line 464 of \lib\upgradelib.php: plugin_defective_exception thrown
    line 271 of \lib\upgradelib.php: call to upgrade_plugins_modules()
    line 1449 of \lib\upgradelib.php: call to upgrade_plugins()
    line 269 of \admin\index.php: call to upgrade_noncore()
  • Davo
    Mon, Feb 27, 2012, 10:05 PM
    There is a Moodle 2.x version of the ligthbox gallery available here: https://github.com/netspotau/moodle-mod_lightboxgallery
  • Picture of seinna gausman
    Tue, Apr 3, 2012, 1:31 PM
    i dont see a download zip for moodle 2.x just a bunch of folders and files...how do i download this plugin?

  • Picture of Przemyslaw Stencel
    Tue, Apr 3, 2012, 6:28 PM
    Click on "Downloads" (to the top-right of the folders) and then the button "Download as zip". Don't be discouraged by the message starting "There aren't any downloads yet..." smile
  • Picture of Rick Sparrow
    Wed, May 30, 2012, 2:00 AM
    Are there any more steps required to get this module working with Moodle 2.2?

    I used the link above to download from the zip file from github (using the Downloads link) and unzipped netspotau-moodle-mod_lightboxgallery-bc0e489.zip. I placed that in my mod folder and went to notifications, but Moodle doesn't see it.

    Does it need to be renamed? I've reset permissions and have no issues with other plug-ins I've downloaded, just this one. It's not in a subfolder either. Any ideas? This is for Moodle 2.2.2. Thanks.
  • Picture of Adam Olley
    Wed, Jun 13, 2012, 10:38 AM
    Rick, if installed correctly, all the files should be in mod/lightboxgallery/. So in that folder you should see version.php and the other files. Make sure your folder is called lightboxgallery and not anything else (many people don't realise you need to rename the folder from what github gives you).
  • Picture of 正华 明
    Fri, Jul 6, 2012, 9:13 AM
    I installed the plugins for moodle 2.x ,but in moodle 2.3+,it con't used,why?
  • Picture of Annick F
    Mon, Sep 10, 2012, 6:55 PM
    Installed on 2.3 but zipped files get display with a black thumbnail. You can view the picture by clicking on the black thumbnail. Photos uploaded individually are fine.....??
  • Picture of mo ollek
    Tue, Sep 18, 2012, 11:07 AM
    If a site administrator first modifies the role to enable students to contribute, instructors may then "switch" this capability on or off in their courses. -- Maybe I'm missing something -- how does a teacher switch this capability on or off in their course?
  • me
    Mon, Oct 15, 2012, 6:28 PM
    Hi. I am using 2.1.1 version of Moodle. I tried to use the .zip file on https://github.com/netspotau/moodle-mod_lightboxgallery but when I installed it, it says:
    Plugin "mod_lightboxgallery" (2012061900) could not be installed. It requires a newer version of Moodle (currently you are using 2011070101, you need 2012062500).

    More information about this error
    Stack trace:

    line 463 of /lib/upgradelib.php: upgrade_requires_exception thrown
    line 265 of /lib/upgradelib.php: call to upgrade_plugins_modules()
    line 1460 of /lib/upgradelib.php: call to upgrade_plugins()
    line 317 of /admin/index.php: call to upgrade_noncore()

    Do you know where I can get a copy of the correct version? Thank you in advance, Sam
Please login to post comments