HotPot

Activities ::: mod_hotpot
Maintained by Gordon Bateson
HotPot module for Moodle 2.x
Latest release:
5182 sites
893 downloads
75 fans
Current versions available: 1

Overview

The Hotpot activity module allows teachers to administer Hot Potatoes and TexToys quizzes via Moodle. These quizzes are created on the teacher's computer and then uploaded to the Moodle course. After students have attempted the quizzes, a number of reports are available which show how individual questions were answered and some statistical trends in the scores.

Dependencies

This module is required by the HotPot question import format for Moodle 2.x

Changes

To view details of recent changes made to this plugin, please click on the following link:

Screenshots

Screenshot #0
Screenshot #1
Screenshot #2
Screenshot #3
Screenshot #4

Contributors

Gordon Bateson (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Gordon Bateson
    Fri, Dec 19, 2014, 11:58 AM
    Thanks Tõnis,
    I inevstigated the issue and made a few improvements to the event handler functionality of the HotPot module. I could then confirm that I was able to view the following reports in Moodle 2.8

    * Site admin -> Reports -> Logs
    * Site admin -> Reports -> Events list

    Please could you download the latest version onto you Moodle site, initiate the Moodle upgrade, and let me know if the issue is then fixed on your site.

    best regards,
    Gordon
  • Rahul Kumar
    Wed, Nov 7, 2018, 4:52 PM
    this plugin hot pot is also working for totara site ?
  • Ricardo Caiado
    Tue, Dec 24, 2019, 11:47 AM
    Hi,

    Just update Moodle to v3.8 and got this error message:

    "Use of subplugins.php has been deprecated. Please update your '/XXXX/mod/hotpot' plugin to provide a subplugins.json file instead."

    Ricardo
  • Nicolas Dunand
    Fri, Jun 4, 2021, 5:53 PM
    Hi Gordon,

    Is this plugin still supported in newer Moodle versions?

    Thanks for your great work!
    Nicolas
  • Ridhima Suri
    Thu, Feb 24, 2022, 1:37 AM
    Will this plugin be available for Moodle 4.0?
  • steve lencina
    Wed, May 11, 2022, 1:26 AM
    I just upgraded to moodle 4.0 I should have checked Hot potatoes compatibility first. my bad.
  • Julian Juliani
    Sat, Jun 4, 2022, 1:58 AM
    hello, when I want to use hotpot I can upload information and configure the parameters but when I want to use the hotpot in the course it gives the error access denied invalid credentials, how can I solve this problem?
  • André Luciano
    Mon, Jun 27, 2022, 9:27 PM
    Na versao 4 do moodle está ocorrendo o erro Undefined property: stdClass::$intro in /var/www/moodle/lib/classes/output/activity_header.php alguma ideia de como eu posso corrigir?
  • Smaragda V
    Fri, Aug 5, 2022, 12:26 PM
    Are there any plans to provide an updated version of this?
  • Moises Sousa
    Thu, Aug 18, 2022, 9:27 PM
    Hello Gordon.

    Is there a possibility to update this plugin to 4.0 version?

    Kind regards.

    Moisés.
  • ED ED
    Fri, Aug 19, 2022, 8:16 AM
    Hello Gordon.

    Is there a possibility to update this plugin to 4.0 version?

    Regards

    ED
  • Jessica Gramp
    Tue, Jan 3, 2023, 12:56 PM
    It says this plugin works with 4.0 and 3.x versions too. If so, could you please update the description so this is clear? It still mentions Moodle 2.x - thank you smile
  • Takashi Yokoyama
    Sat, Mar 25, 2023, 2:06 PM
    I've just updated my site to 4.1. Is there HotPot plugin compatible with 4.1? I've been using this plugin for many many years... I want to use it with 4.1 as well...
  • SOFIANE HAMZA
    Tue, Aug 22, 2023, 9:37 AM
    i am getting this error on moodle 4.3: Exception - fmod(): Argument #1 ($num1) must be of type float, string given
  • Susan Mangan
    Fri, Oct 6, 2023, 2:53 AM
    Looks there is is a tracker item to build in support for HP7 but no movement in past year https://tracker.moodle.org/browse/CONTRIB-9126
1 2 3
Please login to post comments