General plugins (Local): Disable Right Click

local_disablerightclick
Maintained by Yogesh ShirsathYogesh Babasaheb Shirsath
Plugin helps to disable Right Click(Context Menu), Cut, Copy, Paste and developer tools.
264 sites
625 downloads
11 fans
Current versions available: 1

Disable Right Click plugin helps you to protect your site's content from being reused.

Disable Right Click features:

  1. Protect your content from selection and copy. this plugin makes content protection extremely simple without yelling at your readers.
  2. Disable right click on images to prevent downloading. No one can save images from your site.
  3. Disable right-click on every page.
  4. Disable keyboard shortcuts: Select All (Ctrl+A), Cut (Ctrl+X), Copy (Ctrl+C), Save (Ctrl+S), Paste (ctrl+V), Inspect (Ctrl+Shift+I), View-source (Ctrl+U).(More shortcuts will be added soon)
  5. Work with any themes.
  6. Work well on mobile devices.
  7. Compatible with Chrome and Firefox. (Soon will be compatible with Safari)
  8. Easy to install and use.
  9. Configure as your requirement. Following settings are available:
    1. Disable Right Click
    2. Disable Cut, Copy and Paste
    3. Disable Developer Tools
Support me on:
Patreon: https://www.patreon.com/yogshirsath
Paypal: https://www.paypal.me/yogshirsath

Screenshots

Screenshot #0
Screenshot #1
Screenshot #2
Screenshot #3

Contributors

Yogesh Shirsath
Yogesh Babasaheb Shirsath (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Yogesh Shirsath
    Wed, Apr 22, 2020, 1:00 AM
    @Edurne Saldias, I didn't understood your concern. Can you please elaborate. If possible then please use English.
  • Picture of Gonzalo Muñoz Quintero
    Tue, May 5, 2020, 10:30 PM
    Yogesh, thanks for your work. Could you please do that it works over SCORM packages and other resources?
  • Picture of Rogier van Dongen
    Wed, May 6, 2020, 5:49 PM
    @yogesh
    Plugin is broken in multiple Moodle versions, because AMD explicitly requires a "define()" statement to declare/define amd modules.
    Yours uses "require", which is basically only to be used in user code, not when the AMD module is defined. Please fix.
  • Picture of JJ Prade
    Sat, May 30, 2020, 2:44 AM
    Hi Yogesh, this plugin don't work in Moodle 3.8.3
  • Yogesh Shirsath
    Sat, May 30, 2020, 11:02 AM
    Sorry Moodler's for late reply. I'll give update within week.
  • Picture of LUIS ALEJANDRO RODRIGUEZ PINILLA
    Tue, Jun 2, 2020, 2:29 AM
    Hello thank you for this excellent plugins but there is the possibility to be able to program the roles since it blocks me from teachers and the Spanish language for when the messages come out.
  • Picture of Santosh Nagargoje
    Tue, Jun 9, 2020, 1:27 AM
    @Yogesh, good job... just i would like to ask you that how can we allow right click for teachers? i would like to restrict to students only. please help me as my client has requirement.
  • Yogesh Shirsath
    Tue, Jun 9, 2020, 1:44 AM
    Good news for those Moodler's who were looking for role based restriction. I have added capability based blocking. Allow "local/disablerightclick:allow" capability to teacher to allow all functionalities blocked by plugin. Wola.
  • Picture of LUIS ALEJANDRO RODRIGUEZ PINILLA
    Thu, Jun 11, 2020, 9:34 AM
    Yogesh Babasaheb Shirsath
    Thank you very much for this last update, finally there is the possibility to change the blocking messages to Spanish.
  • Picture of Santosh Nagargoje
    Thu, Jun 11, 2020, 6:16 PM
    Hi Yogesh, this plugin initially worked in Moodle 3.8.3 but now doesn't work in Moodle 3.8.3
    what will be problem?
  • Picture of Michel Rancourt
    Fri, Jun 12, 2020, 4:46 AM
    Hello I cannot find the capability base blocking Allow "local/disablerightclick:allow" for teacher. I have updated the plugin. I have 1.0.0 (2020060700) version on Moodle. Thx
  • Yogesh Shirsath
    Fri, Jun 12, 2020, 11:07 AM
    @Santosh, I have tested it on Moodle 3.8.3 and it is working. Try reinstall latest version. Check settings once. If nothing works then email me.

    @ Michel, Install latest version. Follow this: Site administration -> Users -> Permissions -> Define roles. Click on edit button in front of Teacher. Filter (local/disablerightclick:allow). Then allow this capability.
  • Picture of Santosh Nagargoje
    Fri, Jun 12, 2020, 4:22 PM
    @Yogesh, I again checked by reinstalling but its not working...
  • Picture of Michel Rancourt
    Fri, Jun 12, 2020, 10:34 PM
    thx. Working great on 3.8.3
  • Picture of Vladimir ZH
    Sun, Jun 21, 2020, 3:23 PM
    Does the plugin comfortable with 3.9 version? I do not see it working(
1 2
Please login to post comments