Course formats: MindMap Format

format_mindmap
Maintained by Picture of Łukasz Sanokowski Łukasz Sanokowski
Mindmap Course Format allows Moodle users using courses through interactive, personalized mindmap. Additionally, it provides features unavailable in standard Moodle, which are: graphical presentation of conditional dependencies and distinction of modules where student have problems (and which are near deadline).
285 sites
252 downloads
31 fans

It is fully compatible with standard Moodle course formats (like weekly format or topics format) and already existing courses can be switched to MindMap format.

It uses Freeplane Java Applet to display map, thus Java is required.

Take a look at screenshots which show the same course in standard topics format compared to MindMap format.

Screenshots

Screenshot #0
Screenshot #1

Contributors

Picture of Łukasz Sanokowski
Łukasz Sanokowski (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of jj li
    Sun, 31 May 2015, 10:05 PM
    copy the folder to moodle/course/format/
  • Picture of Pat Rock
    Wed, 1 Jul 2015, 4:52 PM
    HI Łukasz

    I installed successfully the plugin (moodle 2.9) but when I try to open a course in a mindmap format I have the message :

    condition_info,condition_info_section,condition_info_base classes can not be used any more, please use respective classes from \core_availability namespace
    Plus d'informations sur cette erreur
    Debug info:
    Error code: codingerror
    Stack trace:
    line 28 of /lib/conditionlib.php: coding_exception thrown
    line 235 of /course/format/mindmap/mind_map_generator/lib.php: call to require_once()
    line 226 of /course/format/mindmap/mind_map_generator/lib.php: call to format_mindmap_print_fa()
    line 177 of /course/format/mindmap/mind_map_generator/lib.php: call to format_mindmap_print_module()
    line 163 of /course/format/mindmap/mind_map_generator/lib.php: call to format_mindmap_pamfs()
    line 104 of /course/format/mindmap/mind_map_generator/lib.php: call to format_mindmap_print_section()
    line 35 of /course/format/mindmap/mind_map_generator/lib.php: call to format_mindmap_create_file()
    line 52 of /course/format/mindmap/format.php: call to require_once()
    line 280 of /course/view.php: call to require()
  • Picture of Łukasz Sanokowski
    Mon, 6 Jul 2015, 9:05 PM
    Hi Pat, it seems that conditions api have changed in 2.9. I have to update my Moodle to 2.9 and upgrade this course format.
  • Picture of Pat Rock
    Sun, 12 Jul 2015, 9:04 PM
    Hi Łukasz and thank you very much.
    Now mindmap is loaded, but the map is missing. I've got the message:
    "Could not open URL http://mysite/course/format/mindmap/mind_map_generator/file.php?filename=le5df49d97862b&courseid=7."
  • Picture of Łukasz Sanokowski
    Mon, 3 Aug 2015, 5:38 PM
    Hi Pat, does the problem still occur? I can't reproduce this error.
  • Picture of wera y
    Tue, 8 Sep 2015, 12:22 PM
    Hi Łukasz,
    I installed the plugin (moodle 2.9) but when I try to open a course in a mindmap format the gray panel replaced the display of the course map.
  • Picture of Łukasz Sanokowski
    Tue, 8 Sep 2015, 4:35 PM
    Hi Wera, do You have Java?
  • Picture of Arne Peters
    Mon, 22 Feb 2016, 9:04 AM
    Hi Lukasz,

    the idea of creating a mindmap format ist fantastic ! I loved the idea right from the moment I saw it on this site ... unfortunately my browser no longer supports java. I realized it, once I had Java installed.

    I guess this is the future now, no more Java in Chrome or Firefox or Safari ... so is there a version coming up without ?

    Or am I doing something horrebly wrong and it all works fine ?

    Thanks for your reply in advance. With best regards,
    Arne H. Peters
  • Picture of Łukasz Sanokowski
    Thu, 31 Mar 2016, 3:31 PM
    Hello Arne

    You are right - lack of Java support in browsers is a problem, indeed. I am looking for open source mindmapping tool to switch interface from Freeplane Java Applet. Regards
  • Picture of wael alkhatib
    Tue, 20 Sep 2016, 3:58 AM
    hi, is it supported on moodle 3.1?
  • Picture of Łukasz Sanokowski
    Wed, 21 Sep 2016, 4:30 PM
    Hi Wael, yes it is supported.
  • Picture of Jade siu
    Thu, 23 Mar 2017, 12:00 PM
    May I know if there is any video that showing how to use it? I tried to install and could not see any hints to use it.
    BTW, could you make it supporting 3.2 as well?
  • Picture of Łukasz Sanokowski
    Thu, 23 Mar 2017, 3:49 PM
    Hello Jade

    It does support Moodle 3.2, I've updated plugin requirements. It is installed in regular way, just put it in to /course/format directory and click "Notifications" in admin panel. Next - go to a course setting and change the course format parameter to "MindMap"
  • Picture of Jade siu
    Fri, 24 Mar 2017, 4:19 PM
    Thanks Lukazs

    However, I found that by changing the format, I do not see the way to create a mindmap on the course format. Other than this course_format, do I need to add block_mindmap and mod_mindmap? However, I found that they are not working for Moodle 3.2.

    Sorry I really have no clues. Kindly shed me light.
  • Picture of Łukasz Sanokowski
    Fri, 24 Mar 2017, 9:32 PM
    Jade, there are no built-in editing tools in mind map. If you want to change course content, just turn editing mode on, and you will see regular course page.
1 2
Please login to post comments