Stripe Payment with SCA and Coupon

Enrolment ::: enrol_stripepayment
Maintained by DualCube Team
Add a price to your courses and check out quickly with Stripe Payment. Stripe is a user-friendly payment solution that allows for secure transactions. This plugin includes a number of payment processing services, including the ability to accept credit card payments. You can also offer various discounts to learners looking to purchase your courses.
Latest release:
1307 sites
570 downloads
74 fans
Current versions available: 4

Brief Introuction

Elevate your e-learning payment experience with the Stripe Payment Plugin. Seamlessly integrate Stripe, a leading payment gateway, and empower your learners with effortless payment management. 

Rest easy with robust security features, including fraud prevention and data encryption, safeguarding your business and users from online threats. Unlock the power of coupon support for accessible course offerings. 

Benefit from Stripe's speedy and reliable payment processing, and tailor your enroll button's design to seamlessly fit your site. Maximize your e-learning payment system's efficiency by installing and configuring this exceptionally effective plugin today.

What Stripe Payments Offers!

Add a price to your courses and check out quickly with Stripe Payment. Stripe is a user-friendly payment solution that allows for secure transactions. This plugin includes a number of payment processing services, including the ability to accept credit card payments. You can also offer various discounts to learners looking to purchase your courses.

Our Features:
Easy to use

Stripe has a simple and intuitive user interface that makes it easy for learners to manage their payment processing

Flexible payment options

With a wide range of payment methods, including credit and debit cards, Apple Pay, Google Pay, and Alipay transactions become easy.

High level of security

Stripe is known for its robust security features, including built-in fraud prevention tools, data encryption, and 2-factor authentication. This helps to protect businesses and their customers from online fraud and hacking.

Coupon Support

You also get the option to offer special discounts to learners using stripe coupons.

Fast and reliable payment processing

Stripe processes payments quickly and reliably making it easy for learners to get started. This document will help you to configure the plugin further https://dualcube.com/docs/stripe-payment-with-sca-and-coupon/

Enroll Button Color

This unique feature will help you select the color of the enrolment button as per your choice.

stripe color

S Stripe Pro Version!

Stripe Pro is an advanced payment gateway that allows you to offer subscription payments to students. You can also access premium features such as free trial, sign-up fee, and so on with this solution. Go To Stripe Pro site

😊By investing in Stripe Pro, you become an essential partner in shaping the future of these projects. Keep the open-source spirit alive!

Screenshots

Screenshot #0
Screenshot #1
Screenshot #2
Screenshot #3
Screenshot #4
Screenshot #5
Screenshot #6

Contributors

DualCube Team (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Vis kommentarer
  • chandan kumar
    man., 31 jul. 2023, 21:29
    Does this plugin also generate and mail Invoice to students?
  • DualCube Team
    tir., 1 aug. 2023, 00:59
    Hi Chandan, I hope you're doing well. Currently, when students purchase a course, the admin can obtain the invoice from their own Stripe account and then manually send it to each student.

    However, we understand the need for an automated solution to generate these invoices. We've already submitted this request to our development team, and they will take further decision of this feature in the near future.

    We will keep you posted.
  • Jesús Moreno
    lør., 19 aug. 2023, 20:43
    Hi! Is possible to make a suscription monthly payment with thist plugin? Also to assign roles depending on the monthly payed and open new contents according to it.
  • DualCube Team
    man., 21 aug. 2023, 14:14
    Hi Jesus, with our Stripe Pro (https://dualcube.com/product/moodle-stripe-payment-pro/), yes, you can take subscription payments.

    Regarding the roles, can you please explain what flow are you looking for so we can assist you with this.
  • Robert Mann
    tor., 12 okt. 2023, 00:48
    Hi, I have been testing the plugin (v3.4.3) and have a couple of issues to feedback...
    1. in edit_form.php, cost is formatted as an INT so you can only use whole number prices. I assume this should be FLOAT ?
    2. in enrol.php, it is a missing the closing of the final div which screws up the formatting for subsequent enrolment methods
    Thanks
  • DualCube Team
    tor., 12 okt. 2023, 23:45
    Robert, thanks for reporting this issue.

    We will release an update by this week, with the fix. You can track the progress of this issue from here : https://github.com/dualcube/moodle-enrol_stripepayment/issues/133
  • Hieu Han
    ons., 21 feb. 2024, 19:19
    I'm using enrol_stripepayment version: '3.4.4 (Build: 2023101400)'

    When users click on "Buy now" button, nothing happens.

    The console show this error message:
    Warning: Undefined variable $instance in /usr/local/www/moodle/enrol/stripepayment/externallib.php on line 259

    Warning: Attempt to read property "currency" on null in /usr/local/www/moodle/enrol/stripepayment/externallib.php on line 259
    [
    {
    "error": false,
    "data": {
    "status": "cs_test_a1mX2Hd3..."
    }
    }
    ]
  • DualCube Team
    ons., 21 feb. 2024, 22:13
    Hi @Hieu Han, it seems like you haven't set the currency for your courses. Can you please set that and check again.
    Please do keep us posted.
  • Dan Rapoza
    ons., 10 apr. 2024, 11:11
    Is it possible to allow specific coupons for specific courses?
  • DualCube Team
    tor., 11 apr. 2024, 16:06
    Dan, thanks for getting in touch with us.

    Currently we don't have any such flow, however we do have plan to implement this on our end in future update.
    For now you can track the progress of this issue from here https://github.com/dualcube/moodle-enrol_stripepayment/issues/142
  • Gareth Harris
    ons., 17 apr. 2024, 19:39
    We currently take Stripe payments in two different places and have done for a long time. We take them using a Stripe plugin in WooCommerce and using your Moodle plugin. In the past, on Moodle when a user makes a purchase using your plugin the Stripe pop-up has their email address already completed in an uneditable field.
    We have just updated to the newest plugin and have an issue where this email box is filled with the email address of the most recent purchaser on the WooCommerce side. This is very strange.
    Any help would be much appreciated.
  • DualCube Team
    ons., 17 apr. 2024, 22:06
    Hello Gareth, we're sorry to hear about the issue you encountered.

    Could you please provide us with the steps to reproduce this problem? This will allow us to investigate the issue more effectively by replicating it on our end.
  • DualCube Team
    tor., 18 apr. 2024, 16:57
    Hi Gareth, we have fixed this.

    Kindly download the fixed plugin from here https://github.com/dualcube/moodle-enrol_stripepayment/archive/refs/heads/master.zip

    So, after downloading the plugin , follow these steps :
    – Delete the installed moodle-enrol_stripepayment plugin
    – Unzip the GitHub plugin
    – Rename the folder as “moodle-enrol_stripepayment” and remove the master tag. Now, zip this folder again.
    – Upload this plugin on your site.

    Please do keep us posted.
  • Simon Davies
    lør., 11 mai 2024, 14:43
    Hi Dual Team, I have the same issue as Gareth, but on a Moodle 3.9 site - is there anything that can be done? Thanks so much,
  • DualCube Team
    lør., 11 mai 2024, 15:15
    Simon, in our most recent update, we've already implemented the fix. However, please note that our minimum requirement for Moodle is version 4.0. We highly recommend updating your Moodle version accordingly. Alternatively, you can modify our code to set the minimum requirement to version 3.9, but we cannot guarantee whether it will work.
Please login to post comments