Lucimoo EPUB import

Book tools ::: booktool_importepub
Maintained by Haakon Meland Eriksen
Lucimoo EPUB import/export add-ons for the Moodle book module. Lucimoo consists of two add-ons for the Moodle book module: * The "importepub" add-on provides functionality to import material from EPUB ebooks into book module books.
Latest release:
415 sites
150 downloads
18 fans
Current versions available: 1

Add a book activity to your course and use Lucimoo to import content from EPUB ebooks. In addition to importing an entire book, you can choose to import chapters as individual books - this is handy if you want to intersperse each chapter with other Moodle activities. You can import EPUBs from files and from URLs.

Screenshots

Screenshot #0
Screenshot #1
Screenshot #2
Screenshot #3
Screenshot #4

Contributors

Haakon Meland Eriksen (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Thu, Jun 11, 2015, 1:37 PM
    I have imported Lucimoo ebook import into this Git repository at GitHub:

    https://github.com/HaakonME/Lucimoo-ebook-import
  • Thu, Jun 11, 2015, 2:47 PM

    That's a good start, thanks (hopefully the git repo will be updated with future updates, too). Can you please edit the plugin record and putt that URL into the source code URL field please?

  • Fri, Jun 12, 2015, 3:43 AM
    I think I have managed to fix most issues, and have requested a re-approval.
  • Fri, Jun 12, 2015, 4:00 AM

    Thanks for fixing all the raised issues. You are cleared to land now, welcome to the Plugins directory!

  • Fri, Jun 12, 2015, 4:24 AM
    Wonderful! smile Thank you for your guidance, David!
  • Tue, Jul 14, 2015, 4:47 PM
    Dear Haakon. is there any plan to make it compliance with epub 3?. I have created some epub using exe learning but your tool doesn't recognise the quizzes.
  • Fri, Jul 17, 2015, 6:58 AM
    Dear Carlos. Lucimoo is in compliance with EPUB 2 and EPUB 3. However, Lucimoo and EPUB is at present primarily geared towards publications, none fiction and fiction. I do not know the quality of eXe as an EPUB authoring tool. Can you check if your EPUB validates using the https://github.com/IDPF/epubcheck tool? GUI versions are available from http://www.pagina-online.de/produkte/epub-checker/ and http://www.publishing-systems.org/downloads.php . If your EPUB validates, please contact me again, then we will have to dig deeper into the problem.
  • Thu, Mar 10, 2016, 10:26 PM
    Dear Haakon
    sorry, i just saw your reply today. I do apologize. in deed, it is not passing the validation. It is a pity because the exelearning files have a lot of interactions (quizzes and feedbacks activities)
  • Tue, Mar 15, 2016, 3:35 PM
    Dear Carlos,
    No worries. EPUB 3 does support interactivity, but was regarded as cutting edge in 2014, see http://epubzone.org/news/epub-3-and-interactivity . I think you might have more luck with exporting your interactive content to a different format, like IMS or SCORM, and then import those into your Moodle site.
  • Wed, Aug 17, 2016, 3:07 PM
    Lucimoo EPUB import version 0.17 for Moodle 3.1 is now available. smile

    Version 0.17 should work if the server uses PHP 7, while version 0.16 does not work if the server uses PHP 7.

    Version 0.16 should also work with Moodle 3.1 if the server does not use PHP 7.
  • Wazza
    Sat, Aug 26, 2017, 2:26 AM
    Hello! I get the following error upon importing (still version 0.16)

    ×Debug info: Column 'visibleoncoursepage' cannot be null
    INSERT INTO mdl_course_modules (course,module,instance,visible,visibleoncoursepage,visibleold,groupmode,groupingid,completion,completiongradeitemnumber,completionview,completionexpected,availability,showdescription,added) VALUES(?,?,?,?,?,?,?,?,?,?,?,?,?,?,?)
    [array (
    0 => '6165',
    1 => '28',
    2 => 0,
    3 => 1,
    4 => NULL,
    5 => 1,
    6 => 0,
    7 => '0',
    8 => 0,
    9 => NULL,
    10 => 0,
    11 => 0,
    12 => NULL,
    13 => 0,
    14 => 1503683669,
    )]
    Error code: dmlwriteexception
  • Sun, Aug 27, 2017, 12:07 PM
    Does this plugin work on Moodle 3.31? Thanks
  • Tue, Jan 30, 2018, 1:53 AM
    Hello, everyone - we have a new version 1.0 for you! A big thank you goes to the Ministry Division of the Archbishops’ Council of the Church of England, which supported the development of some features of this latest version of the plugin.
  • Wed, Jan 31, 2018, 4:25 AM
    Thanks to the community for testing our 1.0 release by importing more EPUB files into Moodle, we uncovered and fixed a bug, and can already provide a version 1.1 for you! Depending on your feedback, we may release another in a week or two.
  • Tue, Feb 19, 2019, 8:29 PM
    Not available for Moodle 3.6
1 2
Please login to post comments