Blocks: CSS theme tool

Maintained by Sam HemelrykSam Hemelryk
A block to aid theme designers in customising the current theme by providing an in page CSS editor GUI. Using this block the user can select to add a rule, click on the part of the page they want to style and then use the friendly GUI to add styles to the item that was clicked on.
32 sites
5 fans
Current versions available: 2
The CSS theme tool is a block that is designed to make CSS creation and editing for Moodle both easy and accessible. It aims to provide a point and click interface with WYSIWYG controls for adding CSS rules and provides a user friendly interface for creating CSS that is suitable for everything from creating simple modifications to creating entire themes. As well as giving the user an easy means to create CSS it also allows the admin or a Moodle site to make immediate modifications to the installations CSS that will be visible by everyone using the site (not just those who can create CSS) and does this all without the need for editing any files within Moodle or even having to create or modify themes.


  • A point and click CSS editor with buttons and manual CSS style entry.
  • Intelligent in page selector to make sure you are styling what you want.
  • Persistence over pages so you can create styles, save them, and browse to other pages to check the effects.
  • Ability to save and download the CSS you create.
  • Autosave feature so that you don't have to worry about losing your work (it saves as you go).


  • Moodle 2+
  • A browser that supports the latest JS and CSS standards (Not tested in IE)
  • JavaScript enabled (this is a largely powered by JS)


Screenshot #0
Screenshot #1
Screenshot #2
Screenshot #3


Sam Hemelryk
Sam Hemelryk (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of Dave Emsley
    Tue, Mar 6, 2012, 3:06 AM
    I've tried to install this block on a Moodle 2.2.1+ build 20120202 but the notifications page tells me Moodle 2012020200 is required.

    Slightly confused about this, any suggestions, thoughts?


  • kn
    Thu, Mar 22, 2012, 7:10 PM
    You must change the parameter: $plugin->requires = 2012020200.00; to a proper version: $plugin->requires = 2011120500; in file version.php of the plugin.
  • Bob Singletary
    Sat, Mar 31, 2012, 4:19 AM
    This looks like a nice tool. However, it would be desirable to not be required to change the $plugin param every time an update to Moodle is performed, or is that not an issue. Can we just ignore the notification without modifying $plugin?
  • Bob Singletary
    Sat, Mar 31, 2012, 4:22 AM
    OK, answered my own question as to whether notification can be ignored. Will not let the plugin installation proceed. Still back to my orig concern. Is a future release of this going to address the issue or will we always need to modify the $plugin->requires param?
  • Sam Hemelryk
    Tue, May 22, 2012, 11:43 AM
    Hello, I have fixed up the required version and have uploaded a new version now.
  • Picture of Marcelo CS
    Sat, Dec 28, 2013, 12:54 AM
    Hi ... This plugin works on version 2.6 of moodle? tnks
  • Sketch...
    Wed, Nov 18, 2015, 6:12 PM
    Sam, Moodle 3.0 has just been released. Is this plugin still supported? The last version was released on 22 May 2012.
  • Sam Hemelryk
    Wed, Nov 18, 2015, 6:25 PM
    Hi Luis,
    I've not had any time to work on this unfortunately, as such it is dead in the water presently.
Please login to post comments