Installing and upgrading help

Unable to connect to Moodle download server.

 
Picture of Sokunthearith Makara
Unable to connect to Moodle download server.
 

It seems like my Moodle site has been disconnected from Moodle download server.

I get this message when I try to Check for Available Updates:

"Unable to fetch available updates data - unexpected HTTP response code."

I get this message when I try to update the language pack:

"Unable to connect to the download server. It is not possible to install or update the language packs automatically. Please download the appropriate ZIP file(s) from https://download.moodle.org/langpack/3.3/ and unzip them manually to your data directory"

And when I tried installing/updating a plugin (such as Coupon) from Moodle.org:

"There is a request to install plugin Coupon (block_coupon) version 2017092500 from the Moodle plugins directory on this site. However, the plugin installation pre-check failed (reason code: remoteunavailable)."

Any suggestions, please?

I'm using Moodle 3.3.2+, PHP 5.6

 
Average of ratings: -
Picture of Leon Stringer
Re: Unable to connect to Moodle download server.
Particularly helpful Moodlers

Is your Moodle site on a Microsoft Windows server? If so you may need to update your certificate bundle.

 
Average of ratings: -
Picture of Sokunthearith Makara
Re: Unable to connect to Moodle download server.
 

Hi Leon,

Thanks for your suggestion. My Moodle site is working fine now.

 
Average of ratings: -