Text editors

problem with the equation editor

Picture of Baloo belhaouane
problem with the equation editor


I am using moodle 2.0 and try to do a calculated question.

I cannot use the equation editor in the question text: when I click on the button, it tells me to download the last version of Java. Even if I have the last version of Java, I did it anyway but still doesn't work.

I need to write the symbol for the vectors: A⃗ A→ 

 Any help would be greatly appreciated. 

Average of ratings: -
Picture of Helen Foster
Re: problem with the equation editor
Core developersDocumentation writersMoodle HQParticularly helpful MoodlersPlugin developersTestersTranslators


If you're still using Moodle 2.0 then I'd recommend that you upgrade your site to a stable version of Moodle e.g. 3.1 as soon as possible for security reasons. You should find that the equation editor works then. Please see the documentation Upgrading for details.

Average of ratings: -
Picture of Baloo belhaouane
Re: problem with the equation editor

Thank you for the advice but the university I'm working for won't allow an upgrade not decided by the administration. Therefore, I have to work with the version 2.0 of moodle.

Average of ratings: -
Picture of AL Rachels
Re: problem with the equation editor
Core developersParticularly helpful MoodlersPlugin developersTesters

Hi Baloo,

I know people usually hate to hear it when some one says it works for them...but I do have an old Moodle 2.0 site and the equation editor available in the HTML editor does work for me. Even simpler to me, it also works if I just type in the Latex code directly. Have you also tried typing the Latex in directly? If it works typing the vector in, this would tend to indicate that you probably do have something wrong with your java.

Average of ratings: -
Picture of Baloo belhaouane
Re: problem with the equation editor

Hi Al,

Thank you for the tip but it doesn't work when I use directly the latex code for the vector: \( \vec{a} \).

I used this Code on the moodle Sandbox and it worked but it gave me the following picture on my normal moodle session:

Java is already upgraded on my computer and I can use the equation editor on the moodle sandbox without a problem.

Average of ratings: -
Picture of Ken Task
Re: problem with the equation editor
Particularly helpful Moodlers

This might not be what is needed ... a guess ...

Don't have a 2.0 (very old) to test this but the code is there in moodlecode/filter/tex/texdebug.php

Is the filter for LaTex turned on?   Is it configured?

There is an option in configuration to use Moodle's built in mimetex scripts or one can point to the location of the mimetex executable you desire to use.   The built-ins are located (oddly enough) in the same directory as the texdebug.php script ... moodlecode/filter/tex/ and one will see:


If you are on a Linux system (CentOS/RedHat/Ubuntu), Moodle should be using mimetex.linux

That file needs to be executable by the web server user and group:

-rwxrwxr-x 1 apache apache 1317676 Feb 14  2015 mimetex.linux

One can see it work from the command line ...

cd /pathtomoodlecode/filter/tex/

then type: ./mimetex.linux  (with no parameters).

You should see an ascii (text) representation of  Ascii dump of bitmap image... Hex dump of colormap indexes, asterisks denote "black" bytes (index=8)...  and The 9 colormap indexes denote rgb values... if it's functioning.

Test via browser (must be logged on):


Will allow you to enter latex code and see if the server can generate the gif.

Looks like ...

'spirit of sharing', Ken

Average of ratings: -