Installing and upgrading help

installation (version 5.5.31 is required and you are running 5.5.5.10.1.10)

 
Picture of renato agura
installation (version 5.5.31 is required and you are running 5.5.5.10.1.10)
 

hello guys it's my first post and my first time in moodle... i got this report during the server check "version 5.5.31 is required and you are running 5.5.5.10.1.10"  what should I do? im using XAMPP V3.2.2 please help me out...


 
Average of ratings: -
Picture of Usman Asar
Re: installation (version 5.5.31 is required and you are running 5.5.5.10.1.10)
Particularly helpful MoodlersPlugin developers

Renato,

are you sure about XAMPP version 3.2.2? as I dont remember seeing 3 and 4 series, after v.1.8.3, it was straight jump to version 5.6+, nothing  in between.

Are you using windows platform?

you can use windows installer package, that comes with everything preset, else if you want to  specifically use XAMPP, then download versions 5.5.33 / 5.6.19 /  7.0.4 all coming with MariaDB 10.1+

 
Average of ratings: -
Picture of AL Rachels
Re: installation (version 5.5.31 is required and you are running 5.5.5.10.1.10)
Core developersParticularly helpful MoodlersPlugin developersTesters

You are going to need to upgrade your database version. 31 is newer than 5. In those numbers, the period is used as a separator, not as a decimal point, so five.five.five is old version compared to five.five.thirty-one.

 
Average of ratings: -
Picture of Marina Glancy
Re: installation (version 5.5.31 is required and you are running 5.5.5.10.1.10)
Core developersMoodle HQParticularly helpful MoodlersPlugin developersTesters

Hello, you need to edit your config.php and specify database as "mariadb" instead of "mysqli"

There is an issue MDL-51080 about improving the error message

 
Average of ratings: Useful (6)
Picture of Richard Torres
Re: installation (version 5.5.31 is required and you are running 5.5.5.10.1.10)
 

Thanks for that tip, Marina! Worked like a charm.

 
Average of ratings: -
Picture of Trong Tri Nguyen
Trả lời: Re: installation (version 5.5.31 is required and you are running 5.5.5.10.1.10)
 

thanks Marina very much smile

 
Average of ratings: -
Picture of MoEiN MusaviPur
Re: installation (version 5.5.31 is required and you are running 5.5.5.10.1.10)
 

Hi

I Just Want To Test In Windows, i used xampp and this problem ...

I Cant Fix it. Help. In php.ini i cant find database

 
Average of ratings: -
Picture of Daniel Newton
XAMMP
 

Hello,

I am a novice to all of this Moodle carry on and need some help/advice.

I have XAMPP installed on my laptop which I am using to design a Wordpress website.

I want to install Moodle on the same laptop using the same XAMPP server. Would I be able to do this and would it have any impact on the Wordpress website I am building using the same XAMPP server? If not, would I be able to install a second XAMPP server onto my laptop and use that for the Moodle?


Thanks, Dan

 
Average of ratings: -
Picture of Rick Jerz
Re: XAMMP
Particularly helpful Moodlers

Dan, others might jump in and give you additional ideas.

I too have XAMPP running on my Mac and PCs, and have installed Moodle in each.  I do this for experimentation purposes, especially when not connected to the Internet.  From my knowledge, XAMPP is not meant for "live" Internet users, but you might know if this is possible from your experience with WordPress.  Is your WordPress "live" on the Internet?

Here's a quicky way to install Moodle.

1) Create a new database for Moodle.

2) Create a folder called "moodledata" one level down from your htdocs.

3) Download a copy of Moodle and unzip it into its own folder, such as htdocs/moodle.

4) Type Moodle's URL into your browser, such as http://localhost/moodle3, which will start the install process.

 
Average of ratings: Useful (1)
Picture of Daniel Newton
Re: XAMMP
 

Hello Rick,

Thanks for getting in touch. I am using XAMPP in the design of a website. The website is not yet finished and is not live online yet. Hopefully it will be finished in the next week and I will then put it online. I have opened a HostGator account and I want to integrate Moodle into my website. The website is an English language training site and I am incorporating ELearning tasks, hence the need for Moodle.


I am just worried that if I use the XAMPP installed on my PC for Moodle, it might delete or damage the website I am designing with WP.


What do you think will happen if I use the same XAMPP that I am using for WordPress to run Moodle?

With thanks,

Dan

 
Average of ratings: -
Picture of Rick Jerz
Re: XAMMP
Particularly helpful Moodlers

I am not a WordPress user.  I cannot see any reason why both applications cannot run on the same server, except unless they require different versions of php, possibly.  I am not sure how you plan to organize your website, and there are many ways.  I would put moodle into its own folder, such as "yourdomain.com/moodle" especially if you are trying to make your WordPress be your main website.

I have seen WordPress/Moodle integration discussed here on moodle.org, and there seems to be some ways to integrate the two, but I don't have this need so I really can't advise you.

I have had success developing a new install on XAMPP last December, and then moving it to my production severs.  It's not that hard to do (once you know what you are doing.  smile )

 
Average of ratings: Useful (1)
Picture of Taiwo Emmanuel
Re: XAMMP
 

Just follow the instructions as specified above by Rick Jerz, their will be no reason for interference of application or anything. Have used a single XAMMP installation with various CMS and moodle without any chaos. Just enure you have a separate db created for each applications installed.

BR

 
Average of ratings: Useful (1)
Picture of Dave Hope
Re: installation (version 5.5.31 is required and you are running 5.5.5.10.1.10)
 

Excellent, thanks Maria - worked like a charm!

 
Average of ratings: -
Picture of Azeem Abbas
Re: installation (version 5.5.31 is required and you are running 5.5.5.10.1.10)
 

Please clarify about the error issue.

After editing the config.php file I'm receiving the error:

"Config table does not contain version, can not continue, sorry.

More information about this error

It is usually not possible to recover from errors triggered during installation, you may need to create a new database or use a different database prefix if you want to retry the installation."

I clicked on the link and got this:

The most likely cause of this error is that the 'version' key is missing from your configuration dictionary.
Steps to fix:
  • Open <moodleinstalldir>/version.php
  • Find the value in $version
  • Open 'mdl_config' in database manager
  • Insert key after last entry with name = 'version' and value = <value found in version.php
Please help me sort out this problem.


 
Average of ratings: -
Picture of Marcus Green
Re: installation (version 5.5.31 is required and you are running 5.5.5.10.1.10)
Core developersParticularly helpful MoodlersPlugin developersTesters

What did you change in config.php?

 
Average of ratings: -
Picture of bipin gaur
Re: installation (version 5.5.31 is required and you are running 5.5.5.10.1.10)
 

Thank you Marina, I looked around and tried at least 20 different configuration, yours worked the first time .

 
Average of ratings: -
Picture of Andreu Martí
Re: installation (version 5.5.31 is required and you are running 5.5.5.10.1.10)
 

Thank you very very much Marina! I was trying to install different MariaDB versions in order to get rid of the warning message until I found your post.

All the best!

Andreu.-

 
Average of ratings: -
Picture of sadaf sadafian
Re: installation (version 5.5.31 is required and you are running 5.5.5.10.1.10)
 

Excellent, veryyyyyy thanks Maria

 
Average of ratings: -
Picture of Ronil Chand
Re: installation (version 5.5.31 is required and you are running 5.5.5.10.1.10)
 

thanks so much from Fiji...........was of great help

 
Average of ratings: -
Picture of Namanya Abert
Re: installation (version 5.5.31 is required and you are running 5.5.5.10.1.10)
 
Average of ratings: -
Picture of syed adil
Re: installation (version 5.5.31 is required and you are running 5.5.5.10.1.10)
 

@Marina you said, Hello, you need to edit your config.php and specify database as "mariadb" instead of "mysqli"


How do i go to config.php. Where is it located?

Can you give me a step by step guidance, i am new to this.

 
Average of ratings: -
Picture of Clément Michard
Re: installation (version 5.5.31 is required and you are running 5.5.5.10.1.10)
 

I think it's the /.../moodle/config.php file

 
Average of ratings: -
Picture of Clément Michard
It doesn't work for me
 

Hi there, 


I'm a total newbie at this, and I tried to install moodle on a local server on windows 10 (no one's perfect) (to try it, figure out the pb I could encounter, etc), so I began with Wamp, and it failed, so I migrated to Xampp, and the creation of the localhost worked fine. Until I tried to install moodle, and this error showed up. 

So, firtly, thanks for this post. Then, I chnaged the 'mysqli' to 'mariadb', rebooted apache and mysql (via Xampp), re-entered "localhost/moodle/", and it shows still the same error. Did I do something wrong ?


I noticed someone said to migrate to xampp 5.6 or higher, but I could'nt find it, and the version I've got aired feb 1...


thanks a lot

 
Average of ratings: -
Picture of aditya singh
Re: installation (version 5.5.31 is required and you are running 5.5.5.10.1.10)
 

Thanks Marina, this worked for me, hope we can have a setting for that in in our installation form.

 
Average of ratings: -
Picture of Cornelius Ehmke
Re: installation (version 5.5.31 is required and you are running 5.5.5.10.1.10)
 

Search for the string "$CFG->dbtype" This should show you the line you're looking to change.

 
Average of ratings: -
Prof. Jeziel
Re: installation (version 5.5.31 is required and you are running 5.5.5.10.1.10)
 
Marina,

Thank you very much.

I applied your suggestion and worked perfectly.

I translated your post to the Portuguese and sended to another groups in this language.

God bless you.

Jeziel


 
Average of ratings: -
Picture of Sunil Chhipa
Re: installation (version 5.5.31 is required and you are running 5.5.5.10.1.10)
 

Excellent..!! Thanks, Marina Glancy..!!

 
Average of ratings: -
Picture of James Steerpike
Re: installation (version 5.5.31 is required and you are running 5.5.5.10.1.10)
Particularly helpful Moodlers

Caught me as well running Debian Stretch. Glad your post pushed this up where I noticed it a few days ago.

 
Average of ratings: -
G. Grow
Re: installation (version 5.5.31 is required and you are running 5.5.5.10.1.10)
 

Just to clarify with some specific steps. If I left out any, please add them:

By the time the installation stops on the page of server checks, it has already created a moodle folder with a config.php inside it.  

Go to that config.php, open it in an editor, and change the line that specifies the db to mariadb, like this:

$CFG->dbtype    = 'mariadb';

After saving this change, return to the Moodle installation page where it stopped. Reload it.

If all is well, the installation should now continue. 

 
Average of ratings: -
G. Grow
Re: installation (version 5.5.31 is required and you are running 5.5.5.10.1.10)
 

Whoa! I think I have the solution. Does this work for you?

If your server uses mariadb, choose mariadb from the dropdown menu in early stages of the installation process.

Then the installation will no longer stop with the confusing message claiming that you have the wrong version of mysql.

The ideal error message would say that the database you specified does not match the one that is running. 

The workaround I posted above -- editing the config.php file -- also works, but it is unnecessary. 



 
Average of ratings: Useful (1)
Picture of Makmesh iKiev
Re: installation (version 5.5.31 is required and you are running 5.5.5.10.1.10)
 

Thanks, that was really helpful

 
Average of ratings: -
Picture of Atif Azad
Re: installation (version 5.5.31 is required and you are running 5.5.5.10.1.10)
 

Awesome! Thanks Maria, That's work for me also 

 
Average of ratings: -
Picture of tim st.clair
Re: installation (version 5.5.31 is required and you are running 5.5.5.10.1.10)
Plugin developers

 Thanks for the tip! I came across it because I initially installed on a MySQL box (and hence chose mysqli as the driver) then moved the site to a different box with Maria DB 10.2.10 before the upgrade to Moodle 3.4. Be good to have this changed / mentioned during the upgrade step, perhaps show the current db driver setting?

 
Average of ratings: -
Picture of Rahul Rai
Re: installation (version 5.5.31 is required and you are running 5.5.5.10.1.10)
 

Hi Renato

I thing what is you problem facing.

Moodle’s upgrade check gives only the error: “version 5.5.31 is required and you are running 5.5.5.10.0.20”. This error leads to things like issue #45070 and not the fix in the blog.

 
Average of ratings: -