Installation help

 
 
Picture of Patricia Loofbourrow
Do I need to upgrade?
 

Hi, I just got Moodle 2.3.3, which was installed on my BlueHost account through MOJO. I haven't installed anything else.

I see that the most recent version is 2.5.1+, but although I am fine with following directions, the directions on upgrading are going over my head here.

For example, it says to "move files to another directory". Which files? What directory? It looks like moodledata is on both my public_html and my www directories -- do I need to move everything on them to both? If so, where is it safe to move them?

So my question is (unless you want to walk me through this): Is there going to be a problem if I don't upgrade? Or is this going to cause a lot of problems later on?

Thanks for your help.

 
Average of ratings: -
Picture of Howard Miller
Re: Do I need to upgrade?
Group DevelopersGroup Documentation writersGroup Particularly helpful Moodlers

To answer your second question first - you don't *need* to upgrade but it's living dangerously if upgrading is a problem for you. If a serious security issue comes along or some bug is affecting your workflow then there'll be nothing you can do about it. 

Version 2.3 is now only supported for security fixes, so there'll be no more general bug fixes anyway. 

I've no idea what MOJO is... is this one of these 'one click' installer scripts for Moodle? If it is, you might want to think about asking BlueHost how you can upgrade. We generally have no idea how these scripts installed Moodle so it's very difficult to give you support.

The most important thing is that you have good backups of your site. If you have backups then it's hard to do anything all that terrible performing an upgrade.

 
Average of ratings: -
Gmads
Re: Do I need to upgrade?
Group Particularly helpful MoodlersGroup Testers

Hi Patricia,

Technically, you could go and use your M 2.3.3 site for a long time. Yes, security could be an issue, but that is just like everything else in life. Is that a big problem? There are people still using 1.9, or even older versions like 1.7, without problems.

Putting subtle issues aside, I'd say the only future problem would be that of upgrading to a newer more distant version than your current one. People upgrading from version 2.2 to 2.5, definitely have an easier job than those trying to do it from 1.7, for example.

Before considering a version upgrade, you first need to make sure that your server has the minimum required components (http://download.moodle.org/) :

PHP 5.3.3, MySQL 5.1.33 or Postgres 8.3 or MSSQL 2005 or Oracle 10.2

Assuming you can upgrade, the real question then is, do you need to upgrade, or would you like to upgrade? If so, yes, we can walk you through.

Cheers!

 
Average of ratings:Useful (2)
Picture of Visvanath Ratnaweera
Re: Do I need to upgrade?
Group Particularly helpful Moodlers
Patricia

Fully agree with Guillermo.

In case you are wondering when the support ends, here's the time-line: http://docs.moodle.org/dev/Releases
 
Average of ratings:Useful (1)
Picture of Patricia Loofbourrow
Re: Do I need to upgrade?
 

Yes, my server can handle the upgrade.

I'm contacting MOJO, who installed it in the first place  (https://www.mojomarketplace.com -- seems to be an app company) to see if they can do the upgrade as they offer free upgrades on the site.

Thanks!

 
Average of ratings: -
Gmads
Re: Do I need to upgrade?
Group Particularly helpful MoodlersGroup Testers

OK, if your server complies with the minimum requirements that's one less problem to worry about.

As a beginner one normally starts using "automatic installers or upgraders", experience though, only proves that this method isn't very reliable. Anyway, even if they can do it and you decide to let them do it, please do make a full site backup before anything else:

http://docs.moodle.org/23/en/Site_backup

If you have any doubts about this process, do not hesitate to ask for help. Omitting this very important step can turn a simple upgrade procedure into a real nightmare (just check some threads in these forums).

 
Average of ratings:Useful (1)
Picture of Patricia Loofbourrow
Re: Do I need to upgrade?
 

I noticed that 2.3.3 is only supported for security through December. So if MOJO can't/won't do the upgrade, I'll be back near the end of the year (after I get this class going) to get your help ... wink

 
Average of ratings: -
Picture of Visvanath Ratnaweera
Re: Do I need to upgrade?
Group Particularly helpful Moodlers
I Patricia

I hope you were talking to Guillermo. In case you upgrade during the semester and run into trouble I don't want to be a part of it!
;-(

May be I'm over caring. During the 1.9 to 2.x transition so many things went wrong, I'm a burnt child, you can say. I still plan the transition day to be in a vacation and http://docs.moodle.org/24/en/Upgrade a copy of the site http://docs.moodle.org/23/en/Moodle_migration first and test it. Just before the transition, I take a http://docs.moodle.org/23/en/Site_backup.
 
Average of ratings:Useful (2)
Gmads
Re: Do I need to upgrade?
Group Particularly helpful MoodlersGroup Testers

LOL! big grin

Yes, that 1.9 to 2.x upgrade can be quite a trip!

 
Average of ratings:Useful (1)
Picture of Patricia Loofbourrow
Re: Do I need to upgrade?
 

Thanks for the tips! smile

 
Average of ratings: -