General help

 
 
Picture of Aditya Kakodkar
"New window" behaviour in v 2.4
 

Upgraded to Moodle 2.4 yesterday. While the overall features look good, our content creators are not very happy about the behaviour of the display option "New window" for external links in v2.4.

Previously the display option "New window" would open the external links directly. But, since the upgrade, an intermittent page with title,description and the external link is displayed in the new window. This extra step is starting to cause much anguish amongst our content creators.

Is there a way to revert to the old way (open links directly in the new window)?

P.S. We upgraded  from v2.1 to v2.2 and then to v2.4.

http://classroom.oceanteacher.org

 
Average of ratings: -
Picture of Ken Task
Re: "New window" behaviour in v 2.4
Group Particularly helpful Moodlers

As an Admin user, login and use 'open' in site search.

2 hits to check settings:

File: Default: Automatic, Embed, Force download, Open, In pop-up

Select all options that should be available, existing settings are not modified. Hold CTRL key to select multiple fields.

and 2nd hit

URL: Default: Automatic, Embed, Open, In pop-up

Select all options that should be available, existing settings are not modified. Hold CTRL key to select multiple fields

Both should give more options for controlling links and display of those links.

'spirit of sharing', Ken

 

 
Average of ratings: -
Picture of Aditya Kakodkar
Re: "New window" behaviour in v 2.4
 

Ken, changing default settings is not a problem here. Please read the thread below (from Rick).

Thanks for your reply

Adi

 
Average of ratings: -
Picture of Rick Jerz
Re: "New window" behaviour in v 2.4
Group Particularly helpful Moodlers

This is a known bug and is being worked on as we speak, see MDL-37015.

Please vote for it so that it continues to get high priority.

I discovered the exact same problem about a week ago, when I upgraded my experimental Moodle website.  This single problem is causing me to wait to upgrade my production website because I use the "New Window" feature a lot (like in 75% of my activites).

 
Average of ratings:Useful (2)
Picture of Aditya Kakodkar
Re: "New window" behaviour in v 2.4
 

Thanks Rick, voted.

 
Average of ratings: -
Picture of Rick Jerz
Re: "New window" behaviour in v 2.4
Group Particularly helpful Moodlers

I thought that I would mention that the moodle developers fixed this problem today.  The fix is in the newest version of Moodle 2.4.

 
Average of ratings:Useful (1)
Picture of Christopher Blake
Re: "New window" behaviour in v 2.4
 

Awesome!

 
Average of ratings: -
Me
Re: "New window" behaviour in v 2.4
 

I am very new to the upgrading process. How do I get this fix in the 2.4 version (build 20121203) I am using?

 
Average of ratings: -
Picture of Rick Jerz
Re: "New window" behaviour in v 2.4
Group Particularly helpful Moodlers

Hi DeWayne, the very simple answer to your question is that the fix is already in the latest stable release of Moodle 2.4 at http://download.moodle.org/.

My guess, however, is that your question might be "how do I upgrade," right? If so, the simple answer to this question can be found in the Moodle docs.  But I have seen some of yours and others discussions that "simple" is not always "simple".  But it can be.  (By the way, I forget where you are with your system because I haven't watch your posts carefully enough.)

Last night, I wasn't sure if this fix was incorporated into the latest release, so I upgraded my "experiment" moodle.  This took me less than 10 minutes, really!  Now that the two major problems that I had with Moodle 2.4 are resolved, I am ready to upgrade my production moodle site.  It too should take less than 10 minutes, but I am always very careful, so when ready, I will do the upgrade more casually.  It might take me 20 minutes.  I am between semesters, so there is no urgent rush.  I will probably upgrade sometime today, giving me several weeks to make sure everything in Moodle 2.4 is ready for students.

 
Average of ratings: -
Me
Re: "New window" behaviour in v 2.4
 

It wored, kind of; I cannot login. When I did upgrades like this in 1.9 I had to delete the session files in the moodledata. That does not exist in 2.4; is ther something like that I have to do here?

 
Average of ratings: -
Picture of Rick Jerz
Re: "New window" behaviour in v 2.4
Group Particularly helpful Moodlers

Did you make sure to retain your config.php file from your old moodle, and move it to your new moodle?  I am not sure about the "session files".  Even when I was running Moodle 1.9+, I don't recall needing to do this.  Nope, I don't do anything like this in 2.4 either.

 
Average of ratings: -
Me
Re: "New window" behaviour in v 2.4
 

opps, I forgot to copy that over. I did now and it works. Sorry.

 

Thanks

 
Average of ratings: -
Picture of Rick Jerz
Re: "New window" behaviour in v 2.4
Group Particularly helpful Moodlers

Make sure to keep of list of things to do when you upgrade so that you don't forget. 

I think that you are getting the hang of this Moodle stuff, and maybe even starting to enjoy it a little.  smile

By the way, just a hour ago, I upgraded my production Moodle 2.3 to 2.4.  Everything went well.

 
Average of ratings: -
Picture of Aditya Kakodkar
Re: "New window" behaviour in v 2.4
 

Thanks Rick, Could not upgrade earlier due to some ongoing courses. Upgraded to 2.4.3 yesterday. Things seem fine.

Regards,Adi

 
Average of ratings: -
Picture of Marc Dastous
Re: "New window" behaviour in v 2.4
 

Just downloaded the latest stable version of 2.5+ and the problem has returned. Cannot open a new tab, or window, without the intermediate page appearing. ARGH!!!!

 
Average of ratings: -