Your Moodle version

Question types: Matrix question

qtype_matrix
Maintained by Picture of Laurent Opprecht Laurent Opprecht, Picture of Nicolas Dunand Nicolas Dunand
Matrix question type.
167
178
2

Matrix question type. Adds support for k' grading as well as a streamlined user interface.

This question type allows the teacher to define the rows and columns that make up a matrix. Students can select either multiple or single answers per row, depending on how the question has been configured. Each row receives a grade defined by one of the grading methods. The final grade for the question is an average of their grades for each of the rows.

Screenshots

Screenshot #0

Contributors

Picture of Laurent Opprecht
Laurent Opprecht (Lead maintainer)
Picture of Nicolas Dunand
Nicolas Dunand: Developper
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of James Thomas
    Sat, Jun 23, 2012, 11:29 AM
    What is it? What does it do? Where is the description or image?
  • Picture of Ivana Boskovic
    Sat, Jul 21, 2012, 6:51 PM
    Description from Moodle 2.3.:

    "This question type allows the teacher to define the rows and columns that make up a matrix. Students can select either multiple or single answers per row, depending on how the question has been configured. Each row receives a grade defined by one of the grading methods. The final grade for the question is an average of their grades for each of the rows."
  • Picture of Education Technology
    Thu, Apr 4, 2013, 7:03 AM
    Hi, I'm quite new with installing plugins, we're currently running on 2.3. I've tried installing it but it doesn't show up in any of the question types. Is this compatible with 2.3? Do I need to have old versions of Moodle for it to run?
  • Picture of Laurent Opprecht
    Thu, Apr 4, 2013, 2:16 PM
    Cheers, the plugin was developped for moodle 1.9 et 2.0. I am afraid moodle 2.1? introduced a new question engine so it is no surprise it doesn't work. We plan to update the plugin during our next migration but I am afraid it is not scheduled for this year.
  • Picture of Huy Hoang
    Tue, Jan 14, 2014, 5:16 AM
    the style.css is full of !important, which should never be used generally. These three rules basically affect every pages (especially for tablet users)

    #page-content .region-content{
    overflow: visible !important;
    }

    #page-content #region-main {
    overflow: visible !important;
    }
    #page-content {
    overflow: visible !important;
    }
  • Picture of Hugo Ribeiro
    Thu, Jan 16, 2014, 12:12 AM
    Is there any way to export/import the questions?
  • Picture of Ron San
    Fri, Oct 17, 2014, 2:41 PM
    will this be upgraded? i have been looking for this type of question for a long time. i hope you provide the latest version. thanks in advance
  • Picture of Martin Greenaway
    Mon, Nov 16, 2015, 9:24 PM
    Just to save people the trouble - this does not work on 3.0 and in fact causes a whole heap of problems if you try. ref: https://moodle.org/mod/forum/discuss.php?d=323266#p1297791
  • Picture of Nicolas Dunand
    Mon, Jan 25, 2016, 8:21 PM
    Martin, it seems you're referring to the outdated version of this plugin (listed here on this page). However, as stated at the top of this page, "See repo for latest [...] versions". The latest version available from GitHub since last September (see "Source control URL" link above) works fine on Moodle 2.7-3.0.
  • Picture of Martin Greenaway
    Mon, Jan 25, 2016, 8:43 PM
    Hi Nicolas - thanks for the clarification. It may be advisable to amend the text at the top of the page in that case, because I read that line as suggesting that the latest and older versions were 1.9 and 2.0, not that this version from this page was 1.9 and 2.0 which I'm guessing from your comment is actually the case.
Please login to post comments