Your Moodle version

Activities: Reader

mod_reader
Maintained by Picture of Gordon Bateson Gordon Bateson
The Reader module for Moodle 2.x tracks the students' reading achievements.
1k
113
5
Moodle 2.0, 2.1, 2.2, 2.3, 2.4, 2.5, 2.6, 2.7, 2.8, 2.9

Overview

The Reader module for Moodle 2.x tracks the students' reading achievements by maintaining a total of the number words each student reads. After reading one of the books at an appropriate reading level, a student takes quiz to demonstrate a reasonable understanding of the content of the book. If they pass the quiz, the number of words in the book is added to the total number of words they have read. Students are encouraged to work toward the reading goal, which is the number of words the teacher expects them to read in a term. Various reports are available to the teacher who can adjust the reading goals, student levels, and book difficulty if required.

Dependencies

The Reader module requires the Ordering question type for Moodle 2.x

Changes

To view details of recent changes made to this plugin, please click on the following link:

Screenshots

Screenshot
Screenshot
Screenshot

Contributors

Picture of Gordon Bateson
Gordon Bateson (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of Rob Bright
    Wed, Nov 20, 2013, 4:02 PM
    Ok, thanks for that.

    I downloaded that version but now this error pops up.

    Data for the following books was downloaded: switch_minus
    Error writing to database

    More information about this error

    Debug info: Unknown column 'answers' in 'field list'
    UPDATE mdl_qtype_multichoice_options SET answers = ? WHERE questionid = ?
    [array (
    0 => '',
    1 => 228,
    )]
    Error code: dmlwriteexception
    Stack trace:
    line 444 of /lib/dml/moodle_database.php: dml_write_exception thrown
    line 1258 of /lib/dml/mysqli_native_moodle_database.php: call to moodle_database->query_end()
    line 1598 of /lib/dml/moodle_database.php: call to mysqli_native_moodle_database->set_field_select()
    line 2164 of /mod/reader/admin/download/downloader.php: call to moodle_database->set_field()
    line 2117 of /mod/reader/admin/download/downloader.php: call to reader_downloader->add_question_postprocessing_multichoice()
    line 1026 of /mod/reader/admin/download/downloader.php: call to reader_downloader->add_question_postprocessing()
    line 588 of /mod/reader/admin/download/downloader.php: call to reader_downloader->add_question_categories()
    line 464 of /mod/reader/admin/download/downloader.php: call to reader_downloader->add_quiz()
    line 100 of /mod/reader/admin/download.php: call to reader_downloader->add_selected_itemids()
  • Picture of Rob Bright
    Sat, Nov 30, 2013, 4:12 PM
    Thanks for the fix, working great now!
  • Picture of John Gifford
    Mon, Dec 2, 2013, 8:29 PM
    I just tried to install this mod and got a warning about qtype_ordering. I'm using Moodle 2.4.5+
  • Picture of Gordon Bateson
    Tue, Dec 3, 2013, 8:22 AM
    You can download the ordering question type (for any Moodle 2.x) from the following link:
    https://github.com/gbateson/moodle-qtype_ordering/archive/master.zip
  • the Tallest Man in Western Japan?
    Sat, Mar 22, 2014, 8:57 AM
    Hi Gordon,

    Have Moodle 2.6.2+ (20140314) and accessing a quiz in Moodle reader gives me this:

    get_context_instance() is deprecated, please use context_xxxx::instance() instead.
    line 4020 of /lib/deprecatedlib.php: call to debugging()
    line 3767 of /mod/reader/lib.php: call to get_context_instance()
    line 3495 of /mod/reader/lib.php: call to reader_cheatsheet_init()
    line 60 of /mod/reader/view_books.php: call to reader_search_books()

    I also get numerous php errors when trying to access the new Admin area:

    build_navigation() is deprecated, please use $PAGE->navbar methods instead.
    line 1988 of /lib/deprecatedlib.php: call to debugging()
    line 974 of /mod/reader/admin.php: call to build_navigation()

    Notice: Undefined property: stdClass::$last_update in /var/www/html/moodle/2x/mod/reader/admin.php on line 1101 Notice: Undefined property: stdClass::$update_interval in /var/www/html/moodle/2x/mod/reader/admin.php on line 1101

    I am assuming this happened due to our migration to version 2.6.2.

    Is there something I can do to help troubleshoot/repair this problem?

    -Thom
  • Picture of Jesse H
    Sun, Jul 27, 2014, 7:33 PM
    I'm also having issues in 2.7
    Debug info: Table 'mdl_question_ordering' already exists
    CREATE TABLE mdl_question_ordering (
    id BIGINT(10) NOT NULL auto_increment,
    question BIGINT(10) NOT NULL DEFAULT 0,
    logical TINYINT(2) NOT NULL DEFAULT 0,
    studentsee TINYINT(2) NOT NULL DEFAULT 0,
    correctfeedback LONGTEXT CHARACTER SET utf8 COLLATE utf8_general_ci,
    partiallycorrectfeedback LONGTEXT CHARACTER SET utf8 COLLATE utf8_general_ci,
    incorrectfeedback LONGTEXT CHARACTER SET utf8 COLLATE utf8_general_ci,
    CONSTRAINT PRIMARY KEY (id)
    , KEY mdl_quesorde_que2_ix (question)
    )
    ENGINE = InnoDB
    DEFAULT CHARACTER SET utf8
    DEFAULT COLLATE = utf8_general_ci
    COMMENT='Options for ordering questions'
    Error code: ddlexecuteerror
    Stack trace:
    line 449 of /lib/dml/moodle_database.php: ddl_change_structure_exception thrown
    line 839 of /lib/dml/mysqli_native_moodle_database.php: call to moodle_database->query_end()
    line 76 of /lib/ddl/database_manager.php: call to mysqli_native_moodle_database->change_database_structure()
    line 412 of /lib/ddl/database_manager.php: call to database_manager->execute_sql_arr()
    line 364 of /lib/ddl/database_manager.php: call to database_manager->install_from_xmldb_structure()
    line 499 of /lib/upgradelib.php: call to database_manager->install_from_xmldb_file()
    line 1615 of /lib/upgradelib.php: call to upgrade_plugins()
    line 434 of /admin/index.php: call to upgrade_noncore()
  • Paul
    Wed, Jan 7, 2015, 5:04 PM
    When I try to install into either Moodle V6 or 7 I get an error which flags saying that the depenancies check failed, even though everything else checked out fine during the install.
  • Picture of Dale Davies
    Wed, Jan 7, 2015, 5:14 PM
    Hi there, the plugin installed fine but after creating a new reader activity I get an "error reading from database" error sad
  • Picture of Gordon Bateson
    Wed, Jan 7, 2015, 5:24 PM
    Dale Davies, we need more details about that error. Try enabling Moodle debugging and display of error messages (Site administration -> Development -> Debugging), and see if you can get a fuller error message.
  • Picture of Gordon Bateson
    Wed, Jan 7, 2015, 5:25 PM
    Paul Raper, if you read the dependancy notices carefully they should tell you what other plugins need to be installed. For the Reader module, you probably need to install the ordering question type. You can find it in the plugins repository on moodle.org (https://moodle.org/plugins/view.php?plugin=qtype_ordering)
  • Picture of michell mejia
    Thu, Jan 8, 2015, 11:54 PM
    please help me where i need upload the book.... i have this message in Books ->Edit -> mode_edit()
  • Picture of michell mejia
    Fri, Jan 9, 2015, 12:01 AM
    Debug info: Unknown column 'ra.readerid' in 'where clause'
    SELECT ra.*, rb.difficulty, rb.id AS bookid FROM mdl_reader_attempts ra JOIN mdl_reader_books rb ON ra.bookid = rb.id WHERE ra.userid = ? AND ra.readerid = ? AND ra.deleted = ? AND ra.timefinish > ? ORDER BY ra.timemodified
    [array (
    0 => '2',
    1 => '1',
    2 => 0,
    3 => '1420693200',
    )]
    Error code: dmlreadexception
    Stack trace:
    line 443 of /lib/dml/moodle_database.php: dml_read_exception thrown
    line 1014 of /lib/dml/mysqli_native_moodle_database.php: call to moodle_database->query_end()
    line 594 of /mod/reader/lib.php: call to mysqli_native_moodle_database->get_records_sql()
    line 123 of /mod/reader/view.php: call to reader_get_level_data()
  • Picture of Gordon Bateson
    Fri, Jan 9, 2015, 9:23 AM
    Michell Meija, sorry about that error message. I have fixed it now. Please download the latest version of the Reader module and try again.
  • Picture of michell mejia
    Fri, Jan 9, 2015, 11:57 PM
    My friend the other problem is resolved but now, tell me where i can upload books? and i have this error in books --> EDIT --> ONLY SHOW mode_edit()
  • Picture of Gordon Bateson
    Wed, Jan 14, 2015, 12:00 PM
    Michell Mejia, above where it says "mode_edit()", you will see a link to "Download books with quizzes". Please click that. You need to create an account on moodlereader.org in order to download book data and quizzes.
1 2
Please login to post comments