Activities: JClic

mod_jclic
Maintained by Picture of Projectes TAC Dep. Educació CatalunyaProjectes TAC Dep. Educació Catalunya, Picture of Sara Arjona TéllezSara Arjona Téllez, Picture of Pau Ferrer OcañaPau Ferrer Ocaña
This module allows the incorporation of JClic activities in Moodle and save its state.
862 sites
541 downloads
16 fans
Moodle 2.0, 2.1, 2.2, 2.3, 2.4, 2.5, 2.6

JClic [http://clic.xtec.cat/] is a set of free software for the development of multimedia educational activities.

This module allows the incorporation of JClic activities in Moodle. Its main features are:
- Allows embedding easily JClic activities in some Moodle course.
- Facilitates students tracing because it stores the score, date and duration of each of the attempts made by the users.

It has been developed by the Departament of Education of Catalonia.

Screenshots

Screenshot #0
Screenshot #1
Screenshot #2

Contributors

Picture of Projectes TAC Dep. Educació Catalunya
Projectes TAC Dep. Educació Catalunya (Lead maintainer)
Picture of Sara Arjona Téllez
Sara Arjona Téllez: JClic module for Moodle lead maintainer
Picture of Pau Ferrer Ocaña
Pau Ferrer Ocaña: JClic module for Moodle lead maintainer
Picture of Francesc Busquets
Francesc Busquets: JClic lead maintainer
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of Nicolás Cabello
    Sun, Oct 15, 2017, 6:00 AM
    Hola Francesc,
    Gracias por la respuesta. No sé qué ocurrió la vez anterior pero acabo de probar JClic en la versión Moodle 3.3+ y funciona perfectamente.
  • Picture of josep font bon
    Tue, Jan 8, 2019, 6:47 AM
    Hola.
    Instale la versión del moodle 2.8 para tener la máxima compatiblidad con el modulo de jclic, y ahora resulta que no me cargan los jclics. Al lado de mostrar resultados me aparece este mensaje breve. duedate: Me podeis ayudar? Muchas gracias.
  • Picture of Francesc Busquets
    Tue, Jan 8, 2019, 5:01 PM
    Hola Josep,

    Moodle 2.8 es muy antiguo y ya no está en mantenimiento. El módulo debería funcionar correctamente con las versiones actuales de Moodle. Muchas escuelas de Cataluña lo estan utilizando con Moodle 3.4 (la versión actualmente utilizada en Àgora-Moodle), pero lo hemos probado también con 3.5 y 3.6 sin problemas.

    Asegúrate de utilizar la última versión del repositorio GitHub, que se encuentra en:
    https://github.com/projectestac/moodle-mod_jclic

    Próximamente actualizaremos también las versiones en este espacio de Moodle.org, pero por ahora las versiones de GitHub son las más recientes.

    Ten en cuenta que el plugin de JClic funciona ahora en HTML5, y puede hacerlo a partir de un proyecto ya publicado en Internet (por ejemplo, cualquier actividad de la biblioteca zonaClic: https://clic.xtec.cat/repo/ o las bibliotecas personales de usuarios XTEC: https://clic.xtec.cat/mylib/), o bien subiendo a Moodle un archivo de tipo ".scorm.zip" que puedes generar con las versiones más recientes de JClic Author (https://clic.xtec.cat/legacy/es/jclic/download.htm)

    Espero que te funcione correctamente. En caso de error, intenta recopilar la máxima información posible y abre una incidencia en: https://github.com/projectestac/moodle-mod_jclic/issues

  • Picture of josep font bon
    Wed, Jan 9, 2019, 12:25 AM
    Gràcies Francesc, quan he fet l'actualització en la darrera pantalla m'apareix encara aquest missatge:
    "Prohibido
    No tiene permiso para acceder a /moodle28/admin/upgradesettings.php en este servidor.
    Además, se encontró un error 403 Prohibido al intentar usar un ErrorDocument para manejar la solicitud."

    He d'instalar obligatoriament la vesió 3.5 i 3.6?
  • Picture of Francesc Busquets
    Wed, Jan 9, 2019, 2:15 AM
    Hola Josep,

    Moodle 2.8 és del 2014, i el suport va acabar el 2016.

    Aquí tens la referència de versions:
    https://docs.moodle.org/dev/Releases

    Hauries de passar-te com a mínim a Moodle 3.1 (suportat fins a maig 2019), tot i que el més aconsellable seria anar a 3.5, que compta amb "suport a llarg termini" (LTS) i estarà mantingut fins a abril de 2021.
  • Picture of josep font bon
    Wed, Jan 9, 2019, 4:04 AM
    Hola Busquets,
    He instalat en el hosting x10 el moodle 3.3.6 i la versio 3 del modul de jclic. I continua sense cargar el jclic. He fet també l'actualització del java. I he vist que quan obric un jclic amb el jclic, l'obri correctament. Em pots ajudar ja no sé que fer...
    L'ordre de l'instal·lació ha sigut: Primer instal·lar el moolde i despres l'extensió. Passant tots els paràmetres correctament, i apareixent "éxito" i en la darrera quan apareix "guardar como" i al fer clic és quan m'ha aparegut l'error d'abans novament:
    "Prohibido
    No tiene permiso para acceder a /moodle28/admin/upgradesettings.php en este servidor.
    Además, se encontró un error 403 Prohibido al intentar usar un ErrorDocument para manejar la solicitud."
  • Picture of Francesc Busquets
    Wed, Feb 6, 2019, 4:51 PM
    Hola Josep,
    Acabo de veure el teu comentari. Sembla que tens un problema de permisos de fitxers en el teu servidor, o potser estàs intentant fer un upgrade saltant massa versions de cop (de 2.8 a 3.3 són moltes versions!)
    En tot cas, l'error fa referència al "core" de Moodle (fitxer "/moodle28/admin/upgradesettings.php"), no sembla que sigui un problema específic del mòdul de JClic.
  • Picture of Francesc Busquets
    Wed, Feb 6, 2019, 4:52 PM
    Version 3.0.3 just released in moodle.org.
    It should work properly with Moodle 3.4, 3.5 and 3.6 (and probably also with older versions)
  • Picture of raoul richa
    Mon, Nov 25, 2019, 4:06 PM
    Hello
    I installed jclic plugin 3.0.3 in moodle 3.6.2.
    when i start a jclic activity i get this : "There is no session for this activity yet."
    as an administrator I can preview the activity correctly.
    Thanks for your feedback
  • Picture of Projectes TAC Dep. Educació Catalunya
    Tue, Nov 26, 2019, 3:08 AM
    Hi Raoul,
    When you open a JClic activity as a teacher or admin the main page is for results view, but there is a link in the "Administration" panel labeled "Preview JClic activity". This link will launch the activities in preview mode.

    Hope this helps!
  • Picture of Nicolás Cabello
    Fri, Mar 20, 2020, 12:54 AM
    Saludos,
    Les cuento que llevo un tiempo usando JClic en moodle, pero últimamente (mi versión de moodle es 3.7.2) me he percatado que no se alcanza a visualizar el boton para poner en pantalla completa la actividad JClic, esto me sucede en computador de escritorio con google chrome y firefox. Entre la barra de navegación y el menú es muy poco el espacio que deja moodle a la actividad JClic por lo que el boton de pantalla completa era de bastante útilidad. De antemano gracias
  • Picture of Juan Ignacio
    Thu, Mar 26, 2020, 5:09 AM
    En moodle 3.8.1 no se logras visualizar la actividad en la ultima version del plugin. 3.0.3
  • Picture of Francesc Busquets
    Fri, Apr 24, 2020, 9:46 PM
    Hola Juan Ignacio,

    Hemos actualizado el módulo HTML5 de JClic para solucionar un problema que impedía su funcionamiento en Moodle 3.8, relacionado con [este error](https://github.com/babel/babel-loader/issues/401) del módulo `babel-polyfill`.

    Para comprobar el funcionamiento solo hay que recargar la página. Si aparece algún otro error, repórtalo por favor en: https://github.com/projectestac/moodle-mod_jclic/issues
  • Picture of Francesc Busquets
    Fri, Apr 24, 2020, 9:51 PM
    Hola Nicolás,

    La actualización del módulo HTML5 de JClic soluciona también el problema con el botón de pantalla completa. Ahora ya debería funcionar.

    Hemos solucionado también un problema que aparecía en las actividades que utilizan la grabación de voz del usuario. Ahora debería funcionar con cualquier navegador web moderno.
  • Picture of Nicolás Cabello
    Mon, May 11, 2020, 8:25 PM
    Si, funciona. Muchas gracias
1 2 3
Please login to post comments