Your Moodle version

Activities: Flash Card Set

mod_flashcard
Maintained by Picture of Tomasz Muras Tomasz Muras, Picture of Valery Fremaux Valery Fremaux
Flashcards

Important information.

The flashcard module was originally written by Valery for 1.9. It was hosted on the old Moodle plugins database, there was also an version initially ported to Moodle 2.

Tomek took over the work on it, finished porting into Moodle 2 and done few releases on the new plugins database page (this one). The latest version of this module is 3.2 and is available on github: https://github.com/tmuras/Moodle-Flashcard . It includes set of fixes from alekiy that should get it to work on Moodle 2.5. You can use it but this development is dis-continued.

Valery has now updated his branch of flashcard module into Moodle 2.5. The source code is https://github.com/vfremaux/moodle-mod_flashcard and the latest release is also on this, new plugins database as 2.4.0 (Build 2012040100). This is the branch you should be using now.

Both versions of flashcard module have diverged and are not compatible with each other. It's not possible to easily switch from one version (3.1 or 3.2) to another (2.4.0) without re-installing (and hence loosing all data).

Contributors

Picture of Valery Fremaux
Valery Fremaux (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of Andreas Grupp
    Mon, Jan 13, 2014, 5:12 PM
    Hello
    just tried the upgrade from 2012071800 to 2014010600 in the new Moodle 2.6.1. I have the same problem as Rodney. The error message is:

    Debug info: Unknown column 'customreviewemptyfileid' in 'mdl_flashcard'
    ALTER TABLE mdl_flashcard ADD extracss LONGTEXT CHARACTER SET utf8 COLLATE utf8_unicode_ci AFTER customreviewemptyfileid
    Error code: ddlexecuteerror
    Stack trace:

    line 447 of /lib/dml/moodle_database.php: ddl_change_structure_exception thrown
    line 833 of /lib/dml/mysqli_native_moodle_database.php: call to moodle_database->query_end()
    line 88 of /lib/ddl/database_manager.php: call to mysqli_native_moodle_database->change_database_structure()
    line 77 of /lib/ddl/database_manager.php: call to database_manager->execute_sql()
    line 538 of /lib/ddl/database_manager.php: call to database_manager->execute_sql_arr()
    line 310 of /mod/flashcard/db/upgrade.php: call to database_manager->add_field()
    line 670 of /lib/upgradelib.php: call to xmldb_flashcard_upgrade()
    line 395 of /lib/upgradelib.php: call to upgrade_plugins_modules()
    line 1580 of /lib/upgradelib.php: call to upgrade_plugins()
    line 431 of /admin/index.php: call to upgrade_noncore()

    This problem seems to be still in the January version. Any help???
  • Picture of Krister Viirsaar
    Tue, Jan 21, 2014, 5:05 PM
    Updating from 2012080800 to 2014010600 on Moodle 2.6.1, getting EXACTLY the same error as Rodney Wolford and Andreas Grupp.
  • Picture of Valery Fremaux
    Tue, Jan 21, 2014, 5:20 PM
    This seems a break in the upgrade chain between branches... Could you try the following : Revert the flashcard in version 2012040201 in the table mdl_modules of Moodle, and rerun the updater...
  • Picture of Valery Fremaux
    Tue, Jan 21, 2014, 5:21 PM
    Note that the flashcard upgrade chain discontinues the previous version from Tomaz Muras, as the model did have big shifts between both tracks...
  • Picture of Krister Viirsaar
    Tue, Jan 21, 2014, 5:45 PM
    Valery, you mean to say that upgrading from 3.2 to 2.6 is impossible and needs to be completely reinstalled?
  • Picture of Krister Viirsaar
    Tue, Jan 21, 2014, 5:47 PM
    Because "2012080800" that i'm upgrading from is 3.2.
  • Picture of Krister Viirsaar
    Tue, Jan 21, 2014, 5:48 PM
    Also the version Andreas Grupp is upgrading from is 3.1.
  • Picture of Krister Viirsaar
    Tue, Jan 21, 2014, 5:49 PM
    I know this is in the Description. But then not everything makes sense, because then why does moodle tell me there is a new version if upgrading is impossible?
  • Picture of Krister Viirsaar
    Tue, Jan 21, 2014, 7:01 PM
    So if you could just confirm there is no way to get from 3.2 to 2.6 without losing the data. Also, 3.2 will not work on 2.6 or newer?
  • Picture of Valery Fremaux
    Tue, Jan 21, 2014, 8:26 PM
    "why does moodle tell me there is a new version" : because this is an automated process. We discussed longly with Tomas to decide wether making some clone implementation or merging code and architectures. Tomas was not longer available for maintaining flashcard on a long run, and actually no running project using it.

    "Also, 3.2 will not work on 2.6 or newer?" : there is a risk, yeah... 3.2 track is discontinued.
    We discussed about having some data conversion script betwen too branches. Achieving in conclusion that it was too heavy work to change all the card content strategy from one version to the other.
  • Picture of Krister Viirsaar
    Tue, Jan 21, 2014, 8:34 PM
    okay, thanks for the info.
  • Picture of Frederick Hoyt
    Thu, Feb 6, 2014, 10:38 AM
    Hi,

    I am using Moodle 2.6.1 with the flashcard add-on version 2.4.0 for a language course.

    The add-on is working, but I would like to able to have it keep track of each time a particular student uses it and for how long. As far as I can tell, the add-on doesn't currently support this.

    My goal is to be able to give students extra credit for every time they use the flashcards for (at least) ten minutes. In order for me to do that, the add-on has to record the beginning and end timestamps for each time a student uses the cards and then to include that info in the summary for the deck.

    Is there a way to do this with the add-on that I haven't found, or a way to tweak the code so that it does?

    Thank you for your time and for the very useful add-on.
  • My Hero
    Sun, Feb 23, 2014, 5:25 AM
    Hi,

    As I attempt to upgrade my site from 2.5.3 to 2.6.1 I keep getting the error mentioned above (in the 2.5.3 installation there is flashcard version 2.4, but in the moodle 2.6.1 I put in the newer flashcard version). There are several flashcard activities in a number of courses and I don't want to delete them before I upgrade to the new version. Are there any workarounds other than using the legacy (flashcard 2.4) module or deleting and then re-installing?

    Thanks,
    Paul
  • Picture of Krister Viirsaar
    Sun, Feb 23, 2014, 3:13 PM
    @Paul there is no workaround. I tried all the ways I could thik of. You need to use legacy or reinstall.
  • My Hero
    Mon, Feb 24, 2014, 12:24 AM
    Okay, thanks. What I did was first export the mdl_flashcard_deckdata and then use the import feature. It's not a perfect solution, but it works.
1 2 3
Please login to post comments