Select Moodle version:

General plugins (Local): OU search

local_ousearch
Provides an indexed full-text search backend for OU activity modules.
Maintained by: Picture of sam marshall sam marshall

Sets

This plugin is part of set Open University. Plugins from the set work the best when installed together.

This is a cross-database indexed text-search facility. It does not do anything on its own, but if you install it alongside ForumNG, OU blog, or OU wiki then it will provide full text search for those modules.

It could also be used by other module developers who require indexed full-text search.

Contributors

Picture of sam marshall
sam marshall (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of imbu danilot
    Thu, Oct 13, 2011, 12:04 AM
    I get the following error when installing:
    Debug info: Missing version value in version.php
    Stack trace:
    •line 464 of \lib\upgradelib.php: plugin_defective_exception thrown
    •line 271 of \lib\upgradelib.php: call to upgrade_plugins_modules()
    •line 1466 of \lib\upgradelib.php: call to upgrade_plugins()
    •line 317 of \admin\index.php: call to upgrade_noncore()

    actually this is what I see in version.php
    <?php
    $plugin->version = 2010120300;
    $plugin->requires = 2010111500;
    $plugin->displayversion = 'Unstable development version (use at own risk)';
Please login to post comments