General plugins (Local): Moodle Adminer

local_adminer
Maintained by Picture of Andreas GrabsAndreas Grabs
This plugin is based on the great tool adminer. The main advantage of this plugin is, it can handle different types of database. So it works with MySQL/MariaDB, PostgreSQL, Oracle and MSSQL.
2537 sites
1k downloads
74 fans

This plugin is based on the great tool adminer. The main advantage of this plugin is, it can handle different types of database.
So it works with:

  • MySQL/MariaDB
  • PostgreSQL
  • Oracle
  • MSSQL

Here are some of the key-features:

  1. you can define trigger
  2. you can change the order of fields
  3. you can easy create or alter views
  4. you can create stored procedures
  5. if you rename a database so the database is altered and not copied like phpMyAdmin it does
  6. you can define foreign key with referential integrity

To install it you only have to copy it into the "local" folder in your moodle-installation and call the notification-page. After the installation you will find a new link "Moodle Adminer" below "Site administration / Server".

Screenshots

Screenshot #0
Screenshot #1
Screenshot #2
Screenshot #3
Screenshot #4

Contributors

Picture of Andreas Grabs
Andreas Grabs (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of Guido Roessling
    Thu, Nov 30, 2017, 3:34 AM
    Oops. Forget it - for some reason, it was version 2.9. No idea why I was using such an old version - and why no updates were shown... Note: even that version worked with PostgreSQL 9.4.15, PHP 7.0.25 and Moodle 3.4 wink
  • Ricardo Caiado
    Sat, Mar 17, 2018, 11:29 PM
    Hi,

    Any update to Moodle 3.4?

    Ricardo
  • Picture of Gary Lynch
    Thu, Aug 30, 2018, 6:12 PM
    I have installed with 3.5 and have this error when i try to use 'Unable to connect to PostgreSQL server: FATAL: no pg_hba.conf entry for host "127.0.0.1", user "blah", database "postgres", SSL off'
  • Picture of Ruthine Burton
    Mon, Nov 5, 2018, 10:03 PM
    Hi, the hosting company for our Moodle (3.5) have let me know that Adminer appears incompatible with the Adaptable theme (latest version for Moodle 3.5). They had to uninstall it as it would hang the programme. This is a great plugin that I have used previously. Do you have any plans for updating it to be compatible with Adaptable? Thank you. Ruthine
  • Picture of Andreas Grabs
    Tue, Nov 6, 2018, 6:32 AM
    I am sorry but please use the bugtracker!
  • Picture of Christian Bocquet
    Mon, Apr 1, 2019, 8:34 PM
    Hi Ruthine, to make this plugin compatible with the Adaptable or Essential theme, try to remove lines 56 and 57 from the templates/adminer.mustache file:
    56 require(['theme_boost/modal']);
    57 require(['theme_boost/loader']);
  • Picture of Michael Milette
    Tue, Jul 2, 2019, 10:58 PM
    Hi Andreas! Is there a reason that the version here on Moodle.org is one version ahead of the version on GitHub?
  • Picture of Andreas Grabs
    Wed, Jul 3, 2019, 3:16 AM
    oops, I forgot to push it to github. I only pushed it in my private repostory.
    Now it is up to date.
    Thank you Michael for this info!
  • Picture of Karen Holland
    Mon, Oct 5, 2020, 7:22 PM
    Hi Michael, thanks for such a wonderfully useful plugin! Would it be possible to get the Github 3.5 branch updated to 4.7.7 as well? TIA smile
  • Picture of Andreas Grabs
    Mon, Oct 5, 2020, 8:14 PM
    Hi Karen, it's actually Andreas ;). For Moodle 3.5 to 3.8 please use the branch "MOODLE_38_STABLE".
    Best regards
    Andreas
  • Picture of Rainer Busch
    Tue, Nov 3, 2020, 9:35 PM
    Is this plugin compatible with moodle version 3.9 ?

    Best regards
  • Picture of Rainer Busch
    Tue, Nov 3, 2020, 9:35 PM
    Is this plugin compatible with MariaDB ?

    Regards
  • Picture of Andreas Grabs
    Tue, Nov 3, 2020, 11:29 PM
    Hi Rainer,
    yes this plugin runs in Moodle 3.9 and works fine with MariaDB.
    Best regards
    Andreas
  • Picture of zeinal 85
    Sun, Nov 22, 2020, 1:19 PM

    I have a problem in version 3.10+, namely when I choose Indonesian, all videos cannot be played. an error message appears on json. how to handle it?
  • Picture of Andreas Grabs
    Sun, Nov 22, 2020, 7:26 PM
    Hi Zeinal, I am sure you are in the wrong place. The Adminer plugin has nothing to do with videos. You might be looking for a different plugin.
    Best regards
    Andreas
1 2 3 4
Please login to post comments