Select Moodle version:

Enrolment: User role assignment from LDAP

enrol_ldapuserrel
This plugin allows you to configure automatic synchronisation of relationships between users from a LDAP server. It is mainly used to assign Parent/Mentor rôle.
Maintained by: Picture of Maxime Pelletier Maxime Pelletier

If you need to assign Parent or Mentor role, this plugin will help you. It reads data from LDAP and then assign the specified role based on the information in LDAP.

In LDAP, you need to have an entry for the Parent/Mentor which contain an attribute (which can have multiple values) with the list of children/mentee.

For more details, go to http://docs.moodle.org/23/en/LDAP_User_role_assignment

Screenshots

screenshot
screenshot

Contributors

Picture of Maxime Pelletier
Maxime Pelletier (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • MD shot of me from his iphone4
    Sun, Nov 4, 2012, 12:58 AM
    Hi,
    Please consider adding urls for:
    - code repository
    - issue tracker
    - documentation
  • Picture of Maxime Pelletier
    Tue, Nov 6, 2012, 2:27 AM
    Code repository is already specified in download details. Where should I add the github URL? https://github.com/maxCSA/moodle-enrol_ldapuserrel
    For issue tracking, I think we can use Moodle Tracker and the CONTRIB related to this plugin: http://tracker.moodle.org/browse/CONTRIB-3938
    As for the documentation, not sure where is the best place. I'll have a look at that.
    Thanks for your help
  • Picture of Helen Foster
    Tue, Nov 6, 2012, 8:12 PM
    Hi Maxime, here's a page for the documentation: http://docs.moodle.org/23/en/LDAP_User_role_assignment (I just made a start on it.)
  • Picture of Geoff Young
    Mon, Nov 26, 2012, 7:54 PM
    Hi Maxime, I tried to install this on my Moodle 2.1.2 system and it wanted me to upgrade mixed

    Specific message regarding build versions was: 2011070102.06, you need 2012061700

    Any way of getting a version to work bakc-level without having to upgrade my environment ? Many thanks !
  • Picture of Maxime Pelletier
    Tue, Nov 27, 2012, 12:15 AM
    Hi Goeff,

    The reason why you get that message is because I don't know if the plugin is compatible with Moodle 2.1, so it requires Moodle 2.2.

    If you can test the plugin in development, modify the file moodle/enrol/ldapuserrel/version.php and change the line
    $plugin->requires = 2012061700;
    for
    $plugin->requires = 2011070102.06;

    This will tell Moodle that the plugin is compatible with you version of Moodle.

    I'm confident that it'll work well because there are no major differences between 2.1 and 2.2

    Please let me know if it works well.
  • Picture of German Valero
    Sun, Dec 9, 2012, 1:59 AM
    Hi Maxime,
    I was translating the ldapuserrel plugin and I found what seems to be a typo in the English language strings:
    2.3 [localobjectuserfield_desc,enrol_ldapuserrel]
    "Name of the field in Moodle user table that is used to identified the mentee"

    "identified " should be "identify" (I think, but I am not a native English speaker).
    Thanks in advance for your help.
  • Picture of Maxime Pelletier
    Mon, Dec 10, 2012, 11:29 PM
    Hi German,
    You are right, it's a mistake. I'll fix that!

    In which language are you translating the plugin? I could include your translation in the package. If it's good for you, just place you language directory somewhere that I can retrieve it and I'll include it.
    Also, have you experience any problem with the plugin?
    Regards
Please login to post comments