Blocks: oohoo - Text to Speech

block_tts
Maintained by Picture of Patrick ThibaudeauPatrick Thibaudeau, Picture of Nicolas BretinNicolas Bretin
OOHOO Text to Speech is a Moodle block that reads outloud the content of a resource
123 sites
98 downloads
15 fans
Current versions available: 1

This block adds text to speech functionality to Moodle

It can be configured to use either the Google speech engine or the Microsoft speech engine. When added to a resource such as a page, it reads the contents.

There is also a lexicon to add pronunciations for words that it pronounces improperly. For example, it could possibly say I.V. for the text IV. It should, however, say 4. You could add in the lexicon IV = four and it willpronounce it properly.

 

A special thank you to Ryan Thomas who is the original author of this block.

Screenshots

Screenshot #0
Screenshot #1

Contributors

Picture of Patrick Thibaudeau
Patrick Thibaudeau (Lead maintainer)
Picture of Nicolas Bretin
Nicolas Bretin: Developer
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of Nicolas Bretin
    Fri, Apr 19, 2013, 10:46 PM
    Hi Tim,

    Thanks it works better with this server!

    So on this page, with firebug you have the request : http://smartmove.moodle.com.au/blocks/tts/app/_php/tts_config.php?courseid=3&service=google&voice=en&_=1366382325334
    And it should return JSON. But if you look at the response it start with a notice:
    Strict Standards: Creating default object from empty value in /home/sli/public_html/smartmove/config.php on line 5
    It is generally because the config.php missed the $CFG = new stdClass();
    It is because your config.php file is from an older version of moodle and of course this file is not updated when you update Moodle.
    So just add this line to your config file and try again.

    But I'm not sure why this error doesn't show up on your normal pages...

    Nicolas
  • Picture of Roland Sherwood
    Fri, Apr 19, 2013, 11:44 PM
    Hi Nicolas. Just a quick note to confirm the developers of Bootstrap will hopefully revert to the original naming of the region-main element under 2.5 (not sure bout the 2.4 version of the theme):

    "The reason the div id was renamed was to avoid conflicts with Moodle's base theme CSS. The Moodle_25 branch of the bootstrap theme does not rely on base CSS anymore so I guess we could change the names back to region-main."

    So, fingers crossed you don't need to spend time implementing any changes to the block in order to ensure compatibility. Btw, just to confirm I followed your suggestion and modified the selector definition and the blocks works fine now.

    Thanks again.
  • Picture of tim wilde
    Sat, Apr 20, 2013, 9:20 AM
    Hi Nicolas,

    That’s fixed it! The plug-in is now light grey ,the spinning icon has stopped and I can now click “play”. Thank you so much for your help.

    Just for clarification and reference for anyone else who experiences a problem with the plug-in being greyed out and spinning. The fix is to add $CFG = new stdClass(); to the top of the moodle/config.php file .

    I now just have one further small problem. The TTS system works with Microsoft but not with Google. If I click on play with the system set to Microsoft I get some sound but it is fairly slow and stuttered. I understand that the Google TTS is smoother, so I thought that I would try that one. However I get no sound via Google
    See the following page
    http://smartmove.moodle.com.au/course/view.php?id=3

    It highlights the first word but no sound and I cannot get past the first word

    I attach the Firebug debug info here. The first part is Microsoft (which works, The second is Google, which produces no sound)
    http://smartmove.moodle.com.au/misc/TTSlog2.txt

    I hope that we can resolve this and then I can leave you in peace!

    Thanks again for your help to date

    Regards

    Tim

  • Picture of Nicolas Bretin
    Mon, Apr 22, 2013, 11:57 PM
    Hi Tim,

    Apparently the Google service refuse to serve the mp3...
    Can you go on github => https://github.com/oohoo/moodle-block_tts/issues/2
    And follow my instructions in order to modify a file in your TTS block.
    I just don't want to publish something that doesn't work on Moodle!

    Thank you for your return!

    Nicolas
  • Picture of tim wilde
    Tue, Apr 23, 2013, 10:01 AM
    Hi Nicolas

    I am able to download the test file from here without any problems
    http://translate.google.com/translate_tts?tl=en&ie=UTF-8&q=test%201%202%203

    I added the new file to /tts/app/_php/_services/google_tts_config.php

    (Note that I could only find this file in _services).

    However unfortunately I still have the same problem playing Google TTS

    Sorry about this. Can you please let me know if there is anything else that I can do to troubleshoot the problem

    Thanks

    Tim
  • Picture of Aditya Dubay
    Wed, Jan 8, 2014, 4:07 PM
    Hi,
    I wish to know, when you people release plugin for moodle 2.6. I wish to use this plugin and eagerly waiting for it.
  • Picture of james logue
    Fri, Mar 7, 2014, 2:36 AM
    I have upgraded to 2.5.4 and added the oohoo plugin. I get a grayed out box and the cog wheel spins continuously. I don't have any users on my site at this time since I am testing the site. Any help with this would be great. I have read everything I can find but haven't found any solutions.
  • Picture of Roland Sherwood
    Mon, May 12, 2014, 5:09 PM
    James - just to quickly note that the TTS block requires Flash support in the browser, so if you don't have that installed (or are using an iOS device) the player will be exhibit the issues you've described.
  • Picture of Dimo Dimov
    Mon, Sep 1, 2014, 5:08 PM
    Hi,
    We use Moodle 2.6.4 (Build: 20140714) and the same issue with the gray box and the spinning wheel. Any help will be appreciated.
  • Picture of nata g
    Sat, Sep 6, 2014, 5:13 PM
    Hi,

    This plugin seems to be awesome. Unfortunately my version of Moodle is 2.7. Are there any chances that an update will be released for this version ?
    Thank you.
  • Picture of Sheila Owen
    Thu, Aug 27, 2015, 7:52 PM
    Has anyone been successful in getting this plugin to work in Moodle 2.7?
  • Picture of Masood Ziayee
    Wed, Aug 21, 2019, 8:25 PM
    Can anyone help me with this plugin please??
    It seems to be not working. I am running Moodle version 3.7 locally.
    thanks,
  • Picture of Ranjan Bera (IN)
    Fri, Jan 3, 2020, 9:30 PM
    Hi.
    I installed this plugin but its not working properly
    Its showing javascript error Uncaught TypeError: Cannot read property 'msie' of undefined.
    Please help me
    My moodle version is 3.2
  • Picture of M Daoud
    Sat, Apr 18, 2020, 10:25 AM
    not working on 3.8., keep trying to connect !!
  • Picture of Istituto Comprensivo Osio Sotto
    Fri, Apr 24, 2020, 2:53 AM
    Not working on 3.8, can anyone help us to fix it or suggest another plugin? Thanks in advance
1 2 3 4
Please login to post comments