Quickfind List

Blocks ::: block_quickfindlist
Maintained by Mark Johnson, Ray Morris
Quick Find List Block for Moodle This block allows quick searching of users from a block, and displays a configurable link for each search result
Latest release:
302 sites
38 downloads
17 fans

The Quick Find List block can be added to a course or site page to allow searching of users within that page.

Each instance of the block can be configured to search only for users with a certain role, or for all users.

With Javascript enabled, the block will "find as you type", otherwise it will display a button to perform the search.  Each search result will display as a link which defaults to the user's profile - this link can be customised for each instance of the block.

Please dont report bugs here

If you experience an error with the block, or would like to request a feature, please use the "Bug Tracker" link below.

Screenshots

Screenshot #0
Screenshot #1
Screenshot #2

Contributors

Mark Johnson (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Fri, Jul 26, 2013, 10:08 PM
    Hi Ray,
    I've seen your pull request on Github, as soon as I get the chance to test it out I'll merge it in and do a release.

    Thanks
    Mark
  • Mon, Jan 20, 2014, 10:11 PM
    Hi, this plugin is indispensable. Any plans or eta to make available on 2.6? I've not been able to install for a while and it is missed. Thanks again for your work. Nick
  • Mon, Jan 20, 2014, 10:57 PM
    Hi Nick, I'm not working with Moodle at the moment, but if you let me know what the problem is when you try to install it I might be able to address it in the near future. Can you give me any more details about why you can't install it?
  • Tue, Mar 11, 2014, 10:18 PM
    This is working just fine in 2.6. The only thing I would like to change is that when I am in a course and am a site admin, I would like the block to be able to link to any user's profile, not just users that are enrolled in the course.
  • Thu, Feb 5, 2015, 5:52 PM
    Hi, I'm looking for a plugin to facilitate the searching process within my moodle contents (courses and teachers). Does this version suit with Moodle 2.7 (and next Moodle version 2.8)?
    Thanks
  • Thu, Feb 5, 2015, 6:06 PM
    As far as I know, there's no reason why it shouldn't work with 2.7 or 2.8. If you try it and find that it doesn't, please let me know what problems you find and I will see what I can do to fix it.
  • Thu, Feb 5, 2015, 10:00 PM
    Thanks for your quick answer Mark, if I use I will let you know what happens. Also I saw that you are the developer of the "quick course list", is it(might it be) also good on Moodle 2.7?
  • Thu, Feb 5, 2015, 10:11 PM
    Other than the bits of the database they look at, they're pretty much the same code, so if one of them works it's a very good sign that the other will too.
  • Thu, Feb 5, 2015, 10:28 PM
    This one does work in Moodle 2.7/2.8. We're running a pre-release version of 2.8 and it works.
  • Thu, Feb 5, 2015, 10:32 PM
    Thanks Ray, I've updated the entry to reflect that current Moodle versions are supported.
  • Wed, Nov 18, 2015, 1:21 PM
    In version 2.9 one cann't search for the first and last name together.
    Could you please fix it?

    tnx,
    Ruth
  • Sun, May 8, 2016, 3:37 PM
    I am getting the following error when selecting the block from the list to add
    Fatal error: Call to undefined method page_requirements_manager::js_call_amd() in /home1/uaeac/public_html/ADSM/LMSClone/blocks/quickfindlist/block_quickfindlist.php on line 197

    help please
  • Tue, Jan 3, 2017, 8:01 PM
    is there a moodle 3 ver?
  • Fri, Jul 7, 2017, 12:54 AM
    Meir Kirshner - late to the party here, but I'm running on 3.3+ and am having no issues running the block. It's fairly basic and since it's just doing simple DB calls, I suspect it's somewhat immune to lots of the changes that are happening with Moodle.

    Of course I realize now that I've said that out loud, 3.4 will probably break it for me. =)
  • Tue, Jan 5, 2021, 11:29 PM
    The latest version of the block listed here is causing an error in Moodle 3.10, at least with the Edwiser theme, because of the depreciated function `pix_url`. It looks like this was already fixed in the source control two years ago, I'm wondering if one of the maintainers can update the listing here on Moodle.org?
1 2
Please login to post comments