Your Moodle version

Blocks: Progress Bar

block_progress
Maintained by My ugly mug Michael de Raadt
A time management tool for you and your students
156k
3k
29
  • A time-management tool for students
  • Shows progress in activities/resources
  • Colour coded to quickly see completed/viewed
  • Teachers select which pre-existing activities/resources are to be included
  • Order by times/deadlines or order in course
  • Overview page shows teachers the progress of all students
  • Ability to contact students from the Overview page
  • Combined progress on My home page

Screenshots

Screenshot #0
Screenshot #1
Screenshot #2
Screenshot #3

Contributors

My ugly mug
Michael de Raadt (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Dr. Peter Gehbauer, PhD
    Sun, Jun 21, 2015, 10:16 AM
    Peter, I too get the server 500 error when trying to view the students' data. It appears that the progress bar tracks completions though.

    Cheers, (another) Peter
  • Dr. Peter Gehbauer, PhD
    Sun, Jun 21, 2015, 10:18 AM
    My error message is more generic:

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator at webmaster@xxxxxxxxxxx.ca to inform them of the time this error occurred, and the actions you performed just before this error.

    More information about this error may be available in the server error log.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
  • My ugly mug
    Mon, Jun 22, 2015, 9:32 AM
    Hi, Peter.

    I just did some testing on a new Moodle instance and the overview page seemed to be working for me. In order for me to help you, I recommend the same advice I gave the other Peter, being to turn debugging on and report an issue on the Tracker.
  • Picture of naeem mohamed
    Tue, Jun 23, 2015, 10:46 PM
    Hi Michael. i seem to be having issues viewing 'Overview of Students' resources and activities have been added and on the bar the ones viewed are highlighted in green, however when i click Overview of Students. it shows nothing there at all. Just a screen with a drop down for 'role'. any help would be appreciated. Thanking you in advance. naeem
  • Picture of David Manning
    Wed, Jun 24, 2015, 5:13 AM
    Hi Michael,

    I love the idea of your plugin! Given that around 8% of the population is colour-blind, they won't actually know their progress. Can you please add a checkmark or an X on top of each activity so colour-blind people can see their status?
  • My ugly mug
    Wed, Jun 24, 2015, 8:53 AM
    Hi, Naeem.

    It may be that there is an error occurring during the output of the page content. Without debugging on, you won't see any problems.

    1: Turn on debugging (https://docs.moodle.org/en/Debugging) and 2: please post an issue about this on tracker.moodle.org so we can work on this further.
  • My ugly mug
    Wed, Jun 24, 2015, 8:55 AM
    Hi, David.

    Thanks for the feedback about colour-blindness. There is an option in the block's settings that adds ticks and crosses for exactly this purpose. Going further than that, it's also possible to change the colours of the bar in its global settings.

    Michael.
  • Picture of Hamed Azimi
    Thu, Jun 25, 2015, 5:27 AM
    Hi Michael,

    I use dataform as one of the course activities. Why I can't select dataform activities to be included in progress bar?

    Best,
    Hamed
  • My ugly mug
    Fri, Jun 26, 2015, 6:38 AM
    Hi, Hamed.

    The Progress Bar is only able to show information about plugins it is familiar with. New plugins can be made known to the Progress Bar by adding entries to its lib.php file describing the plugin and the database tables where the relevant information can be found. If you are able to get the Progress Bar to work with the Dataform plugin, please share your changes with me (through the Tracker) so I can add them to the distributed code for the benefit of all.

    Michael
  • Picture of Keith Revell
    Wed, Jul 1, 2015, 7:06 AM
    This plugin has been recommended to me and from my first look I see this of great value to our Students, but I have an unusual problem I am hoping someone can help me with. I installed the latest version of the "Progress Bar" block plugin onto my stand-alone Windows PC based test system and everything worked great, but when I installed it on our production system the display behaved strangely.

    On the production system the graphic line is extended and overlaps past the block boundary. I have tried uninstalling and reinstalling the plugin and looked at every configuration option I can think of. All the plugins are up-to-date and I am running Moodle version 2.9+ (Build: 20150514) using the Essential theme. I made sure the Moodle, database and plugins on the two systems were identical by downloading the latest from the website onto my PC.

    I suspect this is more a server configuration or theme issue and not the plugin but I have run out of ideas. If anyone can offer some help I would appreciate it.

    Keith
  • Picture of Keith Revell
    Wed, Jul 1, 2015, 9:56 AM
    We have over 300 Students in our course and when I select the "Overview" option the list starts to populate but about two thirds the way through it stops and I get the error message:

    "The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator at webmaster@ to inform them of the time this error occurred, and the actions you performed just before this error.

    More information about this error may be available in the server error log.

    Additionally, a 404 Not Found error was encountered while trying to use an Error Document to handle the request."

    I have checked the server error logs, and added the debug option to our config but am unable to get any additional information. I suspect it may be a SQL timeout issue as the plugin works great on our test system which handles the same volumes but is on a standalone PC. As our Production system is on a shared platform if it is a SQL timeout then we will be unable to fix it.

    is there a circumvention which would allow us to limit the initial "overview" list to a specific "Group" in which we could setup a limited number of Students? At the moment it defaults to "All participant"s and only when the list is fully populated can you then select a group.

    Thanks,
    Keith
  • My ugly mug
    Wed, Jul 1, 2015, 12:02 PM
    Hi, Keith.

    In relation to the appearance of the Progress Bar, there may be a style conflict from the theme or some other plugin. I've tried to make the CSS specific in the Progress Bar block, but that might not stop other plugins with general CSS rules from interfering. If you find some element that can be styled more specifically to work around this, let me know.

    If the Overview page was reaching a timeout, I would expect a different error. The errors you gave indicate something has gone wrong in the code and may be accessing some files that are not accessible on the server. At the moment, there is no paging on the Overview page. It's something that people have asked for, but I haven't got around to that. If you find out more, please share it on tracker.moodle.org.
  • Wazza
    Wed, Jul 1, 2015, 1:15 PM
    Keith does have a point though concerning the loading time of the progress bar. We sometimes have over a thousand students in one course, which makes the loading of the overview page very time consuming (no error though).

    It's only after loading every student you get the chance to select a group.

    Is pagination an option here? Or perhaps first the ability to choose a group, then load the overview page?
  • My ugly mug
    Wed, Jul 1, 2015, 1:24 PM
    I think Pagination is possible. I'm busy organising MoodleMoots currently. If someone wants to help with this, it would be welcome.

    Here is the issue created earlier relating to pagination.

    https://tracker.moodle.org/browse/CONTRIB-5086
  • Picture of Keith Revell
    Thu, Jul 2, 2015, 2:52 PM
    Thanks for the feedback Michael,

    I think I have resolved the appearance problem by clearing all Theme and Moodle caches and reloading the server. It displays OK now. Still getting the error on our larger course though - but it also seems to be tied to server load as well??????? as it sometimes works OK but more often that not fails. Still unable to capture any error messages despite adding as many debug options as I can find. I think the pagination option would be ideal and solve all our problems.

    Keith
Please login to post comments