Your Moodle version

Blocks: PBLTool (CLPMTool)

block_pbltool
Maintained by Picture of Marcelo Schmitt Marcelo Schmitt
This block implements a project management tool create to be used with collaborative learning. It is integrated with group forum and chat. The main ideia is that students and teacher plan ther activities together.
751
38
1
Moodle 2.7, 2.8, 2.9

 

 

 

 

 

 

 

 

 

 

 

 

 

Screenshots

Screenshot
Screenshot

Contributors

Picture of Marcelo Schmitt
Marcelo Schmitt (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • MD shot of me from his iphone4
    Fri, Nov 9, 2012, 3:52 PM
    Please could you add a readme.txt when you get a chance smile
  • Picture of Juan Bournissen
    Wed, Apr 3, 2013, 7:47 AM
    ¿Este block cumple la misma función que el módulo pbl-master que estaba compuesto PBL, por el bloc file-manager y las rúbricas? ¿O trabaja de otra forma?
    Desde ya muchas gracias
  • Picture of Marcelo Schmitt
    Fri, Apr 5, 2013, 1:02 AM
    Juan
    Não sei se posso responder em português. Se não compreenderes, posso explica em inglês.

    Eu não conheço o pbl-master. Este bloco apresenta um local para gerência de tarefas, fórum, chat e um gráfico de Gant.

  • Picture of German Valero
    Wed, Jun 11, 2014, 11:16 PM
    Hi,
    I am translating the English strings for this plugin in AMOS, and it would be very helpful for me and other translators if the author explained the meaning of 'PBL' (project-based-learning?) and 'CLPM' (collaborative learning project management?).

    Thanks in advance for your help.
  • Picture of ryan sanders
    Tue, Mar 24, 2015, 4:18 AM
    moodle install 2.7.5 and 2.7.7 versions i get following error during install.

    block_pbltool
    Legacy type admin in access.php was renamed to manager, please update the code.
    line 1380 of \lib\accesslib.php: call to debugging()
    line 2757 of \lib\accesslib.php: call to assign_legacy_capabilities()
    line 873 of \lib\upgradelib.php: call to update_capabilities()
    line 422 of \lib\upgradelib.php: call to upgrade_plugins_blocks()
    line 1615 of \lib\upgradelib.php: call to upgrade_plugins()
    line 434 of \admin\index.php: call to upgrade_noncore()
    Legacy type admin in access.php was renamed to manager, please update the code.
    line 1380 of \lib\accesslib.php: call to debugging()
    line 2757 of \lib\accesslib.php: call to assign_legacy_capabilities()
    line 873 of \lib\upgradelib.php: call to update_capabilities()
    line 422 of \lib\upgradelib.php: call to upgrade_plugins_blocks()
    line 1615 of \lib\upgradelib.php: call to upgrade_plugins()
    line 434 of \admin\index.php: call to upgrade_noncore()
  • Picture of Marcelo Schmitt
    Fri, Mar 27, 2015, 1:18 AM
    Sorry Ryan. I will have sometime to look at that next week. Ok?
  • Picture of Marcelo Schmitt
    Tue, Apr 14, 2015, 12:26 AM
    Ryan
    I published a new release. I think it is ok now.
  • Picture of Jaswinder Singh
    Tue, Apr 14, 2015, 1:43 PM
    Hi there,
    I am getting the error : "Sorry, but you do not currently have permissions to do that (pbltool:viewpages)" when I am logged in as an admin user.
  • Picture of Marcelo Schmitt
    Sat, Apr 25, 2015, 3:06 AM
    JAswinder, what are you trying to access? I have to simulate the error.
  • Picture of Jaswinder Singh
    Sat, Apr 25, 2015, 9:49 PM
    Hi Marcelo, I have added the block to my course page and when I am clicking the Project not configured link, then I am getting the error "Sorry, but you do not currently have permissions to do that (pbltool:viewpages)" even after I am logged in as an admin user.
  • Picture of Marcelo Schmitt
    Fri, May 8, 2015, 1:14 AM
    Hey guys, I was unable to reproduce the error Jaswinder is experiencing. Does anybody has the same problem?
  • Picture of Marc Roze
    Tue, May 12, 2015, 8:42 PM
    I do : I create groups, fill them with students, a forum with groups, a chat with groups, then a block where I select both forum and chat previously created, I save and click on "Project not configured" and get :
    Désolé, vous n'avez actuellement pas les droits d'accès requis pour effectuer ceci (pbltool:viewpages) <- In English : Sorry, but you do not currently have permissions to do that

    Debug info:
    Error code: nopermissions
    Stack trace:
    line 786 of /lib/accesslib.php: required_capability_exception thrown
    line 41 of /blocks/pbltool/authorization.php: call to require_capability()
    line 36 of /blocks/pbltool/view.php: call to include()

    I'm on Moodle 2.8.2 on MAMP.
  • Picture of Marcelo Schmitt
    Fri, May 15, 2015, 4:05 AM
    Sorry guys. I had make a terrible mistake. When I fixed db/access.php, changing admin for manager, I had copied from another plugin of mine. I uploaded a new version correcting it. You can notice that in access.php, I am referencing analytics_graphs instead of pbltool. I hope everything works now.
Please login to post comments