Your Moodle version

Blocks: Grade Me

Maintained by Picture of Tyler Bannister Tyler Bannister, Picture of Logan Reynolds Logan Reynolds
Shows a teacher all of the assignments and manual quiz questions (essays and file responses) that have been submitted, but not graded.

Shows a teacher all of the assignments and manual quiz questions (essays and file responses) that have been submitted, but not graded. The block is configured to work with groups that is, teachers will only see the assignments submitted by students if they are both members of the same group. You'll have to let me know if it works with courses that don't use groups at all. You can install the block on the Front Page and it will show ungraded assignments for ALL courses, and if you put the block on a course page it will only show the ungraded assignments for that course.


Screenshot #0


Picture of Tyler Bannister
Tyler Bannister (Lead maintainer): Maintainer
Picture of Logan Reynolds
Logan Reynolds: Maintainer
Picture of Dakota Duff
Dakota Duff: Original Developer
Picture of Tim Gus
Tim Gus: Contributor
Picture of Linda Vanderbaan
Linda Vanderbaan: Contributor
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • QED
    Wed, Jun 17, 2015, 4:17 AM
    I just upgraded the Grade_me block onto my noodle 2.9+ version. It seems to be working correctly but I do have the following debugging lines at the top of the page.
    line 103 of /blocks/grade_me/block_grade_me.php: call to has_capability()
    line 288 of /blocks/moodleblock.class.php: call to block_grade_me->get_content()
    line 230 of /blocks/moodleblock.class.php: call to block_base->formatted_contents()
    line 971 of /lib/blocklib.php: call to block_base->get_content_for_output()
    line 1023 of /lib/blocklib.php: call to block_manager->create_block_contents()
    line 473 of /lib/outputrenderers.php: call to block_manager->ensure_content_created()
    line 37 of /theme/essential/layout/includes/header.php: call to core_renderer->standard_head_html()
    line 27 of /theme/essential/layout/columns3.php: call to require_once()
    line 1015 of /lib/outputrenderers.php: call to include()
    line 945 of /lib/outputrenderers.php: call to core_renderer->render_page_layout()
    line 244 of /course/view.php: call to core_renderer->header()
  • Picture of Bhargava S
    Sun, Jun 28, 2015, 5:42 PM
    Using Moodle 2.8.5 Installed version of this plugin. When i add the block , it only gets added to the view(url) wherein editing is turned on. If i turn off editing block is not visible. Please help.
  • Picture of William Mair
    Thu, Jul 2, 2015, 7:05 PM
    Can you let me know if this block works with the marking workflow and, more specifically, the allocated marking or if it works on the cangrade permission?
  • Picture of Sue Dowson
    Fri, Jul 3, 2015, 2:26 PM
    Is it possible to get Grade Me to only show unmarked work in the Group that the Lecturer belongs to in a course? We have multiple lecturers sharing the same course. They use Groups and Groupings to ensure only the relevant lecturer receives email notifications of submissions. However, Grade Me is showing all work awaiting grading in their shared courses.

    Thanks for Grade Me. Such a neat add on to simplify life for our lecturers.
  • Picture of Paul Tosney
    Fri, Jul 24, 2015, 6:06 AM
    I'm having some issues where one item to be graded shows multiple times on the Grade Me block. I'm looking at one right now where the student submitted one rtf file, yet the submission shows 3 identical entries in Grade Me, all for the same assignment at the same time from the same student.

    The assignment uses a rubric for grading.

    Moodle 2.7.7+ (Build: 20150505), Grade Me 2014051206

    Any thoughts?

  • Picture of Nikki Macfarlane
    Sun, Jul 26, 2015, 8:09 AM
    I have found what I think is an inconsistency between the Grade Me block and the way Moodle Assignments are handled. When a teacher goes to view an assignment and clicks Edit and then Grade, the assignment module inserts a record into the assign_grades table for that students assignment, setting the grade to -1. This happens just by clicking Edit and Grade, before the assignment is actually graded. However, the Grade Me block is seeing that grade of -1 and then not displaying the assignment in the block as outstanding.

    My teachers are clicking on the red check mark which takes them to ../mod/assign/view and as a result of that action, sets the grade to -1. If they do not grade the assignment immediately, when they go back into Moodle the assignment has disappeared from the Grade Me block. I need the block to continue displaying the assignment as outstanding until it has actually been graded. The teachers usually open the assignment and download it and have a few days before they are ready to give a grade - but when they go back in the block does not show the assignment any longer and they have to go through and manually locate them. Interestingly, this does not happen on assignments that I converted from pre Moodle 2.3, only on ones I have created since then.

    I am using Moodle 2.8 and the Grade Me version and the assignments are set up with a customized scale that has two grades possible - 1 for resubmit and 2 for completed.
  • QED
    Wed, Jul 29, 2015, 6:51 AM
    I guess I spoke too soon. I have not been able to get the Grade Me block to work on my 2.9+ Moodle Version. I have tried everything. Making sure teacher and students are in the same group, changing course formats, looking from a teacher rather than administrator point of view. No matter what I always get "nothing to grade". Is there some secret I'm missing for this block to work or do I just need to wait until a newer version of the block comes out?
  • Picture of Tyler Bannister
    Wed, Jul 29, 2015, 8:28 PM
    Hi Marc, please make sure you run the Moodle cron at least once after installing Grade Me. The Moodle cron will find markable assignments (and other activities based on settings) and set up the Grade Me block so it can display assignments waiting for marking.
  • QED
    Thu, Jul 30, 2015, 1:01 AM
    Thanks for your response Tyler. That is something I have been trying also but to no avail. In a course although I am an administrator I have put myself as the teacher also. I also made another account as a teacher and another account as a student. Whether I'm logged in as admin or the teacher account I cannot see anything in the grade book to be checked that the student account submitted. When in the admin account I get a smiley face with "Nothing to Grade". When in the teacher account I can't even see the block unless I turn editing on. Then the block shows but I don't even see the smiley face and message.
  • Picture of Nikki Macfarlane
    Thu, Jul 30, 2015, 9:57 PM
    Tyler, I think I have foudn the problem I was having with assignments disappearing from the block. If a student uploads a word document as their assignment, the teacher can click the check mark and view that assignment no problem - the assignment still appears in the block until the teacher grades it.

    But, if a student uploads a PDF file as their assignment, the assign module puts an entry into the assign_grades table with a grade of -1 - this means that the assignment no longer appears in the block. So if the teacher simply views an assignment that had a PDF file uploaded it now disappears from the block altogether as if it has been graded even though it has not been.

    I have checked on the forum for the assign module and apparently pdf files are treated differently than other files and this behaviour is expected. The problem is that the grade me block is thinking the assignment is not outstanding even though it is.

    Can some kind of fix be done so that regardless of the file type that is uploaded by the student, the assignment remains on the grade me block until it is actually graded? this is causing a huge problem for my teachers as they cannot find assignments after they go to view them and we cannot stop students from creating pdf files for their assignments.

    Thanks! Nikki
  • Picture of Aster Blistok
    Tue, Aug 18, 2015, 1:01 AM
    Thank you for great update to 2.8/2.9. I have just finished thorough testing on M2.9 and plugin works great! There is a HUGE improvement in performance (compared to 2.5v). There is only one issue I have experienced, where quiz plugin was showing some old (already graded submissions) as well as automatically graded as incorrect ones. I've fixed this by adding AND qas.state = 'needsgrading' on line 53 in sql query for quiz_plugin.php
  • Picture of Andrew Maas
    Sun, Aug 23, 2015, 1:14 PM
    Hi Tyler
    We are having lengthy start-up times of about 1 - 4 mins when we login to Moodle. I firstly logged a support request with our Moodle provider and they have said it is due to the logic in the GradeMe plugin. We are on Moodle 2.7. - This plugin is great and my teachers love it, however are you please able to shed some light on the issue and/or assist me in fixing it?
    Thank you, Andrew
  • Picture of erika alarcon
    Wed, Sep 16, 2015, 2:13 AM
    I'm testing the block in Moodle 2.7.5

    When a teacher clicks on the red check mark which takes them to the student submission page and does not put a score but the teacher clicks on the 'Save changes' button, that submission disappears from the Grade me block.

    However, the teacher still see that there is a submission that 'Needs grading' in the Assignment page (eg. /moodle/mod/assign/view.php?id=333)

    It seems that the block Grade me is not coordinated with the assignments that need a grade.
    I have run the cron

    Thank you, Erika

  • Picture of erika alarcon
    Fri, Sep 18, 2015, 4:51 AM
    I think I found the problem, in \moodle\blocks\grade_me\plugins\assign\assign_plugin.php in the query:

    $query = ", submissionid, asgn_sub.userid, asgn_sub.timemodified timesubmitted
    FROM {assign_submission} asgn_sub
    JOIN {assign} a ON = asgn_sub.assignment
    LEFT JOIN {block_grade_me} bgm ON bgm.courseid = a.course AND bgm.iteminstance =
    LEFT JOIN {assign_grades} ag ON ag.assignment = asgn_sub.assignment AND ag.userid = asgn_sub.userid AND asgn_sub.attemptnumber = ag.attemptnumber
    WHERE asgn_sub.userid $insql AND asgn_sub.status = 'submitted' AND a.grade <> 0
    AND ( IS NULL OR asgn_sub.timemodified > ag.timemodified)";

    the last line refers to the field [] and compares it to NULL, but I think it should say:
    AND (ag.grade IS NULL ....

  • Picture of Brian Evans
    Wed, Sep 30, 2015, 10:59 PM
    Thanks for a great plugin. It saves me loads of time. I wonder if it could be modified to check for unrated forum posts. This would save me lots more time and would be greatly appreciated.

    Thanks again!
1 2 3 4 5 6 7 8
Please login to post comments