Atto: Chemical Structures and Reactions Editor

atto_structure
Maintained by Picture of Carl LeBlond Carl LeBlond
Easily draw and insert chemical structures using MarvinJS. Requires MarvinJS from Chemaxon.
121 sites
49 downloads
5 fans
This plugin provides an Atto toolbar button that allows users to draw and insert images of chemical structures and reactions using MarvinJS.  The width and height of the image can be set before inserting the image.

Sets

This plugin is part of set EasyOChem.

Screenshots

Screenshot #0
Screenshot #1

Contributors

Picture of Carl LeBlond
Carl LeBlond (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of David Mudrák
    Fri, 5 Sep 2014, 5:25 AM
    Please fix the "More documentation on this plugin" link above (currently leading to a non-existing moodle.org page due to a typo).

    Please make the CSS selectors more specific so they affect only the scope of your plugin (after being concatenated with orther CSS style files from other Moodle components).

    Please note, as you seem to use the MarvinJS in couple of plugins now, you might think of some reorganisation in the future in order to avoid repeated settings and code in each plugin. For example a new local_marvinjs plugin that provides functionality to all others, or so. It might help further maintenance of the whole set.

    Best luck with maintaining this. You are cleared to land now, welcome to the plugins directory.
  • Picture of Carl LeBlond
    Sat, 6 Sep 2014, 9:09 AM
    David - Thanks for your input. I fixed the link and css and I have been considering a consolidation of the qtypes. New version has been uploaded and I hide the old one.
  • Picture of Miki Alliel
    Tue, 24 Feb 2015, 8:06 PM
    Hello I succeed instaling and configuring it but when adding anything and clicking on "insert" button - nothing happen I get empty string.
    When clicking on the iconand the editor comes up I can see "valid license cannot be found" is that has something to do with it? if so how can I fix it? Thanks
  • Picture of Carl LeBlond
    Tue, 24 Feb 2015, 10:16 PM
    Mike - This has been fixed on the github version which you can dowload, but I haven't uploaded to Moodle Plugins directory yet. I'll upload a new version to the plugin directory later today when i get a chance.
    Carl
  • Picture of Carl LeBlond
    Tue, 24 Feb 2015, 10:18 PM
    Here is the link https://github.com/cleblond/moodle-atto_structure
    BTW what browser did you test in?
  • Picture of Miki Alliel
    Mon, 2 Mar 2015, 5:10 PM
    Ok thanks I just test it and it's working with this version. before I tried with Chrome and Firefox (last versions).
    When do you think this atto_stricture version will be updated in the "Moodle plugins"? Thank you anyhow.
  • Picture of Mashaal AlGhamdi
    Sun, 15 Mar 2015, 8:43 PM
    Hi Carl
    The problem is still the same as Mikki noticed. Any new updates since today?
  • Picture of Mashaal AlGhamdi
    Sun, 15 Mar 2015, 10:52 PM
    The plugin works perfect! thank you.
    For the new downloaders, just make the structure then click insert. After than, click on insert image of the editor tallbar.
    It works
  • Picture of Andreas Schenkel
    Sun, 20 Dec 2015, 1:40 AM
    Will Chemical Structures and Reactions Editor be updated for moodle 3.0?
  • Picture of murat orgut
    Tue, 19 Jan 2016, 12:37 AM
    Moodle 3 support. Pls...
  • Picture of Carl LeBlond
    Tue, 19 Jan 2016, 1:26 AM
    I've been using it on Moodle 3.0 without any problems. Are you guys (Andreas/Murat) having an issue with it not working?
  • Picture of murat orgut
    Thu, 28 Jan 2016, 4:47 PM
    Thanks... (Carl LeBlond)
  • Picture of sarendar vennapureddy
    Thu, 15 Sep 2016, 4:49 AM
    Hi,

    I have installed atto_structure plugin in my local instance( This instance with only HTTP). It is working fine.
    Here the same plugin installed in HTTPS site. But it wont work it is showing empty structure box.
    In the firebug i changed the to then only its working.
    Please help me how to over come this issue. And the moodle version 3.0
  • Picture of Carl LeBlond
    Fri, 16 Sep 2016, 9:20 PM
    Sarendar - On line 57 of the lib.php try changing http to https. When I get a chance I will update the code so it works on both http and https servers. Thanks for trying my plugin.
  • Picture of Miro Iliaš
    Fri, 17 Mar 2017, 5:20 AM
    Hi,

    I would be very glad to have this plugin for Moodle 3.x.
Please login to post comments