Your Moodle version

Assignment submissions : Online audio recording

assignsubmission_onlineaudio
Maintained by Picture of Paul Nicholls Paul Nicholls
Audio recorder (Flash 10.1+) submission method. Records locally and uploads via HTTP POST, so there's no need for a streaming server!
27k
872
5
Moodle 2.3, 2.4, 2.5, 2.6, 2.7

Finally putting an end to the need for a streaming server (or a Java applet) to allow students to record audio clips for Moodle assignments, the Online Audio Recording assignment uses Flash (10.1+) to record audio from a microphone, convert it to MP3 format and upload it to Moodle via HTTP POST.

INSTALLATION:
- Place the "onlineaudio" directory within your_moodle_install/mod/assign/submission/
- Visit the admin notifications page and complete the installation
- Done!

USAGE (teacher):
- As a teacher, create (or edit) an assignment
- Under "Submission settings", set "Online audio recording" to "Yes" and choose the maximum number of recordings
- Save the assignment

USAGE (student):
- In the assignment submission, find the "Online audio recording" section
- If you haven't used it before, you may need to allow access to your microphone
- Click the red circle button to begin recording
- Click the blue square button (or the red circle button again) to stop recording
- Enter a file name and click "Save"
- Wait for it to state that it's "Ready to upload" and click the "Upload" button


Related plugins:
Online Audio Recording (assignment type for old mod_assignment)
Record Audio (repository plugin - record audio anywhere you can upload a file!)

Screenshots

Screenshot #0
Screenshot #1

Contributors

Picture of Paul Nicholls
Paul Nicholls (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of Gorn ---
    Fri, Jan 31, 2014, 8:46 PM
    Hi paul,

    we're using Moodle 2.4.8, unfortunately the plugin doesn't seem to work. The error message is as follows:

    Debug info:
    Error code: unsupportedsubplugin
    Stack trace:

    line 34 of /mod/assignment/mod_form.php: moodle_exception thrown
    line 191 of /lib/formslib.php: call to mod_assignment_mod_form->definition()
    line 71 of /course/moodleform_mod.php: call to moodleform->moodleform()
    line 268 of /course/modedit.php: call to moodleform_mod->moodleform_mod()

    We also have problems with some strings, but that's just a minor concern.
  • Picture of María José Blanes
    Thu, May 8, 2014, 7:08 PM
    Hi,
    nice plug-in!
    I have Moodle 2.6 and I can use it without problems in Firefox or Chrome, but in debug mode, I get a warning message and I don't know how to fix it:

    filter_text() is deprecated, use format_text(), format_string() etc instead.•line 474 of /lib/deprecatedlib.php: call to debugging()
    •line 195 of /mod/assign/submission/onlineaudio/locallib.php: call to filter_text()
    •line 284 of /mod/assign/submission/onlineaudio/locallib.php: call to assign_submission_onlineaudio->print_user_files()
    •line 240 of /mod/assign/assignmentplugin.php: call to assign_submission_onlineaudio->get_form_elements()
    •line 5752 of /mod/assign/locallib.php: call to assign_plugin->get_form_elements_for_user()
    •line 5833 of /mod/assign/locallib.php: call to assign->add_plugin_submission_elements()
    •line 48 of /mod/assign/submission_form.php: call to assign->add_submission_form_elements()
    •line 191 of /lib/formslib.php: call to mod_assign_submission_form->definition()
    •line 3188 of /mod/assign/locallib.php: call to moodleform->moodleform()
    •line 503 of /mod/assign/locallib.php: call to assign->view_edit_submission_page()
    •line 53 of /mod/assign/view.php: call to assign->view()


    In IExplorer 10, the "Settings.." button of the player doesn't work... so it's possible students can't give the system permission to access the microphone.

    Thanks for your work,
    Maria
  • Picture of Harlow Pinson
    Tue, May 13, 2014, 11:34 PM
    Problem with Moodle 2.7. White screen upon upload, and upon and subsequent views. This is in Chrome Version 34.0.1847.131 m and in Firefox 29.0.1.
  • Picture of Jason Barr
    Wed, May 21, 2014, 4:23 AM
    I am having a problem with this block in Moodle 2.6.2. It will record the audio but when we click the upload button I get this error:

    A required parameter (id) was missing
    More information about this error
    Debug info:
    Error code: missingparam
    Stack trace:
    • line 463 of /lib/setuplib.php: moodle_exception thrown
    • line 545 of /lib/moodlelib.php: call to print_error()
    • line 7 of /mod/assign/submission/onlineaudio/upload.php: call to required_param()

    I have tried explorer, chrome and firefox. I have tried an older version of flash and the latest version of flash too.
  • Picture of Paul Nicholls
    Tue, May 27, 2014, 7:32 AM
    Hi Jason,
    I've just released version 1.1.2, which should fix this issue.
  • Picture of Boris Puhanic
    Thu, Jun 19, 2014, 4:05 PM
    There seems to be an error in locallib.php which causes an error when trying to grade submissions. Line 180 refers to : require_once ... mod/assignment/locallib.php

    I think it should be ...mod/assign/locallib.php.
  • Picture of Toni Soto
    Tue, Jul 1, 2014, 7:09 AM
    Yes the error is fixed as soon as you change in /mod/assign/submission/onlineaudio/locallib.php (line 180):
    from...
    require_once($CFG->dirroot . '/mod/assignment/locallib.php');
    .. to ..
    require_once($CFG->dirroot . '/mod/assign/locallib.php');

    ... as Boris said.

  • me
    Tue, Jul 15, 2014, 3:40 AM
    Hello! We have just moved to 2.7, and installed this plugin for that version. We see the "microphone permission" request, we see the "recording buttons", but when we SAVE and then UPLOAD, we see a "Uploading, please wait....." message that never goes away. So we can complete the entire process, but not get the recorded file to upload. I am using Firefox 26.....is there something obvious that needs to be adjusted to eliminate this final stoppage to the assignment process?
  • Picture of Paul Nicholls
    Wed, Jul 16, 2014, 12:28 PM
    Thanks, Boris/Toni - I've just released v1.1.3 which fixes that reference (and two others) to the "old" mod/assignment plugin. Jim, this should fix your issue with it on 2.7 - please grab a copy from here or Github and you should be all sorted!
  • Picture of Joost Elshoff
    Sun, Aug 17, 2014, 2:48 PM
    Hi!
    I don't know whether this is a general problem with the Assignment activity or with the audio, but everytime I try submitting a recording or a written assignment , it returns a blank page.

    I use Moodle 2.6.2... how do I solve this?
  • George
    Sat, Oct 11, 2014, 1:47 AM
    Hello! I have moved to 2.7.2, and installed this plugin for that version. I did not see the "microphone permission" request, I did not see the "recording buttons" in assingments description page. I did not see anything from this plugin in the assignment's page. I am using Firefox 32.0.3. The I unistaled the plugin and now I have database problem. I can't backup the course I get ERROR message about 'error reading database'. The only way to have backup success is when in backup settings uncheck 'include activities' and 'include question bank' boxes.
  • Picture of Nacho Aguilar
    Wed, Oct 29, 2014, 9:50 PM
    Hi,

    When online submission is under ssl 443 https://url I have this error:

    The page at 'https://myschool/mod/assign/view.php?id=2972&action=editsubmission' was loaded over HTTPS, but displayed insecure content from 'http://www.adobe.com/images/shared/download_buttons/get_flash_player.gif': this content should also be loaded over HTTPS.

    Thanks

    Using Mooodle 2.7.1
  • Picture of Toni Soto
    Tue, Dec 16, 2014, 1:18 AM
    I'm in Moodle 2.7.2 and although I installed the last release 1.2.1. I can't get it to work. The message below appears when i try to submit the recorded file.

    The weird thing is that the same plugin, the same version, installed automatically in another instance on the same server works. I compare both installs and I didn't notice differences apart from that one (the one which fails) has Moodle installed in the root folder of the web server and the other (the one which works) is in a subfolder. I spent hours trying to figure out what's wrong but I'm lost. Any idea please?

    Debug info: Object of class assign_submission_onlineaudio could not be converted to string
    Error code: codingerror
    Stack trace:
    line 393 of /lib/setuplib.php: coding_exception thrown
    line 210 of /mod/assign/submission/onlineaudio/locallib.php: call to default_error_handler()
    line 423 of /mod/assign/submission/onlineaudio/locallib.php: call to assign_submission_onlineaudio->print_user_files()
    line 908 of /mod/assign/renderer.php: call to assign_submission_onlineaudio->view_summary()
    line 221 of /lib/outputrenderers.php: call to mod_assign_renderer->render_assign_submission_plugin_submission()
    line 679 of /mod/assign/renderer.php: call to plugin_renderer_base->render()
    line 221 of /lib/outputrenderers.php: call to mod_assign_renderer->render_assign_submission_status()
    line 3771 of /mod/assign/locallib.php: call to plugin_renderer_base->render()
    line 4064 of /mod/assign/locallib.php: call to assign->view_student_summary()
    line 540 of /mod/assign/locallib.php: call to assign->view_submission_page()
    line 53 of /mod/assign/view.php: call to assign->view()

    Thanks in advance

    Toni
  • Sudeep
    Fri, Jan 9, 2015, 3:54 PM
    I am using Moodle 2.2 and by using this plugin I can record audio and upload them on server.
    But the limitation is I can record upto 8 or 9 minutes only. Beyond that if I record it gets stuck whuile uploading and never gets back. i have no idea how to fix it. Is this a limitation of this plugin, or do I need to try something else? Please suggest someone please.
  • Picture of Paul Nicholls
    Mon, Jan 12, 2015, 4:49 AM
    Sudeep, that sounds like you might be hitting the upload size limit in the assignment, course and/or site. I'm not sure how that would be handled - but it might result in the symptoms you describe. If you have small limits on any of these levels, can you please try increasing the upload limits and see if it fixes it? If not, please post in the forums or the bug tracker (see link in plugin details) so that a proper dialogue can take place.
1 2 3
Please login to post comments