Your Moodle version

Other: ILP Block

Maintained by Picture of Richard Havinga Richard Havinga, Picture of Nigel Daley Nigel Daley
ULCC Individual Learning Plans (ILPs) Block
1k
3
Moodle 2.4, 2.5, 2.6
Individual Learning Plans (ILPs) are becoming central to the support and delivery of personalised learning by providing students with more opportunity to manage and track their own progress. With this in mind, ULCC has developed a fully integrated ILP solution for the Moodle Open Source VLE within inspection criteria outlined by the QIA. Using ULCCs ILP Block you can integrate it with information from external systems, including information for cause for Concerns / Success, attendance, punctuality, exam timetables, timetables, qualifications on entry and initial assessments. It is completely customizable where you can also add your own additional tabs to be displayed in the ILP home page as well.

Screenshots

Screenshot
Screenshot
Screenshot

Contributors

Picture of Richard Havinga
Richard Havinga (Lead maintainer): Learning Technologist
Picture of Nigel Daley
Nigel Daley: Lead Developer
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • MD shot of me from his iphone4
    Tue, May 21, 2013, 12:24 PM
    Hi Richard,
    I've just had a look through the bug tracker and the code itself.
    I'm seeing a 'ilp' folder now after expanding smile
    I think Anthony is concerned about the inclusion of the files (.buildpath, .idea/, .project). They seem to be in the github repository too. I also see a file db/create_preference which seems to contain php code. There is code (utilities) that is also mysql specific and doesn't use the moodle dml api which will hamper this being shared easily across platforms.

    I'll approve this now under other category. Hopefully this can evolve into something that can be more easily shared with the larger community (ie: coming out of others category and into blocks, reports etc).
  • ME
    Thu, Sep 12, 2013, 3:32 AM
    Richard,
    What is your timeline for upgrading this plugin to work with Moodle 2.5. We would like to get it installed for all Moodlerooms UK clients for our release in December, but we are getting a fair number of errors with Moodle 2.5
  • Picture of Richard Havinga
    Thu, Sep 12, 2013, 10:04 PM
    Hi Jason,

    We do currently have a version for Moodle 2.5 but we haven't made this public release yet as our clients get first access to it as they ultimately contribute to the support and development of it. I plan on releasing the latest version to the community after the new year so there will be a version available then. Keep your eyes posted on here and or the git repository.

    Thanks
  • My picture
    Thu, Sep 26, 2013, 1:15 AM
    Thank you very much for releasing an stable version for the community.
    Unfortunately, we are still in Moodle 2.2 and I saw that any previous version is not available. Is there any way of getting an stable version for Moodle 2,2
    Thank you
  • Picture of Richard Havinga
    Mon, Oct 7, 2013, 6:46 PM
    Hi Aaricia, this version of the plugin should work with 2.2 as well.
  • Picture of Jamie Leeke
    Mon, Dec 2, 2013, 9:52 PM
    Hi,

    We currently use the block for Moodle 1.9 and are looking to upgrade to Moodle 2.5 are we able to move the database over to keep all the entry's on our new Moodle?

    Thanks
  • Picture of bobby demers
    Mon, Dec 16, 2013, 10:14 PM
    Hi. Trying to install this plugin but I get the message of
    "There is a request to install an add-on from the Moodle plugins directory on this site. Unfortunately the request is not valid and so the add-on cannot be installed."

    Any ideas as to why this won't install?

    Cheers
  • Picture of Richard Havinga
    Mon, Dec 16, 2013, 10:28 PM
    Hi Bobby you will have to download it and place it into the blocks folder. The install button doesn't work which is why you are getting this message. Thanks
  • Picture of William Lu
    Tue, Feb 25, 2014, 12:00 PM
    I installed ILP Mango successfully on my Moodle2.6. Added a block inside a course successfully. Saw a table of report. But don't know how to edit the report inside the course. I can see a lot of editable fields in Admin>Block> ILP, too many fields to databases, don't know which one I should to change. Is this ILP design for integrating or displaying data from other institutes? I am in New Zealand now. Can I use it for my University? Thanks
  • Picture of Richard Havinga
    Thu, Feb 27, 2014, 9:11 PM
    Hi William, Sorry yes we haven't updated our publically facing documentation for some time (we plan to) but you can find enough info to get you started here: http://docs.moodle.org/21/en/ILP_block It does integrate to display data from other sources through the external plugins options in the settings including attendance and timetabling info through tables or stored procedures.
  • Picture of Tom Moseley
    Mon, Mar 17, 2014, 7:54 PM
    I've installed ILP Mango on my moodle 2.6 Install. Is there a way to get a summary view like you could on the 1.9 version that shows student info, targets and progress review entries all on the same page? Also any updated ETA on the documentation. Lots more features that we want to look at using but not quite sure how to at the minute. Thanks
  • ME
    Thu, May 22, 2014, 5:44 AM
    I installed the plugin in a 2.6 Base Moodle site and I am getting a bunch of missing language strings in the settings page as well as illegal page format statements. An example is:

    Invalid get_string() identifier: 'ilp_mis_attendance_percentbar_plugin_pluginnamesettings' or component 'block_ilp'. Perhaps you are missing $string['ilp_mis_attendance_percentbar_plugin_pluginnamesettings'] = ''; in /vagrant/www/stable/blocks/ilp/lang/en/block_ilp.php?
    line 293 of /lib/classes/string_manager_standard.php: call to debugging()
    line 6831 of /lib/moodlelib.php: call to core_string_manager_standard->get_string()
    line 100 of /blocks/ilp/plugins/mis/ilp_mis_attendance_percentbar_plugin.php: call to get_string()
    line 259 of /blocks/ilp/settings.php: call to ilp_mis_attendance_percentbar_plugin->config_settings()
    line 99 of /lib/classes/plugininfo/block.php: call to include()
    line 53 of /admin/settings/plugins.php: call to core\plugininfo\block->load_settings()
    line 6389 of /lib/adminlib.php: call to require()
    line 19 of /admin/settings.php: call to admin_get_root()

    Is there some where I can get these external plugins? None of the documentation references the need for plugins.
  • Picture of Nakul W
    Tue, Dec 2, 2014, 8:46 PM
    I am not able to install it for moodle 2.7, any help?
  • Picture of Mandy Connick
    Mon, Apr 20, 2015, 3:43 PM
    I am trying to add the ILP block to moodle 2.8 and getting invalid plug in name - is it not compatible with 2.8?
  • Picture of Neil Stapleton
    Mon, May 11, 2015, 8:17 PM
    Further to Mandy's comment... is there a timescale for 2.8 version Richard. I'm presuming there is a working version for 2.8, as you have already been migrating your customer to Moodle 2.8.
1 2
Please login to post comments