Maintained by Picture of Andreas GrabsAndreas Grabs
With this plugin you can define the debugmode for only some selected users.
1 fans
Current versions available: 1

Admin tool "User related debugmode"

Purpose:
With this plugin you can define the debugmode for only some selected users.
The main advantage of this is, that you can activate the debugmode just in a production environment without disturbing the regular work.
Only users who are defined as debuguser can see the debug informations.

Installation:
  1. Copy this plugin into the folder "admin/tool" inside your moodle installation.
  2. Go to the "Site administration -> Notifications" to start the install process.
  3. Important: Go to your "config.php" and add the following line at the end:
require_once($CFG->dirroot.'/admin/tool/userdebug/lib.php');

Usage:
After the installation you will find the new link "User related debugmode" below "Site administration -> Development"


Screenshots

Screenshot #0

Contributors

Picture of Andreas Grabs
Andreas Grabs (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • MD shot of me from his iphone4
    Mon, Oct 8, 2012, 12:05 PM
    http://tracker.moodle.org/browse/MDL-34632 was created for this case. Feel free to contribute any discussion or patch there smile
  • Germán and temudgin
    Tue, Oct 16, 2012, 2:29 AM
    This user_related_debugmodus plugin is great. I also think this plugin should go into Moodle core. It will help admins while it does not unnecessarily disturb regular users in a production environment. I only wished I had seen it before.

    Maybe the plugin developer-maintainer could send an Email to Martin at Moodle HQ or/and to Moodle developers, or post a suggestion in Moodle Tracker.
  • Picture of Tony Hewes
    Mon, Oct 1, 2018, 5:23 PM
    This really amazing plugin that I was looking from many others tools but it's need to updates more by clicking on https://customessaysreviews.com/paperwritings-com-review/ website for useful task. Thank you
  • Picture of Ryley Rush
    Fri, May 17, 2019, 9:45 PM
    When I put require_once($CFG->dirroot.'/admin/tool/userdebug/lib.php'); Moodle crashes. When I change even one symbol it doesn't crash but obviously, the plugin doesn't work.
    I use Moodle for my team of writers at
  • Picture of Andreas Grabs
    Fri, May 17, 2019, 11:32 PM
    Hi Ryley, thanks for trying out this plugin. The require_once line has to be appended after the line with require_once(__DIR__ . '/lib/setup.php');
    --- config.php ---
    require_once(__DIR__ . '/lib/setup.php');
    require_once($CFG->dirroot.'/admin/tool/userdebug/lib.php');

Please login to post comments