Admin tools: Capability explorer

tool_capexplorer
Maintained by Simon CogginsSimon Coggins
An admin tool designed to help Moodle administrators understand how Moodle's capability system works.

Capability explorer v1.0.4

Release notes

Capability Explorer
===================

Capability Explorer is a tool to help explain how Moodle's capability system
works. Select a user, capability and context and you'll get a detailed
explanation of how that capability check is calculated by the system.

Minimum requirements
====================

Currently, due to the YUI treeview dependency, this plugin requires
Moodle 2.7+. It should be possible to backport to any 2.x version by including
the treeview library in the module.

Note: This plugin does not current support sites that use MNet.

Installation
============

Install this plugin into the admin/tool folder, in a subfolder called
capexplorer, then visit the Site Administration > Notifications page to
install.

You can then access the tool via:

Site Administration > Users > Permissions > Capability Explorer

For full documentation and screenshots, see:

http://docs.moodle.org/en/Capability_explorer

Bug reports
===========

Please submit any bug reports or feature suggestions via the Moodle Tracker:

http://tracker.moodle.org/browse/CONTRIB

License
=======

Created by Simon Coggins.
License GNU GPL v3 or later. http://www.gnu.org/copyleft/gpl.html

Moodle 2.7, 2.8, 2.9, 3.0, 3.1

Version information

Version build number
2016081100
Version release name
v1.0.4
Can be updated from
1.0.0 (2013100100), v1.0.1 (2013100100), v1.0.2 (2013100100), v1.0.3 (2015110200)
Maturity
Stable version
MD5 Sum
7337fbc23ad1072cb3a99330c54cca79
Supported software
Moodle 2.7, Moodle 2.8, Moodle 2.9, Moodle 3.0, Moodle 3.1
  • This is the latest release for Moodle 2.7
  • This is the latest release for Moodle 2.8
  • This is the latest release for Moodle 2.9
  • This is the latest release for Moodle 3.0
  • This is the latest release for Moodle 3.1

Version control information

Version control system (VCS)
GIT
VCS repository URL

Default installation instructions for plugins of the type Admin tools

  1. Make sure you have all the required versions.
  2. Download and unpack the module.
  3. Place the folder (eg "mytool") in the "admin/tool" subdirectory.
  4. Visit http://yoursite.com/admin to finish the installation