xAPI Launch Link

Activities ::: mod_tincanlaunch
Maintained by David Pesce
Launch external xAPI (Tin Can) activities from Moodle and track on a Learning Record Store (LRS). Compatible with Storyline, Captivate, and others!
Latest release:
373 sites
328 downloads
51 fans
Current versions available: 1
This plugin allows the launching of xAPI activities from a Moodle course and tracks the resulting xAPI statements with an external Learning Record Store (LRS). This plugin is compatible with activities implementing the Rustici launch method. This includes content created with Articulate Storyline or Adobe Captivate (among others). 
 
Suggestions, bug reports, code reviews, and contributions are welcome! Please don't add comments or questions here. Use Github instead: https://github.com/davidpesce/moodle-mod_tincanlaunch/issues

Note: In an effort to focus our resources on this project, only supported Moodle and PHP versions will be developed and tested against. That is currently Moodle 3.5, 3.7, 3.8, and 3.9. For PHP that is 7.2-7.4. As support drops from the providers of these items, we will drop support as well.

Sets

This plugin is part of set Tin Can.

Screenshots

Screenshot #0
Screenshot #1
Screenshot #2

Contributors

David Pesce (Lead maintainer)
Andrew Downes: ex-maintainer
Please login to view contributors details and/or to contact them

Comments RSS

Afficher les commentaires
  • Paul
    jeu, 7 sep 2017, 14:28
    Hi Andrew,
    I'm sorry if I've asked you this else where, but there seem to be a multitude of Tin Can plugins on Moodle, and for me this complicates things.

    I'm now running a Moodle 3.3 platform and was wondering, will the 3.2 version of your plugin work on 3.3?

    If not, do you have any idea when a 3.3 version will be ready?

    Many thanks, and take care.
  • ven, 6 oct 2017, 03:00
    Hi Andrew,

    First of all, thanks for this great plugin, it's exactly what my organization has been looking for.

    But I'm having a problem with it - I've connected it to my LRS (grassblade) and have been able to send statements successful from my moodle manager account, but when a student attempts to create a new registration they get an error message that says "This course is currently unavailable to students".

    Is this something you've seen before?

    Thanks
  • sam, 28 oct 2017, 01:49
    Is there a way to make the videos to resume where user left off?
  • ven, 23 fév 2018, 18:00
    To everybody asking questions here, note that I don't check this page regularly. If your questions are still relevant, please email andrew.downes@watershedlrs.com or even better, log an issue on the github site.
  • mar, 30 oct 2018, 19:18
    I'd like to install the tincanlaunch plugin on my installation of Moodle (v. 3.5) but I don't know if the plugin supports moodle version 3.5. Indeed, if I try to install the plugin from the official site I do not see the "install now" option. Is it a compatibility issue?
  • mar, 30 oct 2018, 20:33
    @Stefano - this is the official site isn't it? There's no reason why this plugin should not work in versions of Moodle above 3.4. However please note that I'm actively working on this plugin over the next few weeks, so you can expect a new release to fix a lot of bugs. Please help by testing the version on the master branch at github and logging any issues.
  • mar, 30 oct 2018, 21:57
    Ok, thank's for your reply. Yes, I'm referring to this site and this page ( where are mentioned Moodle 3.0, 3.1, 3.2, 3.3, 3.4 and NOT 3.5). If I click on the "Install now" button a page is loaded showing all my moodle installations (the first one installed on my local pc running version 3.0 where I can view the "Install" button and the second one remotely installed running 3.5 version where the button "Install now" doesn't appear. Maybe I need to install the plugin manually.
  • jeu, 6 fév 2020, 14:09
    Hi, is the current version available in the download link the most updated version? Trying to test the plugin in our moodle but a little hesitant since we are using Moodle 3.8. Can anyone help?
  • jeu, 3 jun 2021, 17:56
    Hi everyone. First of all, congratulations with the plugin.
    I have a question. I dont know how to report my own verbs. i use the plugin and all of my own verbs like "passed","checked","completed" become in default verbs like "experienced" or "attempted".
    is possible to report custom verbs? Can you explain me how to do to report with the plugin my own verbs?
    Thanks.
  • ven, 17 déc 2021, 15:24
    Hi everyone, does somebody know how to use this plugin in modle cloud.
    thanks in advance.
  • ven, 22 avr 2022, 03:51
    Hi. The plugin has been installed in our LMS but when we try to upload an xAPI file we get this error:
    The Learning Record Store is not available. Please contact a system administrator. If you are the system administrator, go to Site admin / Development / Debugging and set Debug messages to DEVELOPER. Set it back to NONE or MINIMAL once the error details have been recorded.

    We have contacted our administrator but they don't know what is going on. Does anyone know what we might be doing wrong or if there is a bug somewhere?
  • ven, 22 avr 2022, 04:12
    Hi Dianna.

    Two things to check:

    1. Did the admin set debug messages to DEVELOPER, try and launch the course and note down the full error message? What was that error?

    2. Did you check that all the settings were populated correctly? We're there any settings where you were unsure what to put?

    3. Are you using a fully conformant LRS? What happens if you connect the plugin to a free Watershed Essentials or SCORM Cloud account?
  • mar, 10 mai 2022, 11:57
    Hi, I was wondering if you might be so kind as to give me a little advice on how to use the Tin Can Launch Link activity in Moodle in a more user friendly way? In its basic form, xAPI packages can be launched from an activity via a number of clicks (first on the Activity, then on the 'launch' link). Is it possible to somehow have the Activity launch the xAPI course/ package immediately upon first click without the screen that shows 'First launched', 'Last launched', 'launch' etc.?
  • mer, 11 mai 2022, 02:24
    Hi Peter - take a look at this pull request: https://github.com/davidpesce/moodle-mod_tincanlaunch/pull/208

    It may have what you're looking for.
1 2 3 4
Please login to post comments