General plugins (Local): Compatibility Test

local_compatability_test
Maintained by Picture of Chris Clark Chris Clark, Jeremy self portrait Jeremy FitzPatrick
This local plug-in provides the functionality to check the users browser (Chrome, Firefox, Opera, Safari), Flash, Java, Quicktime and/or Silverlight version against a pre-set minimum version and notify the user that they are not meeting the sites minimum requirements.
21 sites
10 downloads
8 fans

This local plug-in provides the functionality to check the users browser (Chrome, Firefox, Opera, Safari), Flash, Java, Quicktime and/or Silverlight version against a pre-set minimum version and notify the user that they are not meeting the sites minimum requirements.

Additionally the user can be forced to only view the Plug-in status page while they do not meet the minimum requirements.

Developed by LearningWorks Ltd

Screenshots

Screenshot #0
Screenshot #1
Screenshot #2
Screenshot #3
Screenshot #4

Contributors

Picture of Chris Clark
Chris Clark (Lead maintainer)
Jeremy self portrait
Jeremy FitzPatrick
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of Chris Clark
    Wed, 4 Feb 2015, 4:43 AM
    Hi Marc,

    Do you see the banner that appears with the following message:

    "Your browser and/or plugins are not up to date. Click here for more information."

    If not then there may be an issue with the compatibility you're trying to check for.

    If it's not appearing and you believe it should be, can you double check what settings you're testing compatibility for and try again.

    To force the redirect when a user does not satisfy the criteria you need to enable the setting:

    Force View Status Page

    This will not redirect site administrators, but will affect other users as soon as they access any page of the site other than the login page.
  • Picture of Mr. Marc
    Thu, 5 Feb 2015, 3:31 AM
    Chris Clark,
    Thank you for your reply. I have all check boxes checked in the setup and login to our site but never get the compat page. I have created a link to it in a HTML bolck and when I click on the link it does work but doesnt give the correct information about the browsers??
  • Picture of Mr. Marc
    Thu, 5 Feb 2015, 3:31 AM
    I can send you a screen shot of the config and page report?
  • Picture of Chris Clark
    Thu, 5 Feb 2015, 4:12 AM
    Hey Marc,

    Yes screenshot would be very helpful thanks, also can you ntoe the moodle version and anything else that may be useful - OS, browser etc
  • Picture of Mr. Marc
    Thu, 5 Feb 2015, 4:14 AM
    how can i send it to you ?
  • Picture of Mr. Marc
    Thu, 5 Feb 2015, 4:21 AM
    we are using Moodle 2.6.2+ (Build: 20140403) on Centos 6.5 64 bit version, trying this on a windows machine i have all browsers install testing it on an old version of safari and IE.
  • Picture of Mr. Marc
    Thu, 5 Feb 2015, 4:35 AM
    matthes134atgmail.com
  • Picture of Mr. Marc
    Fri, 13 Feb 2015, 5:28 AM
    Is there a way to make this message to display big and bold? So it catches their attention.

    Your browser and/or plugins are not up to date. Click here for more information.
  • Picture of Aaron Leggett
    Fri, 20 Mar 2015, 5:27 AM
    Hi Mr Marc.
    I have emailed you requesting the screenshots and further information on the issues you are experiencing.
    Thanks for helping us improve this plugin for the community.

    Aaron
  • Picture of Mr. Marc
    Sat, 28 Mar 2015, 12:33 AM
    Sorry Aaron never got an email?
  • Picture of Aaron Leggett
    Tue, 7 Apr 2015, 5:49 AM
    Hi Mr Marc,
    I have sent the email to the address you supplied as below.
    matthes134@gmail.com

    Please advise if this is correct
  • Picture of Mr. Marc
    Tue, 7 Apr 2015, 5:57 AM
    Yes that is correct Aaron, it looks like our SSO that is using an iframe in the header is causing the issues with the compatibility checker to run.
  • Picture of Chris Mat
    Fri, 14 Aug 2015, 8:31 PM
    Hi Chris and Aaron,

    Thanks for this amazing plugin. I installed it on Moodle 2.8, it doesn't display the notification if I checked against browsers only. I have to check one of the plugins (Java, flash, etc.) to work. Unfortunately, I don't need to check any of the plugin. How we can fix that?

    Also, could you please add checking against IE because most problems comes from older version of IE.

    Thanks
    Chris
  • Picture of Elizabeth Dalton
    Tue, 20 Oct 2015, 1:18 AM
    Is this plugin compatible with Moodle 2.9? I was able to get the plugin to install with a success message, but I can't get it to display the message for a user no matter what I set the requirements to. I've tried three different themes: Flexipage, More, and Clean.

    It seems like a really useful plugin in concept, but we would prefer a block display and the ability to check IE versions as well as the others. (Actually, we'd prefer to tell users if they are using anything OTHER than a recent version of Firefox to switch.)
  • Picture of Andrew Shaw
    Thu, 18 May 2017, 4:06 PM
    I'm presuming this plugin is no longer maintained? It falsely reports we don't meet the requirements yet it states in the View Status Page we are on higher versions than required, also doesn't take into account Chrome flash either. Using Moodle 3.0.1.

1 2
Please login to post comments