SAML Enrolments

Enrolment ::: enrol_saml
Maintained by Sixto Martin Garcia
SAML Enrol plugin based on the simplesamlphp software. (require Authentication SAML and simpleSAMLphp SP)

SAML Enrolments enrol/saml version of 20-07-2015

Moodle 2.3, 2.4, 2.5, 2.6, 2.7, 2.8, 2.9
Released: Tuesday, July 21, 2015, 12:54 AM
SAML Enrollment for Moodle
-------------------------------------------------------------------------------
license: http://www.gnu.org/copyleft/gpl.html GNU Public License

Changes:
- 2010-11: Created by Yaco Sistemas.
- 2013-10: Maintained by Sixto Martin: https://github.com/pitbulk/moodle_saml

Requirements:
- SimpleSAML (http://rnd.feide.no/simplesamlphp). Tested with version > 1.7
- SAML Authentication for Moodle module

This plugin require a simplesamlphp instance configured as SP
(http://simplesamlphp.org/docs/trunk/simplesamlphp-sp)

Tested in moodle2.0.3, 2.1.2, 2.2.3

Install instructions:

Check moodle_enrol_saml.txt


Important for enrollment!!
==========================

This plugin suppose that the IdP send the courses data of the user in a attribute that
can be configured but the pattern of the expected data is always:
:::
You can change this pattern editing the file auth/saml/course_mapping.php

Version information

Version build number
2015072001
Version release name
enrol/saml version of 20-07-2015
Maturity
Beta
MD5 Sum
5d4dff0250c5e7661ebb4b7cc0ae28f5
Supported software
Moodle 2.3, Moodle 2.4, Moodle 2.5, Moodle 2.6, Moodle 2.7, Moodle 2.8, Moodle 2.9

Version control information

Version control system (VCS)
Other...
VCS repository URL

Default installation instructions for plugins of the type Enrolment

  1. Make sure you have all the required versions.
  2. Download and unpack the module.
  3. Place the folder (eg "myenrol") in the "enrol" subdirectory.
  4. Visit http://yoursite.com/admin to finish the installation