Restriction by password

Availability conditions ::: availability_password
Maintained by Ulm University, Alexander Bias, Kathrin Osswald, Luca Bösch
Moodle availability plugin which lets users restrict resources and activities with password access
Latest release:
879 sites
338 downloads
48 fans
Current versions available: 12

There may come the day in a Moodle admin's life when a teacher requests to protect his course resources from unauthorized access even beyond the mechanisms which Moodle already provides and when this teacher comes up with the idea of adding a "password protection" to uploaded resources. If you had a discussion like this, this plugin is for you.

Please see README file for details about the usage and features of this plugin.

No support in the comments section on this page

Please note that we don't provide any support for this plugin in the comments section on this page anymore.

We appreciate your commendation and reviews for this plugin in the comments. For bug reports and support requests, please read the extensive information in the plugin's README file first and create, if needed, a ticket in the bug tracker which is linked below.

Thanks for your cooperation.

Screenshots

Screenshot #0

Contributors

Ulm University (Lead maintainer)
Alexander Bias: Maintainer
Kathrin Osswald: Developer
Luca Bösch: Maintainer
Davo
Davo Smith: Initial Developer
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Thu, Jan 28, 2016, 3:06 AM
    I've uploaded a new version hopefully fixing the prechecker results
  • Thu, Jan 28, 2016, 3:45 PM

    No worries guys. Prechecker results are meant as rough information about the overall coding style compliance. We do not discriminate solely on them, and we are aware of limits and some bugs (false positives) there.

  • Thu, Jan 28, 2016, 5:31 PM

    BTW see CONTRIB-6025 for more info on the situation about inline phpdocs.

  • Thu, Feb 4, 2016, 4:26 AM
    Very well done.
    Nicely written plugin, works as expected, nice documentation (you might want to fix the typo "Due to limited ressources").
    We definitely want this in plugins DB asap!
  • Thu, Feb 4, 2016, 4:59 AM
    Thanks for the praise and thanks for pointing me to the typo (caused by my german mother's tongue where resources is written with 2 "s") smile
  • Thu, Feb 4, 2016, 5:07 AM

    Thanks Tomek for the peer-review. I am happy to approve the plugin now. Welcome to the Plugins directory!

  • Fri, Dec 9, 2016, 10:20 PM
    Hi, works also on Moodle 2.9 ?
  • Davo
    Sun, Dec 11, 2016, 5:30 AM
    This plugin was developed against Moodle 3.1 - it might work with earlier versions of Moodle, but you would have to edit the $plugin->requires line in version.php, otherwise Moodle will refuse to install it.
  • Tue, Jul 4, 2017, 12:16 AM
    Alexander, thanks, great plugin. Very useful. Should be very popular.
    I use it to limit students access to a chat room.
  • Thu, Nov 7, 2019, 10:50 PM
    Does the password prompt appear for admins as well?
  • Tue, Dec 31, 2019, 2:42 PM
    Hi and congratulations on your good work.
    I have noticed though that the plugin does not appear on whole sections (the options for restricting by password is missing in editsection) while other restriction plugins (for ex by ip) appear everywhere.
    Can this be added?

    Regards,
    Lazaros
  • Mon, Jan 13, 2020, 12:34 AM
    It's a great idea but is there any chance it could work with the tiles theme. It says its passworded but no ability to enter the password.
  • Wed, Jan 13, 2021, 5:21 AM
    Great to see some movement. We are on 3.10+ and looking forward to using this plugin again.
  • Fri, Feb 5, 2021, 7:32 PM
    Which part of the code is used to store the password value in the database and in which table?
    Also please contact me because I want to use your plugin
    00201283254553
1 2
Please login to post comments