Atto: Ruby / furigana

atto_ruby
Maintained by Picture of Jetha Chan Jetha Chan
Ruby phonetic support for Atto.
8 sites
8 downloads
4 fans

Ruby support for Atto! This plugin contains an Atto toolbar button that simplifies annotating text with phonetic information - select some text, click the button and add the pronunciation of the text in question.

Notice This plugin requires Moodle 2.8.8 or Moodle 2.9.2 or greater.

Screenshots

Screenshot #0

Contributors

Picture of Jetha Chan
Jetha Chan (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of Jetha Chan
    Fri, 17 Jul 2015, 11:36 PM
    This plugin has a soft requirement of MDL-50868 (https://tracker.moodle.org/browse/MDL-50868) - you can create ruby tags with this and they'll be stored in the DB okay, but HTMLPurifier will nuke them before they get to the browser.
  • Picture of David Mudrák
    Fri, 24 Jul 2015, 3:35 AM

    Thanks Jetha for sharing the plugin with Moodle community. As it seems that the current Moodle versions would require a custom patch to sort out MDL-50868, I have to move this temporarily into the Experimental category. Note that certain features (such as available updates notifications) may not be available for plugins there. Please, once the situation with the core support is sorted out, let me know so that we can move the plugin into the proper Atto category.

    You are cleared to land now, welcome to the Plugins directory!

  • Picture of Jetha Chan
    Thu, 13 Aug 2015, 11:20 AM
    Hey David - now that MDL-50868 has landed, I've released a v1.0 of this plugin with correct $plugin->requires information. If it meets your approval it'd be great to see this moved out of the Experimental category. smile
  • Picture of David Mudrák
    Thu, 13 Aug 2015, 10:42 PM

    Thanks Jetha, done.

Please login to post comments