General plugins

 
 
Picture of Michael Veit
Re: Slideshow module again
 

In another slideshow it is always the extension ".PNG". There are images with this extension but not all. The images have different extensions. The position of the image (postion 1, 2, 3, ...) with the displayed extension is different, not always the same.

 
Average of ratings: -
Picture of PBSL John
Re: Slideshow module again
 

Do you mean that the images with different extension aren't displaying? Were they displayed in previous versions (Paul Vaughan or James Barrett's)? I think the module expects all images to be the same format, allowing multiple formats might be quite a big change; I'll have a look tomorrow.

 
Average of ratings: -
Picture of Michael Veit
Re: Slideshow module again
 

Thumbnails/(Imagees) with different extension in the same slideshow don't be displayed in the caption page. In the slideshow modules (for moodle 1.X) from James Barrett the thumbnails in the caption page have been produced by the database information: slideshow_captions --> image and the html code ".jpg". This worked as long as only jpg file extension were accepted.

In the version for moodle 2.x there weren't thumbnails on the caption page.

If you can solve it, it would be a fine thing.

In my version I changed the database record in the table slideshow_comments in the field image. If it is a new slideshow, the filename is written with extension. If it is a old slideshow, the thumbnails in the caption page are also displayed. Wether the change is applied to the database depends on the server. Maybe it could be also a solution for you.

 

 
Average of ratings: -