Moodle for mobile

Custom styles not loading

 
Picture of Andrew Earley
Custom styles not loading
 

Hi, my moodle version is 3.5.3.

I am trying to add a custom styles for MoodleMobile but this does not work.

When I type the URL into the browser it is visible.

When using mobileapp.moodledemo.net, inspecting shows that the stylesheet being used is "build/main.css".


 
Average of ratings: -
Picture of Isabel Renedo
Re: Custom styles not loading
 

Hi Andrew,


Can you check if you followed the documentation https://docs.moodle.org/35/en/Moodle_app_guide_for_admins#Customise_your_app_theme?


If you followed it, and it is still not working as expected please indicate us version of the Moodle App as well as device and its Operative System and version (e.g. Android 8, iOS 12, Windows 10, ...) are you using.


Kind regards,

Isabel

 
Average of ratings: -
Picture of Andrew Earley
Re: Custom styles not loading
 

Hi Isabel,

Thank for the reply.

I have an apology to make, I had assumed that this would also work on the demo (https://mobileapp.moodledemo.net/) which I thought was just a web version of the app.


I assume this is not the case as my styles do not take affect, they however have taken affect when checking an android device.

 
Average of ratings: -
Picture of Dani Palou
Re: Custom styles not loading
Core developersMoodle HQParticularly helpful MoodlersPlugin developers

Hi Andrew,

in order for the styles to work in the webapp (mobileapp.moodledemo.net) you need to disable CORS in your browser:

https://docs.moodle.org/dev/Moodle_Mobile_development_using_Chrome_or_Chromium#Installation

Kind regards,

Dani

 
Average of ratings: -