Moodle for mobile

Google email: Android API 26 required

 
Picture of Rekha C
Google email: Android API 26 required
 

I received this email from Google play today.

I have an android custom app made in September 2017 which requires 4.1 and up -Google says it is API 19   20190.

a) What do these mean? 

b) When i next update my app, will Google Play allow ?


Hello Google Play Developer,

This is a reminder that starting November 1, 2018, updates to apps and games on Google Play will be required to target Android Oreo (API level 26) or higher. After this date, the Play Console will prevent you from submitting new APKs with a targetSdkVersion less than 26.

Configuring your app to target a recent API level ensures that users benefit from significant security and performance improvements, while still allowing your app to run on older Android versions (down to the minSdkVersion).

Action required

Please ensure that your apps are configured to target at least Android 8.0 (API level 26) by November 1, 2018. For technical advice on how to change your app's target API level to meet these requirements, refer to the migration guide.

Affected apps

The apps included below have one or more APKs—in production or testing tracks—that aren't currently targeting API level 26 or higher. Apps are listed with the maximum version code and corresponding targetSdkVersion. If you have more than 20 apps that could be affected in your account, please check the Play Console for a full list.


Links in email:

https://android-developers.googleblog.com/2017/12/improving-app-security-and-performance.html

https://www.google.com/appserve/mkt/p/APDk4sMFWJ9a1ff13ZhfqPaMCqkrFYsVTZkyWzPYZBhEIxtP6fJvv5HEX9YQ86NEWweXwTe-4wfwtbXwvslgHNeGwycdTpS79eIineOtnUiPkQ2kW_3UmzL0YQmYcVwVTPFAhx7pQvI9oQWMXIBp


Rekha

 
Average of ratings: -
Picture of aykut ozkaya
Re: Google email: Android API 26 required
 

I am having the same problem. API 26 is the lowest sdkTarget they will allow from this autumn but you can not release anything below that requirement to the play console from yesterday. Please let me know if you find a solution. 

I am planning to change the version value to 26 from 19 in line 25 of the cofig.xml file


<preference name="android-minSdkVersion" value="19" />


However i am expecting lots of errors when building.


Any suggestions or solutions will be appreciated


Thanks


 
Average of ratings: -
Picture of Dani Palou
Re: Google email: Android API 26 required
Core developersMoodle HQParticularly helpful MoodlersPlugin developers

Hi,

this also affects the official app, so we'll fix it in our repository before the deadline. However, please notice that we build using Phonegap Build, so we'll focus on fixing it in there first.

Kind regards,

Dani

 
Average of ratings: -
Picture of aykut ozkaya
Re: Google email: Android API 26 required
 

Thanks Dani

Will you update us when this is fixed so that we try again.


 
Average of ratings: -
Picture of Dani Palou
Re: Google email: Android API 26 required
Core developersMoodle HQParticularly helpful MoodlersPlugin developers

I created this issue, I recommend you to watch it:

https://tracker.moodle.org/browse/MOBILE-2547

 
Average of ratings: -
Picture of Rekha C
Re: Google email: Android API 26 required
 
aykut ozkaya, Could you fix by changing the one line code?


I have to fix in 3.2 version (because i don't have github for 3.3 or 3.4)

Dani, do tell me how i can fix to get SDK 26.

The 3.5 app is defective, hence trying to downgrade the app.


Rekha

 
Average of ratings: -
Picture of Dani Palou
Re: Google email: Android API 26 required
Core developersMoodle HQParticularly helpful MoodlersPlugin developers

We don't compile that version anymore, so I can't help you with that.

 
Average of ratings: -
Picture of Rekha C
Re: Google email: Android API 26 required
 

Can you send me github zips of 3.3 and 3.4 ?

You have those and don't have to do anything like compile.

I did not download those from github then and need them desperately and urgently now.

SDK 26 and above was okay, not necessarily 26

 
Average of ratings: -
Picture of Dani Palou
Re: Google email: Android API 26 required
Core developersMoodle HQParticularly helpful MoodlersPlugin developers

I'm sorry, but I don't have those zip files. Github (git) has a history, you can search the commit or tag you're interested in and download the zip file with that code.

 
Average of ratings: -